LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-11-2005, 01:15 PM   #1
rpb
Member
 
Registered: Mar 2005
Location: the thrid rock from the sun
Distribution: Red Hat 8, FC 3
Posts: 31

Rep: Reputation: 15
XServer: xauth: (stdin):1: bad display name


hello geeks,

there were many threads with the error message as mentioned in the subject line, but none suited my problem. below i describe it..

i am conneting to a machine thru ssh, which is located in a subnet within our LAN. recently our machines underwent a changeover in IP addresses.

it allows me to login to the machine, but on login, i get the following error message:

/usr/X11R6/bin/xauth: (stdin):1: bad display name "ia64:10.0" in "add" command

and no application which requires X server works. for example, xpdf gives the following error:

_X11TransSocketINETConnect: Can't get address for ia64
LTK Error: Cannot connect to X server ia64:10.0

i reckon ia64 has something to do with the hostname, but my reckoning stops there.

kindly help..

thanks,
rpb
 
Old 03-12-2005, 12:01 PM   #2
rpb
Member
 
Registered: Mar 2005
Location: the thrid rock from the sun
Distribution: Red Hat 8, FC 3
Posts: 31

Original Poster
Rep: Reputation: 15
problem sovled....

in the remote system, i set the env variable

$setenv DISPLAY localhost:0.0

now the x-server applicaions work. but i still get the error message..guess this setting has to be done at the global level, anyway i dont have root permission for that machine.
i really dont know what the above changes mean. i got it by some trial and error...hope to understand it soon..

thanks,
rpb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Display Problem jplanteen Linux - Hardware 1 05-29-2005 05:33 PM
Xserver multiple display classical question anup_clemson Mandriva 1 03-08-2005 03:06 PM
No Xserver display with Radeon 3.7.0 drivers and kernel 2.6.1 slimshady165000 Slackware 16 03-08-2004 03:30 PM
bad font display in man pages (rh8.0) moorege Linux - Software 1 09-14-2003 04:47 AM
Why do fonts display so bad in Linux?? frankencat Linux - General 5 09-19-2002 12:47 PM


All times are GMT -5. The time now is 06:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration