LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-17-2005, 03:29 AM   #1
Rodolfo Medina
Member
 
Registered: Nov 2004
Posts: 61

Rep: Reputation: 15
Using chown, chgrp, chmod on a vfat partition?


Hi.

In my Linux-Windows dual boot system MS Windows is under the /mnt/windows directory.
It is a vfat partition, and vfat file systems lack of support for
unix-style permissions, so I don't manage to normally use the `chmod',
`chown' and `chgrp' commands within that directory.
Does anybody know if there is a way
to make those commands work also in a vfat partition?

What I want is to store mail in /mnt/windows. To do so, my mail agent
is using chmod as a security precaution
(to ensure that my messages are not readable by anyone other
than myself), and so it has problems with the vfat file system /mnt/windows.
I worked the problem out by specifing uid=501 and gid=501 in /etc/fstab;
but then no other user than 501 (me) will be able to put his/her mail
into /mnt/windows.

I hope I was clear enough.
Any suggestion?

Rodolfo
 
Old 08-17-2005, 05:21 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
You can use 'umask' in /etc/fstab to specify default permissions for the partition. such as 777 or whatever, so that everyone can use it. Yes, you can use specific guid etc, but you can't really do much with individual folders on the FAT partition. if you see what i mean - it's the whole partition or nothing.

unless someone would correct me ;-)
 
Old 08-17-2005, 06:46 AM   #3
Rodolfo Medina
Member
 
Registered: Nov 2004
Posts: 61

Original Poster
Rep: Reputation: 15
Thanks.

I see: the whole partition or nothing.
Then the question becomes:
would it be possible to change my MS Windows vfat partition
into another kind of partition, e.g. the same kind of
the other linux partitions I have on my hard disk
(Journalised FS ext3, if I remember well?), that does not
have such problems?

Rodolfo
 
Old 08-17-2005, 07:18 AM   #4
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
no, unfortunatley not. MS Windows will only run on FAT or NTFS partitions.


I think the best way to tackle this is to see how/why your mail agent is checking file permissions. It won't actually be using 'chmod' as this changes ownerships. Is it checking for ownership of directories that is saves mail into or something?


Can this be disabled?
 
Old 08-17-2005, 07:34 AM   #5
Rodolfo Medina
Member
 
Registered: Nov 2004
Posts: 61

Original Poster
Rep: Reputation: 15
My mail agent (gnus) is checking file permissions in order to prevent other users
to read my mail: it takes off read and write permissions to users different from
`me' onto the files it creates, I'm not sure about directories.
So, this can't be disabled, or anyway it wouldn't be right for its `philosophy',
and also for practical reasons.

The ownership change could maybe work the problem out though,
because if I could change the ownership of a certain directory
then I could maybe play with chown, chgrp and chmod until I worked it out.
Instead, the chown command does not work for /mnt/windows.

But maybe an NTFS partition would work better?
I know there are writing problems with it, but maybe they can be
solved?

Rodolfo
 
Old 08-17-2005, 07:42 AM   #6
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
NTFS doesn't work well with linux i'm afraid. And FAT is inherintly unsecure. So, i'm not sure what your options are here. maybe create separate partitions for your mailboxes. Although this a hudge kludge of course........
 
Old 08-17-2005, 08:00 AM   #7
Rodolfo Medina
Member
 
Registered: Nov 2004
Posts: 61

Original Poster
Rep: Reputation: 15
Well, thanks indeed for your help!

Rodolfo
 
Old 08-17-2005, 08:17 AM   #8
Rodolfo Medina
Member
 
Registered: Nov 2004
Posts: 61

Original Poster
Rep: Reputation: 15
Maybe a partial solution:
the user who's fecthing mail could first set the ownership of /mnt/windows
with the `mount' command with its options `uid' and `gid'.
Could anyone suggest the right syntax for that?
I didn't manage to find it out from the mount manual.

Rodolfo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chmod ,chown ,chgrp commands not working proper---------------- pal Linux - Newbie 12 03-07-2005 09:55 AM
chmod ,chown ,chgrp------------ pal Linux - Newbie 1 02-27-2005 02:49 PM
chown, chgrp Help Icarus1701 Linux - Newbie 1 10-25-2004 06:42 PM
can i chmod/chown vfat partition demmylls Linux - General 6 01-17-2004 10:07 PM
problems with chown and chgrp apax Linux - Software 6 11-03-2003 03:44 PM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration