LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 11-27-2011, 08:01 PM   #1
dorianrenato
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
Unhappy unpredictable "delete" "move to trash" or "cut" file menu option


each time that i navigate and select one or multiple files the options "delete" "move to trash" or "cut" are randomly disabled to enabled i must go to other folder and only when return the options are available i use fedora14 x86_64 kde and have rw permissions on the partition the fstab entry for the partition is:

/dev/sda13 /media/multm ntfs-3g defaults,noatime,gid=501,gmask=007 0 0


i have tested in dolphin and konkeror with the same behavior, please help
 
Old 11-27-2011, 09:16 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,254

Rep: Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559
This sounds awfully like it might be permission related. Is /media/multm a shared directory?

The next time it happens, try opening a terminal and running ls -l on the items in question to see whether that turns up anything.
 
Old 11-28-2011, 10:00 AM   #3
dorianrenato
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by frankbell View Post
This sounds awfully like it might be permission related. Is /media/multm a shared directory?

The next time it happens, try opening a terminal and running ls -l on the items in question to see whether that turns up anything.
Hi, take me a while to that annoying behavior shown again ...

i did ls to the folder:
[dorian@casiv downs]$ ls -lash
total 251M
4.0K drwxrwxrwx 1 root localuser 4.0K Sep 24 09:37 themes
8.0K drwxrwxrwx 1 root localuser 8.0K Oct 24 05:07 tools
0 drwxrwxrwx 1 root localuser 0 Oct 29 10:17 torrents
24K drwxrwxrwx 1 root localuser 24K Nov 28 09:02 trash
4.0K drwxrwxrwx 1 root localuser 4.0K Sep 22 11:12 utls
4.0K drwxrwxrwx 1 root localuser 4.0K Nov 22 22:52 win
0 drwxrwxrwx 1 root localuser 0 Sep 22 10:55 wine

captura.png

as see on the picture not even "copy" is enabled, my username is "dorian"(uid=500) belong to "localuser"(gid=501) group
[dorian@casiv ~]$ whoami
dorian

[root@casiv ~]# cat /etc/fstab
#
# /etc/fstab
# ...
/dev/sda13 /media/multm ntfs-3g defaults,noatime,gid=501,gmask=007 0 0
/dev/sda14 /media/downs ntfs-3g defaults,noatime,gid=501,gmask=007 0 0
those folders are a local folders but are shared with others over samba , just in case i'll include smb.conf
[root@casiv ~]# cat /etc/samba/smb.conf
[downs]
path = /media/downs
; read only = yes
browseable = no
valid users = sambauser
comment = downs
[multm]
path = /media/multm
; read only = yes
browseable = no
valid users = sambauser



[root@casiv ~]# groups sambauser
sambauser : sambauser localuser
of course has i've tell before changing temporally folder activate the options "copy", "cut", "move to trash", "delete". please help that's really annoying, i'm suspicious that could be ntfs-3g related problem... could be a bug?... thanks

Last edited by dorianrenato; 11-28-2011 at 03:21 PM.
 
Old 11-28-2011, 07:41 PM   #4
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,254

Rep: Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559Reputation: 1559
This is getting a little deep for me. The permissions indicate that all rights are granted. I don't know whether the fact that the folders are owned by root might be an issue or not.

If it's an NFTS file system, though, that might be an issue. I understand that Linux permissions do not translate transparently to NFTS, though I can't find a link that explains it clearly.

I am hoping someone comes along and helps both of us see the light.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can I "cat" or "grep" a file to ignore lines starting with "#" ??? callagga Linux - Newbie 7 08-16-2013 07:58 AM
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 11:35 AM
[SOLVED] "Insert" & "Delete" key returns "~" in a terminal. sharky Linux - General 15 04-26-2011 09:36 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration