LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-01-2011, 03:58 AM   #16
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269

Ok, I think I've solved it now (so far no hangs) using this:
http://linux.koolsolutions.com/2009/...-and-restarts/

So I added 'reboot=force', and so far there have been no hangs. The other options don't work. I no longer use 'acpi=force' as it doesn't really do anything.
 
Old 06-01-2011, 08:03 AM   #17
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,551
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Good luck! Hopefully the problem will not recur
 
Old 06-01-2011, 08:14 AM   #18
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Yeah thanks, it's hard to tell if the solution actually works until happens again ... or doesn't happen again.
 
Old 06-03-2011, 10:24 AM   #19
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Ok, that's not the solution either, but I have found something unusual in the logs, so please help me figure it out. I have noticed that every time it hags '/var/log/messages' says this:

Code:
Jun  2 22:25:45 greatdemonslayer shutdown[25166]: shutting down for system halt
Jun  2 22:25:45 greatdemonslayer init: Switching to runlevel: 0
Jun  2 22:25:52 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/route del default
Jun  2 22:25:52 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -k -d eth0
Jun  2 22:25:52 greatdemonslayer dhcpcd[25199]: sending signal 1 to pid 1520
Jun  2 22:25:52 greatdemonslayer dhcpcd[1520]: received SIGHUP, releasing
Jun  2 22:25:52 greatdemonslayer dhcpcd[1520]: eth0: releasing lease of 192.168.1.2
Jun  2 22:25:52 greatdemonslayer dhcpcd[25199]: waiting for pid 1520 to exit
Jun  2 22:25:52 greatdemonslayer dhcpcd[1520]: eth0: removing interface
Jun  2 22:25:53 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/ifconfig lo down
Jun  2 22:25:53 greatdemonslayer acpid: exiting
Jun  2 22:25:53 greatdemonslayer exiting on signal 15
...
May 27 22:38:31 greatdemonslayer shutdown[30959]: shutting down for system halt
May 27 22:38:32 greatdemonslayer init: Switching to runlevel: 0
May 27 22:38:39 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/route del default
May 27 22:38:39 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -k -d eth0
May 27 22:38:39 greatdemonslayer dhcpcd[30992]: sending signal 1 to pid 1521
May 27 22:38:39 greatdemonslayer dhcpcd[1521]: received SIGHUP, releasing
May 27 22:38:39 greatdemonslayer dhcpcd[1521]: eth0: releasing lease of 192.168.1.2
May 27 22:38:39 greatdemonslayer dhcpcd[30992]: waiting for pid 1521 to exit
May 27 22:38:39 greatdemonslayer dhcpcd[1521]: eth0: removing interface
May 27 22:38:40 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/ifconfig lo down
May 27 22:38:40 greatdemonslayer acpid: exiting
May 27 22:38:40 greatdemonslayer exiting on signal 15
Every time it shuts down normally it says this:

Code:
May 27 00:09:26 greatdemonslayer shutdown[15536]: shutting down for system halt
May 27 00:09:26 greatdemonslayer init: Switching to runlevel: 0
May 27 00:09:34 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/route del default
May 27 00:09:34 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -k -d eth0
May 27 00:09:34 greatdemonslayer dhcpcd[15580]: sending signal 1 to pid 1521
May 27 00:09:34 greatdemonslayer dhcpcd[15580]: waiting for pid 1521 to exit
May 27 00:09:34 greatdemonslayer dhcpcd[1521]: received SIGHUP, releasing
May 27 00:09:34 greatdemonslayer dhcpcd[1521]: eth0: releasing lease of 192.168.1.2
May 27 00:09:35 greatdemonslayer dhcpcd[1521]: eth0: removing interface
May 27 00:09:36 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/ifconfig lo down
May 27 00:09:36 greatdemonslayer acpid: exiting
May 27 00:09:36 greatdemonslayer exiting on signal 15
...
May 25 22:54:19 greatdemonslayer shutdown[28787]: shutting down for system halt
May 25 22:54:19 greatdemonslayer init: Switching to runlevel: 0
May 25 22:54:26 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/route del default
May 25 22:54:26 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -k -d eth0
May 25 22:54:26 greatdemonslayer dhcpcd[28820]: sending signal 1 to pid 1518
May 25 22:54:26 greatdemonslayer dhcpcd[28820]: waiting for pid 1518 to exit
May 25 22:54:26 greatdemonslayer dhcpcd[1518]: received SIGHUP, releasing
May 25 22:54:26 greatdemonslayer dhcpcd[1518]: eth0: releasing lease of 192.168.1.2
May 25 22:54:26 greatdemonslayer dhcpcd[1518]: eth0: removing interface
May 25 22:54:27 greatdemonslayer logger: /etc/rc.d/rc.inet1:  /sbin/ifconfig lo down
May 25 22:54:27 greatdemonslayer acpid: exiting
May 25 22:54:27 greatdemonslayer exiting on signal 15
Notice that the order is different. I don't really know what this means or if it important, but may be important.
 
Old 06-15-2011, 06:31 AM   #20
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I hope I am not early in saying this, but it seems that 'reboot=triple' works. It has worked for around 2 weeks without problems. I hope this has been solved.
 
Old 06-23-2011, 02:44 PM   #21
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
That didn't work either, neither did compiling the latest kernel from scratch using 'make defconfig' and changing a few things, but leaving everything having to do with ACPI alone.

I don't know what else to do, nothing in the logs again. It might be hardware related, because there's absolutely no way for me to debug this, AFAIK.

I can't mark this solved tho, and I will only mark it solved if it doesn't reboot for several months instead of weeks.
 
Old 10-08-2011, 03:35 AM   #22
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I think I finally found a solution.

What I know about the problem:

acpid-2.0.9 that comes with slackware64 13.37 has the problem = randomly refuses to poweroff

I uninstalled that one and installed acpid-2.0.10, and it also had the problem.

I noticed recently, while investigating this issue that acpid does NOT start properly. I checked why, and it seems that the config directory at '/etc/acpi' does NOT contain an 'events' directory. This causes acpid to not start up, without any kind of error or warning or anything that might have given me a clue.

I decided to install an earlier version of acpid-1.0.10, the one without netlink support, and I've made sure all the config directories and files are in place. So far, I have not had any problems.

I will probably have to experiment more in order to say exactly what the problem was. One thing I don't know is if the acpid that came with slackware had the proper config directories. In my other slackware64 13.37 installs the config directories are there and properly set up, so I can only assume that it was set up, but that there must have been a bug in this version. There is also the 'May 27 22:38:40 greatdemonslayer acpid: exiting' in the logs, which backs this up: acpid was running and exited, but the computer failed to shutdown.

For sure I will try to modify /etc/rc.d/rc.acpid to warn me if it fails to start, as this would have helped tremendously in diagnosing this issue.

Last edited by H_TeXMeX_H; 10-08-2011 at 03:43 AM.
 
Old 10-08-2011, 06:26 AM   #23
zk1234
Member
 
Registered: Oct 2010
Location: Poland
Distribution: 4MLinux, Slackware, Slitaz, Mint
Posts: 117

Rep: Reputation: 7
I am under the the impression how H_TeXMeX_H talks to H_TeXMeX_H about the problem announced by H_TeXMeX_H :-)

Now seriously:
This problem is not related to Slackware acpi only. I use busybox applet “acpid” for poweroff in my 4MLinux. Observations:
1) Works 100% on my netbook (Intel graphics),
2) Works ca 50% on my laptop (Radeon),
3) Works much less than 50% on my PC (Nvidia).

Restarting acpid before pressing poweroff button always helps.
 
Old 10-08-2011, 08:05 AM   #24
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I'm sorry, but there's no one else to talk to ... but now you're here

It's true that my laptop works 100% with the regular acpid that comes with slackware, so I have no doubt that this is specific to each machine. Somehow, I still think it is a bug. I'm not sure how to track it down tho. Maybe I'll experiment a bit more and tell the devs.
 
Old 10-15-2011, 07:09 AM   #25
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Ok, I have FINALLY figured it out. Most unexpectedly, the problem was the e1000e driver.

Many thanks to diegoviola at archlinux for the solution:
https://bbs.archlinux.org/viewtopic.php?id=113985&p=3

I would have NEVER guessed that this was the problem if it weren't for him.

Before this, I literally tried every possible kernel parameter I could find, many of them listed in that thread, and none worked at all. What I said earlier about using a different version of acpid, that didn't work either, it did it again after that. Then I tried many different versions including the latest version and it also did not help.

I was getting really pissed off and the last thing I said I would try is blacklisting the e1000e driver (I tried updating but that didn't help). After blacklisting it and/or disabling the onboard ethernet in the BIOS, it NEVER happened again. I tested it by shutting down the machine around 30 times, and another 10 times today.

I disabled the onboard ethernet and bought a new ethernet card, a rtl8139 one. I've bought this type before for another machine and a similar problem was solved there as well.

It must be that the onboard ethernets are the cheapest they could get on there. As a result, it often causes huge problems. Every computer that I've recently bought (last 4 years) has had major issues with the onboard ethernet. This means 3 desktops and 3 netbooks. ALL of them have problems with the onboard ethernet, some more severe (internet cuts out or fail to shutdown), some less (rare internet failure, disabling IRQ 19 for the ethernet card).

I think the only solution from now on is to buy and keep a PCI ethernet card and use that, or a USB wifi card for the netbooks. That's exactly what I've done.

This is officially solved !

Last edited by H_TeXMeX_H; 10-15-2011 at 07:10 AM.
 
  


Reply

Tags
acpi, button, msi, poweroff, shutdown


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make the power button work properly without ACPI Lord Estraven *BSD 3 01-01-2010 10:17 PM
Keyboard Power Button to shutdown my computer stringZ Linux - Software 8 10-16-2009 05:23 AM
Power Button for Shutdown gokul Linux - Hardware 4 01-24-2004 12:40 PM
ACPI: shutdown computer by pushing power button... elluva Mandriva 10 12-15-2003 03:57 AM
Shutdown with power button hriosm Linux - Hardware 4 06-06-2003 02:43 PM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration