LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-06-2005, 10:48 AM   #1
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Need Xorg To Listen On Network When Started By, kdm-3.4


I have 64bit Gentoo, but untill windows 64bit eddition is released, i need to use a 32bit media player to interface with the 32bit MS-windows codecs for playing media such as ASF or WMV.

to do this, i have created a 32bit envoronment within my 64bit OS.
I need the 32bit envoronment to connect to the Xserver in the 64bit OS.

normally this is as simple as setting the display variable to "127.0.0.1:0"
but the graphical X server is not listening for incomming connections on port 6000.

I know this is done by the KDE login manager (KDM) it dissables tcp logins.
In KDE 3.3, you needed to comment out a "nolisten" line in a config file called Xservers

but ive recently upgraded to KDE-3.4. there is no Xservers config file, they must have moved that setting somwhere else.

Does anyone know where ???
 
Old 04-07-2005, 05:26 PM   #2
Ben2210
Member
 
Registered: Feb 2004
Location: Toronto
Distribution: Arch
Posts: 146

Rep: Reputation: 16
I saw in the kdmrc file on a KDE 3.4 install that it mentions the Xservers file, even though it doesn't exist. My guess is that you can just try to create a custom Xservers file. Also look more at the kdmrc file, perhaps there's an option to enable what you want.
 
Old 04-08-2005, 06:22 AM   #3
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
Fantaastic !!!

The answer, for anyone else who happens to stumble across this post is to locate that kdmrc file, find the line

Code:
ServerArgsLocal=-nolisten tcp
and comment it out.
 
Old 04-20-2006, 03:27 PM   #4
shanec
LQ Newbie
 
Registered: Apr 2006
Distribution: Fedora Core 5
Posts: 14

Rep: Reputation: 0
Brand new clean FC5 install here on a new laptop...

I have the same problem. I edited /etc/X11/xdm/kdmrc (also pointed to by /etc/kde/kdm/kdmrc), found the aformentioned line, and commented it out. And Xorg still runs with a -nolisten as seen from my process list:

Quote:
/usr/bin/Xorg :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
I've grep'd all over the place looking for "nolisten". Where else could this be getting turned on?

Last edited by shanec; 04-20-2006 at 03:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding kdm to init.d so LFS boots to kdm StevePhM Linux From Scratch 4 08-08-2005 09:49 PM
Network and Printer Configuration hang when started sloik2000 Linux - Software 1 05-23-2005 05:06 PM
giFT network plugins + Xorg shapes missing alaindu Linux - Software 0 05-19-2005 02:02 PM
KDM (KDE 3.3.2) + xorg 6.8.1 problem reddazz Slackware 2 01-28-2005 07:03 PM
DNS not working in PPP when network is started pospiech Linux - Networking 0 03-17-2004 02:14 AM


All times are GMT -5. The time now is 05:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration