LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-06-2005, 04:39 PM   #1
kewlemer
LQ Newbie
 
Registered: Apr 2005
Location: Los Angeles, CA
Posts: 20

Rep: Reputation: 0
Kernel Panic with Ext2/Ext3 partition check


Hi All,

I am running FC3 with a 2.6.10 kernel without any problems.

I am trying to install a 2.4.21 kernel for an application I am working on. Initially I had problems compiling the 2.4 and after a lot of effort, I changed the gcc to the right version (2.96.3) and was able to compile the 2.4.21 kernel. I also had a problem with 'make install_modules' that version reqired old depmod and I had to create a symlink "ln -s /sbin/depmod /sbin/depmod.old". And finally it compiled and installed.

But when I try to boot this new 2.4.21, I get a kernel panic message saying:-

Code:
Freeing initrd memory: 37k freed
VFS: Mounted root(ext2 filesystem)
attempt to access beyond end of device
01:00: rw=0,want=4612,limit=4096
attempt to access beyond end of device
01:00: rw=0,want=4612,limit=4096
attempt to access beyond end of device
01:00: rw=0,want=4612,limit=4096
VFS: Cannot open root device "LABLE=/dev/hda1" or 00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 00:00
I googled around and made changes to my grub.conf, without use. Here is the relavent part of my grub.conf:-
Code:
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.4.21)
        root (hd0,0)
        kernel /vmlinuz-2.4.21 ro root=LABEL=/dev/hda1
        initrd /initrd-2.4.21.img
Here is my relavent part of fstab :-
Code:
This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/               /                      ext3    defaults        1 1
LABEL=/boot      /boot               ext3    defaults        1 2
none                    /dev/pts           devpts  gid=5,mode=620  0 0
none                    /dev/shm        tmpfs   defaults        0 0
none                    /proc                proc    defaults        0 0
none                    /sys                  sysfs   defaults        0 0
LABEL=SWAP-hda3  swap     swap   defaults        0 0
Although, I have enabled ext3 support for the 2.4.21, the initial messages it throws up before kernel panic, tells it is seeing the hard disk as a ext2. I assume ext3 is ext2 with journaling support. So is this behaviour ok? Is this related to the above kernel panic message? Is the new 2.4.21 kernel simply not able to read my partitions that are in ext3? If so, why? Please help.

I cross checked the .config of 2.6 and the 2.4 for the IDE part and made sure both were the same. Here is the filesystem part of the .config of 2.4, in case it helps you in identifying the problem:-

Code:
# File systems
#
CONFIG_QUOTA=y
CONFIG_AUTOFS_FS=y
CONFIG_AUTOFS4_FS=y
CONFIG_EXT3_FS=y
CONFIG_JBD=y
CONFIG_JBD_DEBUG=y
CONFIG_FAT_FS=y
# CONFIG_MSDOS_FS is not set
CONFIG_VFAT_FS=y
# CONFIG_JFFS_FS is not set
# CONFIG_JFFS2_FS is not set
CONFIG_RAMFS=y
CONFIG_ISO9660_FS=y
CONFIG_VXFS_FS=y
CONFIG_NTFS_FS=y
# CONFIG_HPFS_FS is not set
CONFIG_PROC_FS=y
CONFIG_DEVPTS_FS=y
CONFIG_EXT2_FS=y
Although google gave many links to previous kernel panic messages, they were either due to differnt issues or they did not work for me. Your help will be greatly appreciated.

Thank you,
K
 
Old 04-06-2005, 04:47 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Loose the LABEL in your kernel line (grub.conf).

It should be root=/dev/hda1.

Labels are used when refering to a harddisk with it's label.
 
Old 04-06-2005, 04:57 PM   #3
kewlemer
LQ Newbie
 
Registered: Apr 2005
Location: Los Angeles, CA
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks so much, marghorp. It worked.

Now its failing on:-

Code:
Waring: unable to open an initial console.
Kernel panic: No init found. Try parring init= option to kernel
I guess I have to set some option in the .config. Please help.

Thank you,
K
 
Old 04-06-2005, 07:49 PM   #4
kewlemer
LQ Newbie
 
Registered: Apr 2005
Location: Los Angeles, CA
Posts: 20

Original Poster
Rep: Reputation: 0
An update..I ran a

/sbin/mkinitrd -v -f /boot/initrd/2.4.21.img 2.4.21

And now I am getting this message:

Code:
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted files system with ordered data mode.
pivotroot: pivot_root(/Sysroot,/Sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
freeing unused kernel memory: 276k freed
Kernel panic: No init found. Try passing init= option to kernel.

Any pointers, folks?

Thanks,
K
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
resize ext2/ext3 partition georgec Linux - Software 4 09-22-2009 05:40 PM
How i make Ext2,Ext3 partition from FDISK Shiraz Ahmed Linux - Software 1 08-23-2004 06:56 AM
Need Partition Creator for Ext2, Ext3 and Swap Partitions (FREE) milesonwheels Linux - Laptop and Netbook 2 07-14-2004 05:18 PM
Kernel Panic re Ext3? OldNewbie Linux - Newbie 1 09-12-2003 11:26 AM
SMP Kernel Panic with ext3 on Redhat 9 Gord_McF Linux - Newbie 7 07-31-2003 07:02 AM


All times are GMT -5. The time now is 02:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration