LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-08-2004, 06:42 AM   #1
cwolf
Member
 
Registered: Mar 2003
Location: Switzerland
Distribution: Sun Solaris 7/8/9, Fedora Core 3
Posts: 63

Rep: Reputation: 15
IDE Hardisk Problem when setting drive to standby mode with hdparm


Hi there,
I have two disks on my primary IDE-controller. The first one (hda) is the one where grub is installed. On the second one (hdb) is Linux installed. Because hda is the older (slower and much more noisy) drive, I use it as a backup device. But of course it does not have to be on all the time. So I set it to standby mode with `hdparm -y /dev/hda`. But after 30 minutes it wakes up. Even if it's unmounted. Since it is a very noisy drive, this is very ugly for me. When I set the drive to sleep mode with `hdparm -Y /dev/hda`the it does no more wake up (only with the appropriate commands). But the bad thing is, that again after 30 minutes the system freezes for about three seconds. And the message
Code:
Jul  4 06:25:37 shiva kernel: hda: lost interrupt
is printed to the syslog.

This is an ASUS TUSL2 Motherboard BIOS Rev. 1006 with all power management futures disabled.
The Disks: hda: IC35L040AVER07-0, ATA DISK drive
hdb: ST3120026A, ATA DISK drive
Both are set to DMA-Mode and 32-Bit access mode (with hdparm -c and hdparm -d).

Distribution: Fedora Core 2 Kernel 2.6.6-1.435. The ACPI and APM futures are turned off via the boot-cmd-line in grub (acpi=off apm=off). The apm daemon (apmd) is of course also turned off.

This problem is new since I reinstalled to Computer with Fedora Core 2. Before I had RedHat 9.

Any hint for this problem?

cwolf
 
Old 07-13-2004, 12:17 AM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
try this
Code:
hdparm -S 253 /dev/hda
this resets the mfg default spin down time.........
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Q1: Setting DMA Mode with hdparm mattz40 Debian 3 03-15-2005 04:52 PM
Standby mode for drive, where does command go? inittab? Eradicator Mandriva 1 04-16-2004 08:35 AM
problem with standby mode Error1312 Red Hat 1 03-03-2004 12:39 AM
Cant set dma mode with hdparm and SiS 5513 IDE mush Linux - Hardware 1 12-15-2003 07:35 PM
Suse 8.2 change my DMA setting on my DVD-R drive to off & IDE DMA MODE NOT SHOWING IT maximalred Linux - General 0 08-23-2003 04:58 AM


All times are GMT -5. The time now is 06:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration