LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 08-20-2005, 09:34 PM   #1
airman99
LQ Newbie
 
Registered: Aug 2004
Distribution: Gentoo
Posts: 26

Rep: Reputation: 15
I/O error when copying large file from Memory Stick


I have a Sony Memory Stick that I am attempting to copy pictures/video from to my hard disk. It is connected to my computer via a Lexar 6-in-1 flash card reader. After plugging the card into the reader, the partition appears under /dev/scsi/... and I can mount the card without a problem. I can copy all the .JPG files from the card without a problem. However, when I attempt to copy an .MPG file, I get the following error:
Code:
`/mnt/memory_stick/dcim/101msdcf/mov05776.mpg' -> `./mov05776.mpg' 
 cp: reading `/mnt/memory_stick/dcim/101msdcf/mov05776.mpg': Input/output error
The .MPG files range in size from 15M to 30M. Approximately 2M of the file gets copied before the error occurs. Each .JPG file is 1.5M to 2.5M in size.

I tried connecting the card to my computer via the camera itself, a Sony DSC-V1, and the camera's USB cable. It worked identical to the card reader, mounted OK, copied .JPG files OK, errored out on .MPG files.

I'm running Gentoo with a 2.6 kernel. My Compact Flash card works fine in the Lexar card reader.

Any ideas?
 
Old 08-21-2005, 11:04 AM   #2
eddiebaby1023
Member
 
Registered: May 2005
Posts: 378

Rep: Reputation: 33
How much free space do you have on your hard disk? (Obvious questions first!)
Have you tried using a different method of copying, with dd for instance?

Last edited by eddiebaby1023; 08-21-2005 at 11:05 AM.
 
Old 08-21-2005, 01:25 PM   #3
airman99
LQ Newbie
 
Registered: Aug 2004
Distribution: Gentoo
Posts: 26

Original Poster
Rep: Reputation: 15
I have 101G free on the partition I'm copying to. "dd" produces the exact same results. It's different every time, but the last time I tried it 2.6M copied before the error. Sometimes it's more, sometimes it's less.
 
Old 08-22-2005, 10:26 AM   #4
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Try using dd with the following (or similar) format:

dd if=inFile of=outFile conv=noerror

With the "noerror" option it will refuse to take no for an answer. If it gets an error, it will simply ask for the block over again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing memory in USB stick, flash memory, removable hd etc bamboo_spider Linux - Newbie 3 06-14-2006 06:39 PM
memory stick returns error no medium found newusermike Linux - Newbie 1 08-04-2005 12:02 PM
SCSI Error with memory stick drben Linux - Hardware 2 07-27-2005 05:56 PM
USB memory stick file system linmix Linux - Hardware 2 12-02-2004 06:02 PM
Error copying large files from cdrom patrickyeo Linux - Hardware 1 11-03-2002 07:46 PM


All times are GMT -5. The time now is 05:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration