LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-11-2004, 10:00 PM   #1
blazted
Member
 
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Rep: Reputation: 15
Gentoo Stage 2 Linux Help


I have followed the Gentoo Handbook and up untill this point evrything is working fine. The problem I am having happens when I go to emrge the system.

When I run the command emerge system It starts to build the kernel. After a minute or 2 all of the sudden I get this error pop up and then it stops building the system.

Configure: Error: C++ preprocessor . ~ "?lib/cpp" fails sanity check
see config.log for details
Configure Error: ?bin/sn ' ./configure failed for autoconf-lib-bak

!!! Error: system-devel/gettext-0,12.1.r2 failed
!!! Function econf, Line 363 Exitcode 1
econf failed


I have no idea what to do now. I went over the whole handbook to see if I did anything wrong but I cannot find anything.

I even tried to do a emerge --fetchonly system after to see if that would work but that part went fine but I still get the error when I try to emerge system

An help is greatly appreciated.
 
Old 12-12-2004, 12:40 AM   #2
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Quote:
When I run the command emerge system It starts to build the kernel.
very very strange ! the kernel compiling shouldnt hapen until you have finished emerginh the system !
ive no idea why its doing this, what does "emerge --pretend system" output ?

also, try to remerge the gettext program, with "emerge sync && emerge gettext"
 
Old 12-12-2004, 11:37 AM   #3
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
I got past it the way gwijibow suggested; emerge -p system then emerge the first one on the list or you will see where the problem is.
Sometimes the order will change and the problem emerge will emerge after an emerge sync.If you can't get past it,you can do a stage3 and then set your use flags and do a emerge -e system and you will end up with the same as stage2.Check your /etc/make.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I start installing stage 3 of gentoo from universal gentoo 2005-1? kazuya1977 Linux - General 1 11-11-2005 10:30 AM
Half of my applications are broken. I am using Gentoo stage 1 on 3 nptl (stage 1.5) dragonslay Linux - Games 3 04-01-2005 05:23 PM
Gentoo: Stage 1, Stage 2, or Stage 3 skorpi0wn Linux - Distributions 3 03-01-2005 07:47 PM
Advantages and disadvantages of installing Gentoo GNU/Linux using Stage 1 blood_omen Linux - General 8 01-27-2005 08:37 PM
Gentoo Stage 2 time? cclavey Linux - Distributions 17 11-18-2003 03:42 PM


All times are GMT -5. The time now is 04:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration