LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-16-2004, 04:13 PM   #1
Ryknow215
Member
 
Registered: Dec 2003
Location: Connecticut
Distribution: Fedora Core 2
Posts: 55

Rep: Reputation: 15
Error w/ grub booting windows xp


Hi everybody. I know this question has been asked alot of times before but i'm confused how to solve the problem on my machine. i have fedora core 1 installed on my first hard drive (hda1) and windows xp on my second hard drive (hdb1). when grub loads, i can boot into FC normally w/ no problems but if i boot into XP i get a screen with:

rootnoverify (hd1,0)
chainloader +1

how exactly am i supposed to edit my boot line in GRUB? should it be rootnoverify (hd2,0) b/c it's on my second ide hd, first partition? Or is there another couple lines in there that im missing? Im not dying to boot into xp or anything, but sooner or later i have a couple dvd's i'd like to burn. thanks in advance for any help !
 
Old 03-16-2004, 04:40 PM   #2
darkCanuck
Member
 
Registered: Mar 2004
Location: Edmonton, Alberta, Canada
Distribution: FreeBSD 4.10 RELEASE
Posts: 40

Rep: Reputation: 15
Can you get to your grub.conf and post it here?

That looks like it should work just fine. Did you edit it yourself originally? Because Fedora should have detected it all automatically.

You should try k3b for dvd burning - it works pretty good, at least for data.

Last edited by darkCanuck; 03-16-2004 at 04:43 PM.
 
Old 03-16-2004, 04:47 PM   #3
Ryknow215
Member
 
Registered: Dec 2003
Location: Connecticut
Distribution: Fedora Core 2
Posts: 55

Original Poster
Rep: Reputation: 15
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2115.nptl)
root (hd0,0)
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/1 hdc=ide-scsi hdd=ide-scsi rhgb
initrd /initrd-2.4.22-1.2115.nptl.img
title Windows XP
rootnoverify (hd1,0)
chainloader +1


everything look normal? anything i can change here to fix the problem?
 
Old 03-16-2004, 05:04 PM   #4
darkCanuck
Member
 
Registered: Mar 2004
Location: Edmonton, Alberta, Canada
Distribution: FreeBSD 4.10 RELEASE
Posts: 40

Rep: Reputation: 15
I'm absolutely stumped. It looks perfect according to grub specs.

What order did you install these? Linux then Windows? Or Windows was on hda, got moved down to hdb and installed linux on hda?
 
Old 03-16-2004, 06:52 PM   #5
Ryknow215
Member
 
Registered: Dec 2003
Location: Connecticut
Distribution: Fedora Core 2
Posts: 55

Original Poster
Rep: Reputation: 15
Yup, exactly as you said. XP was on hda, and then i moved that down to hdb and installed linux on a fresh hard drive on hda. Any ideas?
 
Old 03-16-2004, 10:16 PM   #6
darkCanuck
Member
 
Registered: Mar 2004
Location: Edmonton, Alberta, Canada
Distribution: FreeBSD 4.10 RELEASE
Posts: 40

Rep: Reputation: 15
Well, because I'm stumped and apparently none of the people viewing this thread have any ideas, I'll grasp at straws:

Maybe pop out that linux drive and put your windows drive back as master. See if you can boot into windows still. If you can't, maybe (somehow) its bootloader was overwritten. But I don't think that's it because you're getting a GRUB error not a windows bootloader error ("can't find system disk" error or whatever it is).

If windows boots fine then, here's the only other thing I could scrounge up online:

add "makeactive" on its own line after "rootnoverify (hd1,0)"

I read somewhere that some (older) versions of DOS/Windows need this to boot correctly. And, although I wouldn't consider XP to be an older version of DOS/Windows, we're not having any success with anything else so it can't hurt.

So your grub.conf should look like:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2115.nptl)
root (hd0,0)
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/1 hdc=ide-scsi hdd=ide-scsi rhgb
initrd /initrd-2.4.22-1.2115.nptl.img
title Windows XP
rootnoverify (hd1,0)
makeactive
chainloader +1
 
Old 03-17-2004, 09:21 AM   #7
Ryknow215
Member
 
Registered: Dec 2003
Location: Connecticut
Distribution: Fedora Core 2
Posts: 55

Original Poster
Rep: Reputation: 15
Good news! It worked....somewhat. I left (hd1,0) as it was and added makeactive right under rootnoverify (hda1,0) and instead of getting an Error, i got:

Booting command-list

rootnoverify (hd1,0)
makeactive
chainloader +1

_ (blinking cursor)

So what's going on now? The commands seem correct, but it doesn't boot into XP or appear to be doing anything . Just yesterday i put my XP hard drive in hda1 and installed a fresh of Windows on it, so that shouldn't be a problem.


BTW darkcanuck i appreciate all your help with this .
 
Old 03-17-2004, 09:23 AM   #8
tkg
LQ Newbie
 
Registered: Nov 2003
Location: Redwood CIty CA (Silicon Valley)
Posts: 4

Rep: Reputation: 0
grub.conf editing dual boot WINXP 64 and fedora 64

-have similiar question :
but using 64 bit editions of both.
The grub.conf works, fedora launches fine , however when win64 booting says "auotcheck not found"
Im assuming this is something Win 64 uses during boot "a bootloader" of some sort.
Perhaps it was overwritten after fedora was installed.
Has anyone seen anything like this? or have any sugestions?
Thanks
Tkg
 
Old 03-17-2004, 02:22 PM   #9
darkCanuck
Member
 
Registered: Mar 2004
Location: Edmonton, Alberta, Canada
Distribution: FreeBSD 4.10 RELEASE
Posts: 40

Rep: Reputation: 15
Still not getting past grub, though.... strange.

If I recall, some oddities can happen with bootloaders when Windows is not on the first disk of the IDE chain, although there shouldn't be anything to support that theory. Although, if you try this and it works, then that theory becomes Ryknow215's law.

Switch the drives. Make it so that Windows is hda and Linux is hdb. Format the Linux drive into nothingness. Reinstall Fedora (again, ugh). By default, grub will want to install its bootloader on the first disk of the computer (which makes sense, as that's the drive that the BIOS boots by default).

The other option, if you have your Fedora set up the way you want and don't want to start that process over, is just boot up the CD and do an "upgrade." I've never tried this but I would hope it would still go through the bootloader setup part of the installation. If it works it'll save you time.

This'll overwrite Windows' bootloader, which is what we want. Every dual-boot machine (with more than one disk) that I've ever had was set up this way and I've never had bootloader problems.

Now, if that doesn't work, I shall be rendered useless.

p.s. no problem - glad to help!
 
Old 03-20-2004, 04:02 PM   #10
Ryknow215
Member
 
Registered: Dec 2003
Location: Connecticut
Distribution: Fedora Core 2
Posts: 55

Original Poster
Rep: Reputation: 15
Oh man darkCanuck, you're not going to believe this. I completely wiped out both of my hard drives into nothingness, all partitions gone and completely reformatted. I set them up the way i wanted them, the 40gb windows HD as master and the 20gb fedora core HS as slave. I installed xp, went online and downloaded all the system updates and rebooted. then i installed fedora core on the second drive. What happened when i tried to boot up XP after it was done installing FC???

rootnoverify (hd1,0)
chainloader +1

Error

And fedora boots up just fine. Im convinced my computer hates me.
 
Old 03-21-2004, 11:03 AM   #11
darkCanuck
Member
 
Registered: Mar 2004
Location: Edmonton, Alberta, Canada
Distribution: FreeBSD 4.10 RELEASE
Posts: 40

Rep: Reputation: 15
I'm useless!!

Until I finally figured it out, I didn't do the windows updates until after I had both installed. It takes longer than installing the OS!

Well, we could look on the bright side - perhaps this is fate tempting you to make the difficult decision to formally leave Windows behind?

... on the flipside, it could be linux trying to piss you off so much that you don't come back. I had that happen about four years ago.

In the off-chance you're not also frustrated with me and my advice, you could try *one* *last* *thing* if it sounds reasonable to you:

Leave the drives the way they are (hda=40G, hdb=20G). You might have to use Linux first to use its partitioning program (or something else if you've got it) to wipe out the 40G drive. Then, boot the windows installer - partition the 40G drive to something like 20GB NTFS (windows) partition and leave the other 20GB free. Install Windows.

Then install Linux on that 20GB free space on the first drive. That way you'll have the original amout of space used that you intended.

Now, if GRUB has an issue installing a bootloader that doesn't work for a single disk, perhaps you should try a different distribution that doesn't use GRUB (like Mandrake that uses LILO).

This way, you'll have both OSs on the one big disk. Then you can format the second (20G) disk within windows to use as another drive. That way you'll have a combined 40GB for windows, 20GB for linux, except windows will be split over two drives. I do something similar to this sometimes, putting "system-ish" programs (browser, office applications, etc.) on the drive with the OS and games and other data on the second drive.

But, I wouldn't blame you if threw your hands in the air and cursed All. These moments are rather frustrating after spending that much time on them. The first time I had spent 6+ hours installing Gentoo (everything compiles from source), it didn't boot when I rebooted. This happened a few times until I figured out the problem.
 
Old 03-21-2004, 01:49 PM   #12
nemesis
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
I'm having a very similar problem after installing Fedora Core 1. My grub.conf:


default=1
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz

title Fedora Core (2.6.1-1.65)
root (hd0,1)
kernel /vmlinuz-2.6.1-1.65 ro root=LABEL=/ rhgb
initrd /initrd-2.6.1-1.65.img

title Windows XP Pro
rootnoverify (hd0,0)
makeactive
chainloader+1



Fedora boots fine but trying to boot Win XP, the following prints to the screen:

rootnoverify (hd0,0)
makeactive
chainloader+1

(blinking cursor)
 
Old 03-21-2004, 04:26 PM   #13
Ryknow215
Member
 
Registered: Dec 2003
Location: Connecticut
Distribution: Fedora Core 2
Posts: 55

Original Poster
Rep: Reputation: 15
Well for the time being I've been using XP b/c this grub problem seems hopeless. As much as i love Fedora Core, i think im going to have to go back to Red Hat 9 and give LiLo a try to see if that solves anything. I'll give that a try tonight and let you know the details!
 
Old 04-15-2004, 03:28 PM   #14
andymullins
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
I couldn't get XP working for love nor money with exactly the same problem. I had a simple dual boot setup with XP on (hd0,1), and Gentoo on (hd0,3). I finally got it working by removing the rootnoverify (or root, if that's what you have) line all together. i.e.

Code:
title=XP
chainloader (hd0,1)+1
Seemed to work for me, hope it does for others. Oh, and Ryknow215, I have a Dell Dimension. Don't know if this is related.

Last edited by andymullins; 04-15-2004 at 03:30 PM.
 
Old 04-17-2004, 06:29 PM   #15
Aerick
LQ Newbie
 
Registered: Apr 2004
Location: SLC, Utah
Distribution: Red Hat 9.1
Posts: 14

Rep: Reputation: 0
Perhaps the reason the above solution (chainloader (hd0,1) +1) doesn't work is because it's used in conjuction with a single drive configuration.

I tried it on my dual drive configuration with no luck (unfortunately), as I have the same problem as Ryknow215. I have my WinXP drive set as master and my linux drive set as slave. I had the Red Hat 9.1 installer use GRUB for my bootloader, but I specified that it should be put on the slave drive (hdb) instead of the master drive (hda). My slave drive had Win98 on it running in a dool boot configuration with XP. I believe I installed XP from Win98 to create the automatic NTLDR configuration to dual boot into both.

I fear that I may have overwritten something important on my slave drive (where linux now resides) that needs to be available for WinXP to work. When I change the boot order in the BIOS to look at my master drive (XP), I get the ol' "Non System Disk" error.

Does anybody else have any ideas on this problem? It looks like it's shared by more than a couple of people.

As a side note, and perhaps even helpful towards solving this problem, can anyone break down the commands the GRUB bootloader uses, such as "root noverify" and "chainloader"?

-------------------------------------------------
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting Windows from the Grub Prompt Kurzweil Linux - Software 26 08-22-2014 07:21 AM
Problem with booting windows in GRUB meinherzbrennt Linux - Newbie 17 09-10-2004 07:46 AM
Problem with GRUB booting Windows 98 bleedingturnips Linux - Software 0 06-15-2004 09:35 AM
GRUB windows xp not booting mirage Linux - Newbie 2 05-14-2003 02:10 PM
booting windows xp with grub! help!! fisch79 Linux - Software 1 02-20-2003 09:03 PM


All times are GMT -5. The time now is 10:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration