LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-26-2005, 05:58 PM   #1
Niflheim
Member
 
Registered: Jan 2005
Location: Québec
Distribution: Mandrake 10.1 Official
Posts: 104

Rep: Reputation: 15
cant start x with nvidia 6629 drivers


well i wanted to install the 6629 drivers from nvidia. i didnt reallny know how to do, so i did as posted here : http://transgaming.org/forum/viewtopic.php?t=1543

that was very complete and clear, and when i relogged as a user, there was the nvidia white screen, the gears and cedega test saying that everything is ok. how glad was i. but then i rebooted and x didnt start anymore. theres not GUI, just asking me for a login. when i login as user and type "startx", theres a message but x dont start (ill have to look for what it says). what do i do?

it already happened and i had to reinstall the drivers each time i wanted to start linux. and also, i had to log in su to see the gears in the console. and yeah. so i have to reinstall, at each time i want to log in to linux, my nvidia drivers. thats annoying.

what should i doooo



Last edited by Niflheim; 01-26-2005 at 06:17 PM.
 
Old 01-26-2005, 06:18 PM   #2
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
Quote:
but then i rebooted and x didnt start anymore
If X did not start, it will display some information as to what happened onto the console that you try to start it from. Maybe you could show what it says to give us a better idea of what's wrong. Check in /var/log too for a logfile for X.

Something you might want to check as well is if you have your nvidia drivers loading on startup. If the module's not loaded on startup, there's no way it'll work.

To check if nvidia is loading on startup, do this:

Code:
cat /etc/modules.autoload.d/kernel-2.6 | grep nvidia
(if you don't have kernel 2.6 then the file will be called kernel-2.4)
it should output

Code:
nvidia
onto the screen. If it doesn't output anything, your nvidia driver is not loading when your system boots. Simply add a line at the bottom of the file that says "nvidia":

Code:
echo nvidia >> /etc/modules.autoload.d/kernel-2.6

If you're using Xorg (instead of XFree86) then your log file is

/var/log/Xorg.0.log

please give us the tail end of that. If you're using XFree86, the log file is somewhere in /etc/log

-- the dudeman
 
Old 01-26-2005, 06:29 PM   #3
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
Forgot to mention that you can manually load the driver if you need (instead of remaking it):
Code:
modprobe nvidia
That should work.

- the dudeman
 
Old 01-26-2005, 06:41 PM   #4
BROse
Member
 
Registered: Nov 2003
Location: Here & Now
Distribution: SuSE 10.2
Posts: 96

Rep: Reputation: 15
Boot --login as root

Open Terminal and type init 3

sh Nvidia_installer......sh -q

modprobe nvidia

sax2 -m 0=nvidia

Set setting in sax2

Reboot

*******
Thanks to Crashoverride for this gem!
 
Old 01-26-2005, 07:18 PM   #5
Niflheim
Member
 
Registered: Jan 2005
Location: Québec
Distribution: Mandrake 10.1 Official
Posts: 104

Original Poster
Rep: Reputation: 15
ok first, what it says when i log in and type "startx" (it may be a bit wrong because i took a picture of my screen hihihi) :

Release Date : 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.6.0.1-2mdkenterprise i686 [ELF]
Current Operating System: Linux localhost 2.6.0.1-..................................... (.... for things i cant read)
Build Date : 13 September 2004
................
................
Module Loader present
Markers : (--) probed, (--) from config file, (--) default setting
(**) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown
(==) Log file : "/var/log/Xorg.0.log", Time: Wed Jan 26 15:13
(==) Using config file : "/etc/X11/xorg.conf"
Using vt 7

(EE) NVIDIA(0) : Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0) : *** aborting ***
(EE) Screen(s) found, but non have a usable configuration

Fatal server error:
no screens found

Please consult the X.Org Foundation support
at http://wiki.X.Org
for help
Please also check the log file at "/var/log/Xorg.0.log" for additional information
XIO: Fatal IO error 104 (connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaning.
[link@localhost link]$

so thats when i type startx.


when i type "cat /etc/modules.autoload.d/kernel-2.6 | grep nvidia", it only says : cat: /etc/modules.autoload.d/kernel-2.6: No such file or directory

and when you say the tail of /var/log/Xorg.0.log, what is it? im a newbie


oh and thanks a lot guys for trying to help me
 
Old 01-26-2005, 08:21 PM   #6
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
"tail /var/log/Xorg.0.log" means to use the tail command:
Code:
tail /var/log/Xorg.0.log
So I meant it quite literally. The tail command prints out the last 10 lines of a file to the console (you can specify how many lines with the -n switch: tail -n 20 /var/log/Xorg.0.log will print out the last 20 lines).

Did you try loading the nvidia module (driver) manually yet (as root):
Code:
modprobe nvidia
Load the module then do startx.

That "Failed to initialize the NVIDIA kernel module!" part makes it seem like the module wasn't installed right.

To see if your nvidia module is in fact installed:
Code:
lsmod
and you'll get a list going down the screen of all the modules you have installed at the moment. nvidia should be in there. If it's not listed then you don't have in loaded. You could also use "grep" to search the output for the nvidia driver if you don't feel like reading up and down the screen for it:
Code:
lsmod | grep nvidia
One more thing; I'm not sure what distribution you have so you may not have the same directories or directory structure as in mine. There should be a directory called "/etc/modules.autoload.d/". If there is then check what files are in there (there should only be a few). You might have one named "linux-2.6.0" instead of "linux-2.6" or something. Or your directory might be called "/etc/modules.autoload" (with out the ".d" on the end). But there should be a file for autoloading modules.

You need to make sure that the nvidia module is installed right and is loaded before moving on to other things that it could be.

-- the dudeman

PS Thanks for saying something when you don't understand what I'm saying. After a while of using linux, you learn how to do so many things that you start taking a lot of your knowledge for granted and forget that it's not obvious to everyone in the world what you're talking about :-)

Last edited by linuxLuser; 01-26-2005 at 08:25 PM.
 
Old 01-26-2005, 08:53 PM   #7
Niflheim
Member
 
Registered: Jan 2005
Location: Québec
Distribution: Mandrake 10.1 Official
Posts: 104

Original Poster
Rep: Reputation: 15
i forgot to tell what distribution, doh. well im using mandrake community 10.1. i look in /etc but there were no modules folder
i rebooted and when he asked me for my login, i entered as root and typed "modeprobe nvidia" and then "startx". and it worked, x started

then i tailed with 50 lines and it gave this :
[root@localhost root]# tail -n 50 /var/log/Xorg.0.log
[28] -1 0 0x0000d880 - 0x0000d8ff (0x80) IX[B]
[29] -1 0 0x0000dfa0 - 0x0000dfaf (0x10) IX[B]
[30] -1 0 0x0000df00 - 0x0000df3f (0x40) IX[B]
[31] -1 0 0x0000dc00 - 0x0000dc7f (0x80) IX[B]
[32] -1 0 0x0000ee80 - 0x0000eebf (0x40) IX[B]
[33] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[34] -1 0 0x00000400 - 0x0000041f (0x20) IX[B]
[35] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[36] -1 0 0x0000ef80 - 0x0000ef9f (0x20) IX[B]
[37] -1 0 0x0000ef40 - 0x0000ef5f (0x20) IX[B]
[38] -1 0 0x0000ef20 - 0x0000ef3f (0x20) IX[B]
[39] -1 0 0x0000ef00 - 0x0000ef1f (0x20) IX[B]
[40] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
[41] 0 0 0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing extension GLX
(II) Keyboard "Keyboard1" handled by legacy driver
(**) Option "Protocol" "ExplorerPS/2"
(**) Mouse1: Device: "/dev/mouse"
(**) Mouse1: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(==) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "6 7"
(**) Mouse1: ZAxisMapping: buttons 6 and 7
(**) Mouse1: Buttons: 7
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse1: ps2EnableDataReporting: succeeded
[root@localhost root]#

oh and lsmod, nvidia was there :
[root@localhost root]# lsmod
Module Size Used by
nvidia 3465112 12
md5 4576 1
ipv6 249412 10
snd-seq-oss 33728 0
snd-seq-midi-event 7328 1 snd-seq-oss


i did glxgears and they were there, so i guess it works. but i still dont have my gui. if i do modprobe nvidia everytime i boot linux, will everything be fine? if i play a game or use something that needs it, will it be ok?

Last edited by Niflheim; 01-26-2005 at 08:54 PM.
 
Old 01-26-2005, 11:17 PM   #8
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
OK, sorry about the /etc/modules.autoload.d/kernel-2.6 thing. That's a totally Gentoo thing (my distro). I believe that on Mandrake it's something like /etc/modprobe.preload.

The point is that you have the driver, X is set up to use it. You just needed loaded and that's what "modprobe" does for you. You'll have to load it upon every restart (probably as root) so it's best to have this done automagically. So check to see if you have the /etc/modprobe.preload file. I'm pretty sure that's it, but I don't have your distro

You would just add "nvidia" on a new line in the file. Then it should load automagically.

Hope that works!

-- the dudeman

PS Sorry for the "late" response. I was preoccupied for several hours, and only really check out LQ for a small amount of time.


Last edited by linuxLuser; 01-26-2005 at 11:18 PM.
 
Old 01-26-2005, 11:28 PM   #9
Niflheim
Member
 
Registered: Jan 2005
Location: Québec
Distribution: Mandrake 10.1 Official
Posts: 104

Original Poster
Rep: Reputation: 15
ill try that!

hey thanks a loooot! i would never have been able to find that alone ahah

i owe you a beer



edit:
i found modprobe.preload. there was just a line, intel something and i added "nvidia". i rebooted and, magie, the GUI started!! its been a long time since i last saw that ahaha. and everything is perfect, i tried glxgears and all and it works perfectly!

thanks even more, you fixed it all!

i owe you 2 beers

Last edited by Niflheim; 01-27-2005 at 12:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 + UT2004 + Nvidia 6629 Thermodynamic Suse/Novell 3 01-24-2005 05:41 AM
Mandrake 10.1, Nvidia 6629 driver Hexane Linux - Hardware 11 01-11-2005 09:29 PM
Mandrake 10.1 and nVidia 1.0-6629 Drivers - SOLVED mac57 Mandriva 1 12-24-2004 02:05 PM
NVidia 6629 but no GLX chakkerz Linux - Software 3 11-12-2004 09:23 PM
Nvidia 6629 problems TiRkItS Mandriva 3 11-12-2004 09:37 AM


All times are GMT -5. The time now is 10:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration