LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-28-2007, 10:58 AM   #1
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Rep: Reputation: 15
cannot delete drive from root desktop - cannot mount usb flash drive - openSuSE 10.2


I have a pqi 1 gig flash drive - I finally got it working to where it will auto mount when I'm logged in as a user, but I cannot access it as root.

On the root desktop shows a drive labeled "Intellistick-2" or something like that (not logged in as root now). I cannot delete this drive. When trying to mount the drive, it says /dev/sda1 does not exist.

When the drive is mounted as a user, it's shows /media/sda1 in konquerer, and /media/disk on the computer tab of my K Menu.

I'm a newbie (less than 3 weeks total linux experience), and this is all a little confusing. I had problems opening the drive at first, so I edited my /etc/fstab file. I changed it so that it would mount /dev/sda1 to /media/usb. That worked for a while, then all of a sudden I could not access the drive any longer. I tried to copy a file there and it gave me an error. I'm guessing it has something to do with the fact that I removed the drive, and plugged it back in. I also noticed that while the drive was removed, and I browsed to the /media/usb folder, I could still see my files from the drive (though I couldn't access them, obviously). I went back to /etc/fstab I noticed that there was no reference to my 40 gig usb hard drive (which shows up as /dev/sdb1) in the file, so I deleted the /dev/sda1 entry, and now it works perfectly (as a user).

Back to root: I was getting the error about "/dev/sda1/ does not exist" before and after I deleted the /dev/sda1 entry from /etc/fstab. So that is apparently not the issue.

The questions is: how do I get rid of the junk drive on the root desktop, and mount the flash drive properly?



I'm using KDE as a user, and GNOME as root.
 
Old 01-28-2007, 11:30 AM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
post the line you are using in /etc/fstab.

Brian
 
Old 01-28-2007, 11:52 AM   #3
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Original Poster
Rep: Reputation: 15
thanks Brian1 for responding -

here is a copy of the file:

/dev/hdb2 / ext3 acl,user_xattr 1 1
/dev/hdb3 /home ext3 acl,user_xattr 1 2
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0


btw: I have 2 hard drives - 1st for Windows XP, 2nd for openSuSE 10.2. I also have a floppy drive, a CDRW drive, a DVDRW drive, a usb hard drive, and the usb flash drive (aka problem child).
 
Old 01-28-2007, 06:36 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Not sure how to handle the automount idea. Never use it that way. Just old school and mount manually. but I would use a line like this in fstab
Code:
/dev/sda1               /mnt/sda1               auto  umask=000,users,noauto,owner,rw,dirsync   0 0
Make sure /mnt/sda1 directory exist. This is the way I do it.

Brian
 
Old 01-28-2007, 07:01 PM   #5
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Original Poster
Rep: Reputation: 15
thanks again Brian1 -

but, i'm not sure that will help me get rid of the pesky "Intellistick-2" drive on root's desktop, and that might interfere with the drive mounting properly as a user

i'm guessing if i could find away to get rid of that useless drive, then it would automount properly

---

so the real question [i think] is: how do i get the "Intellistick=2" drive removed from root's desktop?

when i try to put it in the trash can, i cannot, and when i right-click and go to 'properties' it does not appear to belong to any user (root or otherwise)

i tried to modify the mount options through the properties menu and restart (both w/ the drive in and out), but no dice. i did not create the drive on root's desktop, and the flash drive does not have a given name - like my usb hard drive; which i named "Backup POS". the drive must have automounted while i was logged in as root, and created it's own name, and made it self "sticky"
 
Old 01-28-2007, 07:14 PM   #6
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Original Poster
Rep: Reputation: 15
okay - never mind

i didn't do anything different, but i just now logged in as root -- the "sticky" drive still can't be deleted, but now it's [generically] named: "984.0 MB removable drive" -- it was automounted, and I could access the contents of my flash drive... i also logged back in as a user and accessed the drive just fine as well...

strange

i think ultimately: removing the /dev/sda1 line from /etc/fstab did the trick

thanks again Brian1 for responding
 
Old 01-29-2007, 03:18 PM   #7
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Just not a user of the automatic mount stuff. Causes to much headache on the hardware I have.

Anyways glad to see it is working.

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 07:16 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 1 12-24-2005 04:25 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 02:15 AM


All times are GMT -5. The time now is 06:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration