LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-24-2005, 09:33 PM   #1
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Rep: Reputation: 15
Can't allow partion permissions for a vfat partition, mounted as my home folder


Hi all. I got Fedora Core 3 on my system. I made a vfat partition while installing, and told it to mount it to /home/[myhomefolder]. Well, it's there, and root can write to it, but my user can do absolutely nothing to it. In fact I can't get into gnome because gnome can't seem to create the neccisary files.

The strange part is that I can't even right click it as root and change the file permissions, it immidietly unchecks the write-permissions boxes (for all users) as soon as I check them. And when I try to change the file owner of my home folder (once again, as root) all it does is say, "sorry, couldn't change the owner"

What's causing it to do this? It's driving me nuts! Anyone know how I can simply (and permently) allow myself to write to that vfat partition? I've done some googleing but to no avail.
 
Old 05-24-2005, 09:47 PM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Take a look at /etc/fstab and add umask=000 on the according line. In case of problem, then post your /etc/fstab.
 
Old 05-25-2005, 01:27 AM   #3
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Thanks, but tried that one. Maybe I did it wrong?
Now when I start, one of the startup tasks fails. It goes by too fast to catch but it mentions that one of several things could be bad, bad option included.

Anyhow, here's my fstab. It seems to not like the unmask option, but I'm not sure.
HDB5 is the device.

------------------------------------------------
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb5 /home/dan vfat auto,user,exec,sync,unmask=000 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hdb7 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
------------------------------------------------
 
Old 05-25-2005, 01:58 AM   #4
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
try this:
Code:
/dev/hdb5 /home/dan vfat auto,owner,users,rw 0 0
 
Old 05-25-2005, 02:21 AM   #5
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Put exactly what you had there. Thanks, but the problem remains.
I could be wrong, but this is what seems to be the root of the problem - I cannot change permissions on my home folder (where the partition is mounted), even when I am root. The boxes that normal let you speficify read/write permissions, simply won't stay clicked, and when I try to change the owner, it says it's sorry and can't do it.

What kind of thing would prevent you from editing permmisions on something (A folder or partition) even when you are root?
 
Old 05-25-2005, 02:57 AM   #6
court-jus
LQ Newbie
 
Registered: May 2005
Location: Toulouse, France
Distribution: Debian, Ubuntu, Gentoo
Posts: 2

Rep: Reputation: 0
Hmmmm

I'm not sure but I think vfat is not permissions aware

If I'm right, you cannot do what you wanna do

I already had the same problem trying to put permissions on an USB Key...
 
Old 05-25-2005, 10:44 AM   #7
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Almost the same thing happened with Fedora Core 2 a while back, only I was able to re-set the write permissions easilly. This time around, FC3 is being super-anal-paranoid, with some lame setting that not only disabled user access to other partitions, but keeps it that way. How and why would something of that nature get into any distro, I wonder?
 
Old 05-25-2005, 11:01 AM   #8
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
FAT partitions don't do permissions - I believe they belong to whoever mounts them, with whatever their default permissions are. That's just how FAT works.

Unless you have a compelling reason, you shouldn't use FAT, for this (amongst other) reasons. It's certainly no good at all as a /home partition. Sorry, but that's all there is to it.
 
Old 05-25-2005, 11:42 AM   #9
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
I'm sorry, I'm pretty certain you are incorrect. It serves as a home folder very usefully - it allows me to use it as my E drive in windows (which I seldom use, but still use). That way I don't need 2 copies of my music, movies, etc on my hard drive.

Thanks anyway though.

I also enabled permissions on /dev/hdb5, in case that was it. That doesn't do a darn thing. Bleh. Besides, those permissions get reset upon rebooting.

Here, if this helps anyone, look at this screenshot:
http://www.aktrailhead.com/Screenshot.png

See those write permissions? Soon as I check them, a quarter of a second later they're unchecked. If I attempt to change the owner of the drive, I get the [vauge] error you see there. And I'm logged in as root there.
What can I do? I just want to use that stinking partition as a normal user, and mount it as my home folder (something I've done before but don't seem to be able to do now).
"Something funny's going on!"
 
Old 05-25-2005, 06:28 PM   #10
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Quote:
Originally posted by DrD
Thanks, but tried that one. Maybe I did it wrong?
Now when I start, one of the startup tasks fails. It goes by too fast to catch but it mentions that one of several things could be bad, bad option included.

Anyhow, here's my fstab. It seems to not like the unmask option, but I'm not sure.
HDB5 is the device.

------------------------------------------------
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb5 /home/dan vfat auto,user,exec,sync,unmask=000 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hdb7 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
------------------------------------------------
I wrote umask, not unmask...............
 
Old 05-25-2005, 10:10 PM   #11
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Good call, Linux.tar.gz, that's a step in the right direction.

I changed that to umask, and that seemed to give the partition universal permissions (boxes stay checked now). I even found another forum that told me to use uid=500 and gid=500 to make the owner of the partition my (defualt) user.

Only now, guess what? The thing that prevented me from logging on as my user all along.. is still there! I rebooted and all. It says the seesion lasted less then 10 seconds, and when I click to show me the .xsession-error file, it says it couldn't get a lock on the ~/.ICEauthority file. Well, at least we got the partition mounted with universal permissions and with the right owner.

This is sort of turning out to be diminishing returns. I think I may just mount it somewhere else. I've always saved my pictures/movies/music on my home folder, but maybe I'll just mount the shared vfat partition somewhere else. Besides, that way I don't have to look at a ton of "dot blah blah" files when I'm in windows. Only drawback is I'll need to save the conents of my home folder when I reinstall the OS to keep my settings and preferences intact (not a real big deal).
 
Old 05-26-2005, 02:59 AM   #12
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
Why not have a proper Linux-formatted /home partition, make a separate FAT partition and mount it in /home/yourname/shared or some such?

That way you get a FAT partition in your /home directory that you can use to share files between OSes, without having the complications of a completely inappropriate filesystem on your /home partition.

Alternatively, there ARE tools available to allow Windows to read ext2 filesystems. You could install that in Windows, and use an ext3 /home

Using a FAT /home is always going to be an ugly hack, no matter what you do to get around it. It just wasn't designed for Linux.
 
Old 05-26-2005, 09:36 PM   #13
mcgrew
Member
 
Registered: May 2005
Location: West Virginia, US
Distribution: Gentoo
Posts: 56

Rep: Reputation: 21
I agree with oneandoneis2, I would never use vfat for home...the least of the problems being that vfat can't handle symbolic links, which are needed by some programs.

If you want your music and such to be in your home directory, why not mount vfat somewhere else and make symbolic links to the directories your music is in in your home directory?
 
Old 05-26-2005, 11:46 PM   #14
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
DrD, let me punish you a bit.
You seem to use Linux for over 2 years... and you still don't read manuals.... very pity. And you use GUI to configure the system.
Sorry, but GUI sucks such tasks. Instead of clicking you could just "chmod" or "chown".
You could find "umask" option in "man mount". There're also many useful info about FSs, their options, and so on.
 
Old 05-28-2005, 11:51 AM   #15
Dodgeram01
Member
 
Registered: Jun 2003
Distribution: Gentoo and Ubuntu
Posts: 95

Rep: Reputation: 15
I went through some of these battles with using vfat myself. Specifically, it's lack of ability for symlinks. At first I wanted to use it as my home partition, but quickly abandoned that notion. Then I wanted to use it for development (storage) partition. I couldn't figure out why nothing would build on it yet would build on a standard Linux partition. Then the light bulb went on (finally).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Permissions on a mounted vfat USB external harddrive Hikaru79 Linux - Hardware 2 02-25-2005 05:39 PM
mounted vfat permissions n3tw0rk Linux - General 3 12-05-2003 04:41 PM
Mounted drive permissions? Vfat kiteless Linux - General 3 08-29-2003 12:32 PM
Permissions problem in mounted vfat partition SparceMatrix Linux - Security 3 04-04-2003 04:19 PM
Permissions problem in mounted vfat partition SparceMatrix Linux - General 2 02-17-2003 02:49 PM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration