LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 02-17-2003, 04:49 AM   #1
SparceMatrix
Member
 
Registered: Aug 2002
Distribution: SME Server, CentOS
Posts: 219

Rep: Reputation: 30
Permissions problem in mounted vfat partition


I have an old HD drive that used to have a dual boot Linux/Windows installation on it. I recently added the drive to a Linux installation that I wanted to use for experimenting with Samba. I was hoping that I could use the old Windows vfat partition as a Samba share.

But, I am finding that I cannot change the permissions on the old vfat shares so that a low level Samba client can write to the share. I've tried a variety of different mount options and switches and it makes no difference. I keep getting "Operation not permmited" messages whenever I try using chmod to allow others to write to that directory or those files where the partition is mounted.

I thought maybe that there was a permissions set under Windows that is causing the problem. But I can no longer boot to that installation, so that would not be a solution.

Does anyone have any idea what the problem here is?
 
Old 04-01-2003, 02:05 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,489
Blog Entries: 54

Rep: Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903Reputation: 2903
You need a mix of uid/gid and maybe an umask setting for the partition, and even then it'll be writable only by that single user.
Look at "man mount" under "Mount options for fat".
 
Old 04-02-2003, 06:41 PM   #3
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,560

Rep: Reputation: 182Reputation: 182
vfat permissions, etc.

vfat file systems have no file table entries for permissions, owner, etc. Linux fakes these things by applying the mount point directory characteristics to all of its subdirectories and their files.

Linux is also sticky about changing the characteristics of an active mount point. So the way that I would approach your problem would be to dismount the vfat partition so that the mount point is just an ordinary empty directory. Then set the ownership and permissions to whatever works best for every file on the vfat partition. Then remount the partition.
 
Old 04-04-2003, 04:19 PM   #4
maxspeed
Member
 
Registered: Mar 2003
Posts: 41

Rep: Reputation: 15
mount it with umask=0222 option and that should fix your problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't allow partion permissions for a vfat partition, mounted as my home folder DrD Linux - General 19 07-26-2006 12:26 PM
Permissions on a mounted vfat USB external harddrive Hikaru79 Linux - Hardware 2 02-25-2005 05:39 PM
mounted vfat permissions n3tw0rk Linux - General 3 12-05-2003 04:41 PM
Mounted drive permissions? Vfat kiteless Linux - General 3 08-29-2003 12:32 PM
Permissions problem in mounted vfat partition SparceMatrix Linux - General 2 02-17-2003 02:49 PM


All times are GMT -5. The time now is 05:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration