LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-04-2005, 01:45 PM   #1
nicflatterie
LQ Newbie
 
Registered: Mar 2005
Location: Montreal
Distribution: Suse, AIX, Solaris
Posts: 15

Rep: Reputation: 0
bash "tab tab" - how to turn off?


I have some procedure that were written on a Solaris / ksh setup. The procedures are just a bunch a commands that I cut and paste using X mouse selection from the procedure file to the shell. This procedure has indentation using tabs so now that I use Linux, bash interprets the "tab tab" as a file completion.

Ex: procedure is:
<TAB><TAB>cd directory
<TAB><TAB>ls

in ksh I cut and past that, it's fine. In bash I get very weird results. These procedures are long and I do not want to edit them all. Note that the indentation may be any number of <TAB> keys (1 to n).

So how do I turn off the bash response to the <TAB> key (if at all possible)? The ideal solution would be something temporary for the session and not a full system/user setup.

Thanks to all!
 
Old 04-04-2005, 02:04 PM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try commenting the line about bash completion in /etc/profile , logout and back in for the change to take effect.
 
Old 04-04-2005, 03:09 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Alternatively (rather than you editing them manually,
or screwing up bash for the sake of a script): how about
if you used sed and replaced the tabs by spaces?

sed -i 's/\t/ /g' <ksh-files>




Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC 4. Modify ALT+TAB behaviour to CTRL+TAB xtracto Linux - Software 1 09-22-2005 02:06 PM
KDE3.4 "Wheel Optical Mouse" tab missing Darkvater Linux - Software 4 04-11-2005 10:49 AM
How can I turn on/install tab completion which I am so used to. jimdaworm *BSD 2 04-06-2005 11:25 PM
New kernel, no "tab complete links" Power User Fedora 1 02-04-2005 01:16 PM
KDE Login Manager missing the "session" tab culturejam Mandriva 13 10-11-2004 12:35 PM


All times are GMT -5. The time now is 09:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration