LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-15-2004, 01:15 PM   #1
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Rep: Reputation: 30
automount partition has problem


I have a vfat partition that I use to keep mp3's on. The line in fstab is

/dev/hdf6 /music vfat rw,users 1 2

When I try to access the /music directory, it gives me a "permission denied"

The permissions for the file are:
drwxr--r-- 12 root root 4096 1969-12-31 18:00 music

When I try to mount the directory, I get:
bash-2.05b$ mount /music mount: /dev/hdf6 already mounted or /music busy mount: according to mtab, /dev/hdf6 is already mounted on /music

However, I can get access to it by unmounting and then mounting it. It's not the biggests hassle I've had with linux, but is somewhat annoying. How can I correct this so that I don't need to unmount - mount after every reboot?
 
Old 12-15-2004, 01:44 PM   #2
cjcox
Member
 
Registered: Jun 2004
Posts: 305

Rep: Reputation: 42
Perhaps a timing issue of sorts? Not sure. You can always at the noauto option so you have to explicitly do a mount /music after boot up.

Of course, you could also edit /etc/auto.master, enable the /misc like, edit auto.misc line to have

music -fstype=vfat,rw,users :/dev/hdf6

and run the REAL autofs (automounter) daemon (enable with YaST->System->Run Level Editor) and just cd to /misc/music. Just an option to try.
 
Old 12-15-2004, 04:31 PM   #3
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
I don't have /etc/auto.master or YAST with slack10. I shouldn't have to manually mount it either
 
Old 12-15-2004, 06:06 PM   #4
cjcox
Member
 
Registered: Jun 2004
Posts: 305

Rep: Reputation: 42
Oops wrong group... sorry about the suse stuff.

You still might want to try using the automounter though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automount vfat partition with rw access for any user Simon Bridge Red Hat 12 05-26-2005 09:37 AM
Automount problem berkay Linux - Newbie 2 08-15-2004 08:32 AM
Automount problem movitto Linux - Software 0 07-05-2004 03:19 PM
Automount Problem don_dimo Linux - Software 2 02-01-2004 02:07 PM
Problem with automount (I think) robbage Linux - Newbie 1 12-12-2002 03:40 AM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration