LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-07-2004, 07:37 PM   #1
johann519
LQ Newbie
 
Registered: Jan 2004
Location: Portland, OR
Distribution: Fedora 1
Posts: 20

Rep: Reputation: 0
acrobat reader installation help noob


I just downloaded adobe acrobat reader and was wondering how to install it. I got as far as extracting it. It wants me to run the install script. How do I do that. Clicking on it doesn't do anything I don't think. Thanks.

P.S. I am running fedora 1 w/ all the updates
 
Old 05-07-2004, 08:11 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
you need to do it from the shell (command line)...

say for example you wanted to run an executable file called "install" (no quotes)... you'd do this:

./install


remember you need to be root to install something system-wide...


 
Old 05-19-2004, 02:17 PM   #3
Utah
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 73

Rep: Reputation: 15
I installed this from Adobe also (using their INSTALL script) It put the files in /usr/local/Acrobat5 .

So now how do I have Mozilla launch Acrobat when I click on a PDF file?

I tried it and it prompts for an application to use and I point it to the acroread script (in the bin dir.). But Mozilla just seems to download the file to /tmp but it never opens in Acrobat.

If I try to execute the acroread script, I get:

Warning: charset "UTF-8" not supported........
aborted

Any Ideas?

Thanks,
Utah
 
Old 05-19-2004, 09:20 PM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
yea its a bug but i forget the fix google around for it thats how i found it.
 
Old 05-19-2004, 09:43 PM   #5
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
As root, edit the acroread script:

Add the following lines just below #! /bin/sh

Code:
LANG=en_US
export LANG

I hope this solves your problem
--Ian
 
Old 05-20-2004, 09:56 AM   #6
Utah
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 73

Rep: Reputation: 15
I'll give that a try and get back.
Thanks,
Utah
 
Old 05-24-2004, 10:13 PM   #7
DankVantam
LQ Newbie
 
Registered: May 2004
Location: Portland
Distribution: Fedora Core 1
Posts: 4

Rep: Reputation: 0
Really stupid question

I am even more of a newbie. I just installed Linux (Fedora Core 1) yesterday and am trying to install the Acrobat reader. I haven't even gotten as far as unzipping the file. I have absolutely no idea what to do with the file. When I go to the Acrobat site I just get a tar.gz file. What am I supposed to do with this file?
 
Old 05-24-2004, 10:59 PM   #8
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Untar the file using
Code:
tar -xzvf nameOfFile.tar.gz
You should now have a directory called nameOfFile, change into it.

There will be a text file in the directory that includes installation instructions

You will probably need to edit acroread (type "vi acroread"), and add the line that I posted in and above post.


I hope this helps
--Ian

Last edited by IBall; 05-24-2004 at 11:03 PM.
 
Old 05-25-2004, 06:38 PM   #9
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Rep: Reputation: 30
Then for the plugin to work, you will copy the file nppdf.so from the /usr/local/Acrobat5 \
/Browsers/intellinux directory to your browser's pluging directory.

If you want the program to run from the command line, make a link in your path (/usr/local/bin)
by making a symbolic link to the acroread file like this:

be root and have the # sign:

ln -s /usr/local/Acrobat5/bin/acroread /usr/local/bin

and then you are in business.

If you want a desktop icon, follow your desktop's convention for creating
links to the application and you should have an icon picture to choose from
somewhere when you browse for it.
 
Old 05-25-2004, 11:39 PM   #10
DankVantam
LQ Newbie
 
Registered: May 2004
Location: Portland
Distribution: Fedora Core 1
Posts: 4

Rep: Reputation: 0
Still confused

I'm still confused. I managed to get Acrobat Reader loaded on my machine and I can indeed view .pdf files. The problem is that the files get downloaded to my /tmp directory and then I have to manually open up the .pdf file within Acrobat Reader. This is an enormous hassle and I hope this isn't how the application is supposed to work. I don't understand how I'm supposed to edit AcroRead and I don't understand how changing the language setting is going to have anything to do with the application opening up when I try to open a .pdf file.

Am I missing something?
 
Old 05-26-2004, 04:16 AM   #11
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Quote:
I'm still confused. I managed to get Acrobat Reader loaded on my machine and I can indeed view .pdf files. The problem is that the files get downloaded to my /tmp directory and then I have to manually open up the .pdf file within Acrobat Reader. This is an enormous hassle and I hope this isn't how the application is supposed to work.
For Mozilla, your plugin directory is "pathToMozillaDirectory/plugins" Simply copy the file
Code:
/usr/local/Acrobat5/Browsers/intellinux/nppdf.so
to the mozilla plugin directory. (You will need to be root to do this).
Also, make sure that "acroread" is in your path. Make a symbolic link to it in /usr/local/bin, by typing this, as root:
Code:
ln -s /usr/local/Acrobat5/bin/acroread /usr/local/bin
You will be able to type acroread at the command line, and it will run.

Quote:
I don't understand how I'm supposed to edit AcroRead and I don't understand how changing the language setting is going to have anything to do with the application opening up when I try to open a .pdf file.
Acroread is actually a shell script. You can edit it, using your favourite text editor, such as vi. As I said before, simply add the lines
Code:
LANG=en_US
export LANG
below the line #! /bin/sh.
I think that this is a bug in Acrobat, but it is not that hard to rectify.

I hope this helps
Ian
 
Old 05-26-2004, 09:37 AM   #12
DankVantam
LQ Newbie
 
Registered: May 2004
Location: Portland
Distribution: Fedora Core 1
Posts: 4

Rep: Reputation: 0
Still having problems

I did what you said (I think) but I still can't get AcroRead to automatically open when I click on a .pdf hyperlink in my browser. I continue to get the download dialog box that shows the file being saved to a directory which I then have to go in to open.

I don't know what you mean by AcroRead being run as a command. I typed in the code that you gave me but when I type AcroRead at the command line (as root) I get a "command not found" message. Am I still missing something?

Thanks for your patience.
 
Old 05-26-2004, 08:04 PM   #13
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
The file is called acroread. Linux is case sensitive, so Command is different from command.

If you did as I said and created a symbolic link in /usr/local/bin, typing acroread at the command prompt should launch Acrobat Reader

I hope this helps
--Ian
 
Old 05-26-2004, 10:36 PM   #14
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Rep: Reputation: 30
Ian

Thanks for your patient and detailed replies. I am going to test this out tomorrow when I install Linux on my computer. I'll let you know how it goes
 
Old 05-29-2004, 12:15 AM   #15
tryitmsg
LQ Newbie
 
Registered: May 2004
Posts: 2

Rep: Reputation: 0
Acrobat reader 5.08 for linux

it has little bugs and with the help of these forms i could fix them
http://www.linuxquestions.org/questions/history/179129


for
Warning: charset "UTF-8" not supported........
aborted

Add the following lines just below #! /bin/sh

LANG=en_US
export LANG

and copy this to the netscape or mozilla plugin folder
in my sys /usr/local/netscape/plugins as i installed netscape
the file is
/usr/local/Acrobat5/Browsers/intellinux/nppdf.so

this will make acrobat reader default(i suppose) for the PDF files (it worked for me)

i suggest to read http://www.linuxheadquarters.com/how.../acrobat.shtml

bye and thanks

nag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
acrobat reader 7 alaios Debian 4 05-19-2005 10:48 AM
Acrobat Reader unixfreak *BSD 4 07-24-2004 10:15 AM
mplayer installation error and acrobat reader phi_rad Linux - Newbie 4 11-08-2003 11:07 AM
Acrobat Reader Installation andrewt Linux - Software 7 10-11-2003 10:59 AM
acrobat reader samon Linux - Software 15 02-24-2003 05:56 AM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration