LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 08-07-2005, 01:53 AM   #1
bhxs1809
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Rep: Reputation: 0
Post Why cannot compute suffix of object files?


When I install glibc-2.3.4 in chapter 6.11,there is an error :checking for suffix of object files... configure: error: cannot compute suffix of object files:cannot compile
See 'config.log' for more details.

Why?And how can I continue.thanks!
 
Old 08-08-2005, 01:13 AM   #2
shotokan
Member
 
Registered: Mar 2005
Distribution: slackware, LFS
Posts: 204

Rep: Reputation: 30
I think the problem has to do with gcc.
Take a look at http://www.linuxquestions.org/questions/history/339554
Could you post the whole error?
 
Old 08-08-2005, 06:22 AM   #3
bhxs1809
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by shotokan
I think the problem has to do with gcc.
Take a look at http://www.linuxquestions.org/questions/history/339554
Could you post the whole error?

Thanks!
 
Old 04-13-2008, 10:14 AM   #4
lakeat
LQ Newbie
 
Registered: May 2007
Location: Shanghai
Distribution: Fedora, Kubuntu, IRIX
Posts: 11

Rep: Reputation: 0
I suggest to look at LD_LIBRARY_PATH or LD_LIBRARYN32_PATH, and you may fix it!

Daniel
 
0 members found this post helpful.
Old 05-22-2008, 07:47 AM   #5
selmaguzel
LQ Newbie
 
Registered: May 2008
Posts: 2

Rep: Reputation: 0
Hi,
I get the same error(checking for suffix of object files... configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
) above after running the command below:
BUILD_CC="gcc" CC="${CLFS_TARGET}-gcc" \
AR="${CLFS_TARGET}-ar" RANLIB="${CLFS_TARGET}-ranlib" \
../glibc-2.6.1/configure --prefix=/usr \
--libexecdir=/usr/lib/glibc --host=${CLFS_TARGET} --build=${CLFS_HOST} \
--disable-profile --enable-add-ons --with-tls --enable-kernel=2.6.0 \
--with-__thread --with-binutils=${CLFS}/cross-tools/bin \
--with-headers=${CLFS}/usr/include --cache-file=config.cache

But I don't know how must I set LD_LIBRARY_PATH or LD_LIBRARYN32_PATH and fix
Can you say according to what clearly?
Thanks in advance.
 
Old 07-18-2010, 01:07 AM   #6
cjrcl
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
Lightbulb

Quote:
Originally Posted by bhxs1809 View Post
When I install glibc-2.3.4 in chapter 6.11,there is an error :checking for suffix of object files... configure: error: cannot compute suffix of object files:cannot compile
See 'config.log' for more details.

Why?And how can I continue.thanks!
I encountered this problem on my RHEL 5.5 Server, the solution to which is rather trickey: first, you should install gmp by ./configure && make && make install; second, install mpfr by ./configure --with-gmp=/usr/local && make && make install; third, it is vital to move any .so files pertaining to gmp or mpfr from /usr/local to another place while leaving .a files untouched; fourth, you can now go into the gcc folder and do make clean && ./configure --prefix=/usr --with-gmp=/usr/local --with-mpfr=/usr/local && make -j 4 && make install; last, restore those .so files you moved.
 
0 members found this post helpful.
Old 07-18-2010, 05:29 PM   #7
bernard.wolsieffer
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
I got the same error attempting to compile g++ 4.5.0

so I can use other things that need g++.
cannot compute suffix of object files: cannot compile
 
Old 08-02-2010, 11:04 PM   #8
peterstockwell
LQ Newbie
 
Registered: Aug 2010
Posts: 1

Rep: Reputation: 0
Thumbs up This fixed my problem

Quote:
Originally Posted by cjrcl View Post
I encountered this problem on my RHEL 5.5 Server, the solution to which is rather trickey: first, you should install gmp by ./configure && make && make install; second, install mpfr by ./configure --with-gmp=/usr/local && make && make install; third, it is vital to move any .so files pertaining to gmp or mpfr from /usr/local to another place while leaving .a files untouched; fourth, you can now go into the gcc folder and do make clean && ./configure --prefix=/usr --with-gmp=/usr/local --with-mpfr=/usr/local && make -j 4 && make install; last, restore those .so files you moved.
Thanks to cjrcl for this post - it solved the problem I was having compiling gcc-4.5.1 on
Fedora 13, running on a Mac under VMWare. I note that the latest gcc now needs an
additional library mpc, so I just continued the system mentioned above with configure and
--with-mpc=/usr/local and everything worked brilliantly.
Thanks again.
 
Old 12-17-2010, 08:18 AM   #9
purus.mail@gmail.com
LQ Newbie
 
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0
Thanks cjrcl excellent solution... worked for me to compile gcc 4.5.1 in centos 5.5
 
Old 12-22-2011, 12:44 PM   #10
ron7000
Member
 
Registered: Nov 2007
Location: CT
Posts: 53
Blog Entries: 1

Rep: Reputation: 16
works for gcc 4.3.6 on itanium ia64 novell sles 10

thanks for the hint. moved the *.so files out of the directories where I have them installed to a temporary location for
/usr/local/gmp-5.0.1
/usr/local/mpfr-3.0.0
/usr/local/mpc-0.8.2

started fresh with ./configure, then make all and it built gcc 4.3.6.

this was on a server running Novell Linux Enterprise Server (SLES) version 10 for Itanium (ia64) that originally came with gcc 4.1.2. I had in the past built gcc-4.2.4 and I used 4.2.4 to build 4.3.6 successfully following the above.
 
Old 12-24-2011, 11:39 AM   #11
david@verdegris.net
LQ Newbie
 
Registered: Dec 2011
Posts: 1

Rep: Reputation: Disabled
Thank you a lot.

I needed a 2 steps compiling.
I moved mpfr, gmp, and mpc shared librairies from /usr/local/lib. Then, running make led to "missing gmp lib". So, I moved back the libraries and ran make once again(without any make clean between), and it succeeded.
 
Old 03-05-2012, 12:04 PM   #12
mlcurry
LQ Newbie
 
Registered: Apr 2011
Posts: 2

Rep: Reputation: 0
A tip for those from the future

I came across this thread when investigating a failing install process for GCC. Lakeat had a good tip, if vague. You should add to your LD_LIBRARY_PATH the path to your installations for MPFR, MPC, and GMP. This works regardless of whether you install in your home directory or not.
 
  


Reply

Tags
configure, g++, libraries


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
glibc in capter 6 -- error: cannot compute suffix of object files Yoyo302 Linux From Scratch 23 05-21-2010 08:28 AM
Relinking object files villie Programming 2 10-13-2005 10:44 AM
how to create unlinked object files from source irfanhab Programming 1 08-18-2005 12:11 PM
Object Files in Slackware? okter Programming 1 05-11-2005 03:16 PM
Event driven object-to-object: C++ template class mecanism ( NOT STL or STDC++) bretzeltux Programming 2 12-23-2003 02:45 PM


All times are GMT -5. The time now is 03:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration