LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 02-13-2005, 07:38 PM   #1
jayprakash
LQ Newbie
 
Registered: Sep 2004
Location: Slovakia
Distribution: Ubuntu Edgy
Posts: 16

Rep: Reputation: 0
Unhappy binutils 1 pass :: broken pipe (?)


/bin/sh ../../binutils-2.15.91.0.2/binutils/../ylwrap "bison -y" ../../binutils-2.15.91.0.2/binutils/arparse.y y.tab.c arparse.c y.tab.h arparse.h -- -d
../../binutils-2.15.91.0.2/binutils/../ylwrap: line 86: 30971 Broken pipe $prog ${1+"$@"} "$input"
make[3]: *** [arparse.c] Error 1
make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/binutils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/lfs/sources/binutils-build/binutils'
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory `/mnt/lfs/sources/binutils-build/binutils'
make: *** [all-binutils] Error 2


does any one nows please?


technical:
mandrake 10
LFS 6
downloaded complete package 133MB so no "bleeding edge" packages
pentium 3 650MHz
512 MB ram


PS:
I searched whole day in google, lfs, linux[anything].org.net... and nothing

Last edited by jayprakash; 02-13-2005 at 07:40 PM.
 
Old 02-14-2005, 12:16 PM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

Interesting problem. Did some searching of my own and came up with little, but it could be a mandrake related problem. Take a look here, especially the reply:

http://www.linuxquestions.org/questi...postid=1171543

I must admit that a different package was installed (wine) but the bison problem could be related. And checking if M4 is installed shouldn't be that hard

Anyway, hope this gets you going again.
 
Old 02-14-2005, 06:21 PM   #3
jayprakash
LQ Newbie
 
Registered: Sep 2004
Location: Slovakia
Distribution: Ubuntu Edgy
Posts: 16

Original Poster
Rep: Reputation: 0
be blessed ))

this worked
M4 was missing
but in 'make install' hapened permission denied error, but i saw already this somewhere here

so thank you very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
5.14. Binutils-2.15.91.0.2 - Pass 2 error! Flash_G Linux From Scratch 5 08-20-2006 07:02 AM
Binutils-pass 1 v. 6.1 microsoft/linux Linux From Scratch 10 09-04-2005 08:27 AM
#Error: 5.4. Binutils-2.15.94.0.2.2 - Pass 1 ukyo Linux From Scratch 2 06-02-2005 05:37 AM
binutils-2.15.92.0.2 first pass, error rogerslin Linux From Scratch 7 12-20-2004 06:44 PM
binutils chapter 5 pass 2 qod Linux From Scratch 3 11-03-2003 01:39 PM


All times are GMT -5. The time now is 10:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration