LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 03-03-2010, 05:57 AM   #1
rajeesh_r@cms.com
LQ Newbie
 
Registered: Dec 2009
Posts: 13

Rep: Reputation: 0
usb hard disk unable to mount in at91rm9200 board


Hi,

I am using linux kernel 2.6.21 for the AT91RM9200 board .
While connecting usb hard disk to the board it is not taking
ie while checking the nod with the command
ls /dev there is no nod
How can i mount this hard disk to my board
Please help me

Error Messages shown below

usb 1-2: new full speed USB device using at91_ohci and address 2
usb 1-2: device not accepting address 2, error -62
usb 1-2: new full speed USB device using at91_ohci and address 2
usb 1-2: device not accepting address 2, error -62
usb 1-2: new full speed USB device using at91_ohci and address 4
usb 1-2: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 4
usb 1-2: new full speed USB device using at91_ohci and address 6
usb 1-2: configuration #1 chosen from 1 choice
scsi1 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 6
usb 1-2: new full speed USB device using at91_ohci and address 10
usb 1-2: new full speed USB device using at91_ohci and address 11
usb 1-2: configuration #1 chosen from 1 choice
scsi2 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 11
usb 1-2: new full speed USB device using at91_ohci and address 12
usb 1-2: new full speed USB device using at91_ohci and address 14
usb 1-2: device descriptor read/all, error -62
usb 1-2: new full speed USB device using at91_ohci and address 17
usb 1-2: configuration #1 chosen from 1 choice
scsi3 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 17
usb 1-2: new full speed USB device using at91_ohci and address 20
usb 1-2: configuration #1 chosen from 1 choice
scsi4 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 20
usb 1-2: new full speed USB device using at91_ohci and address 21
usb 1-2: new full speed USB device using at91_ohci and address 22
usb 1-2: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 22



With Regards
Rajeesh

Last edited by rajeesh_r@cms.com; 03-04-2010 at 06:16 AM.
 
Old 03-05-2010, 06:48 PM   #2
murankar
Member
 
Registered: Jan 2008
Location: Cleveland Ohio
Distribution: Current CentOS 5.6
Posts: 117

Rep: Reputation: 20
first try lsusb in a terminal. See if it is being seen by the usb bus system. Or you can do a reboot and enter the boot order option to the bios and see if the bios is seeing it as an option for booting.

If after all that and the drive is seen; then your issue is in the os most likely.

Another thing you could try is booting a live version of your distro and see if that picks up the drive. If it does then it's your os not the board.

to mount the drive you would have to do something like this

cd /mnt or cd /tmp
mkdir dir_name
mount /dev/sd? /mnt/dir_name
or
mount /dev/sd? /tmp/dir_name

you may have to add additional stuff to the mount command like file system type for it to work.
 
Old 03-15-2010, 04:29 PM   #3
nini09
Member
 
Registered: Apr 2009
Posts: 981

Rep: Reputation: 67
The at91_ohci driver and hard disk negotiating configuration is failure. You need dip into why configuration negotiation is failure.
 
Old 03-16-2010, 11:30 PM   #4
rajeesh_r@cms.com
LQ Newbie
 
Registered: Dec 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Hi,

in the configuration what I need to enable ............
I enabled USB Mass storage section in the kernel level configuration

Thanks
 
Old 03-19-2010, 02:17 PM   #5
nini09
Member
 
Registered: Apr 2009
Posts: 981

Rep: Reputation: 67
Do you enable SCSI disk and USB EHCI?
 
Old 03-19-2010, 11:39 PM   #6
rajeesh_r@cms.com
LQ Newbie
 
Registered: Dec 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Question

I have enabled

SCSI device support
Legacy /proc/scsi support
SCSI disk support

Support for Host side USB
USB Mass Storage support
USB Device File system
OHCI HCD Support


Where need to enable USB EHCI ?? I did n't see this configuration in menuconfig


Thanks and Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount hard disk gimmereeson Linux - Server 1 05-16-2008 03:25 AM
unable to mount USB hard disk dmsreddy Linux - Hardware 13 11-04-2007 06:53 PM
Trying to mount a USB Hard Disk guarriman Linux - Hardware 2 07-12-2007 03:33 AM
How do I get my USB 2.0 Hard Disk to MOUNT? Hawky Linux - Newbie 5 10-26-2004 12:11 AM
How to mount my usb hard disk? raoqn Fedora 1 04-01-2004 05:21 AM


All times are GMT -5. The time now is 06:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration