LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-06-2012, 11:51 PM   #1
mah454
Member
 
Registered: Oct 2009
Location: Iran
Distribution: Debian , Ubuntu , RHEL , CentOS , NetBill
Posts: 132

Rep: Reputation: 15
xrandr add newmode to VGA-0


Hello

I want to use xrandr to add newmode in VGA-0 but it's automaticaly goes to HDMI-0 .
How can I force xrandr to add my mode into VGA-0
This output :

Code:
kernel@kernel-Ubuntu:~$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
kernel@kernel-Ubuntu:~$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
kernel@kernel-Ubuntu:~$ xrandr 
Screen 0: minimum 8 x 8, current 1152 x 864, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0     59.8  
   1152x864       60.0* 
   800x600        72.2     60.3     56.2  
   680x384       119.9    119.6  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4  
   320x240       120.1  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
  1280x1024_60.00 (0x270)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
kernel@kernel-Ubuntu:~$
 
Old 11-07-2012, 07:01 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You need to use the --addmode option. It's documented in the xrandr man page.

Adam
 
Old 11-07-2012, 01:56 PM   #3
mah454
Member
 
Registered: Oct 2009
Location: Iran
Distribution: Debian , Ubuntu , RHEL , CentOS , NetBill
Posts: 132

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by adamk75 View Post
You need to use the --addmode option. It's documented in the xrandr man page.
No ! Before "--addmode" I should define with "--newmode" .
Note : Read example in end of xrandr manual page .
 
Old 11-07-2012, 02:00 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Yes. According to your output above, you were already defining a new mode with --newmode. The next step is using --addmode, as I said.

Adam
 
Old 11-07-2012, 02:25 PM   #5
mah454
Member
 
Registered: Oct 2009
Location: Iran
Distribution: Debian , Ubuntu , RHEL , CentOS , NetBill
Posts: 132

Original Poster
Rep: Reputation: 15
How can fix this problem ?
My mode add to HDMI ! but i have not HDMI connection , I use VGA connection .
 
Old 11-07-2012, 02:28 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You
already know the answer. You use --newmode to create the mode, then --addmode to add it to the correcy output, just as it's documented in the xorg.conf file.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop + Dell monitor: no VGA output with Xrandr mike11 Linux - Newbie 3 05-16-2010 08:58 PM
[SOLVED] Black screen, works on VGA to monitor but not on VGA to TV junkjunk Ubuntu 14 07-07-2009 06:32 AM
radeon and dual head, to xrandr or not to xrandr, that's the question i92guboj Linux - Desktop 1 06-17-2009 06:48 AM
Add new mode to Xrandr conf! drakeman007 Linux - Newbie 5 03-07-2009 08:04 AM


All times are GMT -5. The time now is 05:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration