LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 06-25-2013, 03:15 PM   #1
yurmuki
LQ Newbie
 
Registered: Jan 2012
Posts: 7

Rep: Reputation: 0
Unable to install openldap in debain based elementary OS


Hi while installing openldap when i enter the command:
"apt-get install slapd"
I get the following output
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
slapd : Depends: libldap-2.4-2 (= 2.4.28-1.1ubuntu4.1) but 2.4.28-1.1ubuntu4.2 is to be installed
E: Unable to correct problems, you have held broken packages.


Please help.
 
Old 06-27-2013, 12:49 AM   #2
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,216

Rep: Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121
Hi,

we should be able to help you, but need more information. So, I have a few questions.

- Did you do an "apt-get update" before doing "apt-get install slapd"?
- Have you done and "apt-get upgrade" recently?
- Have you installed any packages "by hand"? (Eg download .deb from random place and install)?
- Can you post your /etc/apt/sources.list and /etc/apt/sources.list.d/* (if any)
- You say this is "debian based" yet the package version strings have "ubuntu" in them": can you explain why?

Evo2.
 
Old 06-27-2013, 04:00 AM   #3
yurmuki
LQ Newbie
 
Registered: Jan 2012
Posts: 7

Original Poster
Rep: Reputation: 0
Hi Evo,

Thanks for the reply.

I run update and upgrade just before running this command. I want to install "openldap" and for this I am running the command apt-get install slapd.

Below is the output of sources list.
I am running this distro:

http://elementaryos.org/

root@hiweed:/home/waqas# cat /etc/apt/sources.list
# deb cdrom:[elementary OS 0.2 _Luna_ - Beta 2 i386 (20130506)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://pk.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://pk.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://pk.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise universe
deb http://pk.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://pk.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://pk.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://pk.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://pk.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

Thanks.
 
  


Reply

Tags
openldap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Elementary Studio GTK Theme - Fusion of Elementary and Ubuntu Studio Themes LXer Syndicated Linux News 0 01-18-2011 08:21 PM
LXer: What is Nautilus Elementary And How to Install Nautilus Elementary in Ubuntu Lu LXer Syndicated Linux News 0 05-21-2010 01:10 AM
Unable to boot after install of NetSecL (Slackware based) EricTRA Slackware 6 03-02-2010 01:21 PM
OpenLDAP-based SSH login by groups fantasygoat Linux - Security 14 11-02-2009 11:58 PM
Disabling ICMP (Ubuntu/Debain based systems) brianthegreat Linux - Security 3 03-28-2006 09:01 AM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration