LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 04-20-2011, 06:44 AM   #1
vikrang
Member
 
Registered: Jan 2011
Location: India
Distribution: Slackware 13.1, Squeeze
Posts: 119

Rep: Reputation: 7
openbox installation on top of Sabayon LXDE


I have very recently installed OpenBox from my default Sabayon 5.5 LXDE install

I am told that LXDE uses OpenBox as a Window Manager..

I am interested in removing the LXDE part (lxpanel,icons and LXDE specific features) from the install and want to convert it into a pure OpenBox installation (as they would call it)..

Currently , I suspect LXDE taking over the Desktop even when I choose "OpenBox" session in LXDM ..This is because I didnt even define an autostart.sh file and the wallpaper of LXDE loaded automatically..

Also , I tried starting from scratch by copying /etc/xdg/openbox/autostar.sh and copyng to ~/.config/openbox/autostart.sh and editing ...I installed a few panels,obconf,cairo-dock and gave the options in the autostart.sh in config/openbox

I seem to find no effect on restart..Somehow the default LXDE takes precedence over OB

My simple doubt is should I uninstall LXDE and then proceed with OB?
 
Old 04-20-2011, 08:07 AM   #2
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Rep: Reputation: 78
add openbox-session to your .xinitrc file. This will load openbox when you startx
 
Old 04-20-2011, 02:19 PM   #3
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
Quote:
Originally Posted by bret381 View Post
add openbox-session to your .xinitrc file. This will load openbox when you startx
I thought that login managers ignore .xinitrc?
 
Old 04-20-2011, 03:14 PM   #4
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Rep: Reputation: 78
Quote:
Originally Posted by MTK358 View Post
I thought that login managers ignore .xinitrc?
You are right, I did not read the full post, but simply scanned over it. my bad

Looking at LXDM.orgs wiki it shows:

"If you want to have a choice between starting in LXDE or other options (including simply Openbox) then it's important not to use LXDM versions earlier than 0.3.0, as they have a bug which interferes with sessions other than LXDE. The bug was worked around by adding support for .dmrc in LXDM 0.3.0."

make sure your using the most recent version of lxdm
 
Old 04-21-2011, 12:37 AM   #5
vikrang
Member
 
Registered: Jan 2011
Location: India
Distribution: Slackware 13.1, Squeeze
Posts: 119

Original Poster
Rep: Reputation: 7
Cool

Thanks Bret381...I suppose I have the latest version of Lxdm because your suggestion just worked !

Now I am thrilled to have an OB session up and running ..I also made some changes to autostart.sh and now everrything looks good!

One small problem , dont know if it can be set right, When I open Libreoffice , the default window which first pops up showing the ICON & "Libre OFFICE 3.0" appears like a plain black rectangle...Maybe the theme also affects the windows of these apps..If window theme can be disabled for LO , pl let me know

Also , initially the network flopped...I wasnt able to up the network...Later I used the terminal used wpa_supplicant and downloaded Wicd for this ...Also If there is some network daemon to start wifi during boot , pl let me know

Thx again!
 
Old 04-21-2011, 09:43 AM   #6
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Rep: Reputation: 78
I would think wicd would be all you need to start at login. I don't use wireless though so hard to say

I know in OpenOffice, there was a way to not use the system theme in one of the settings somewhere, but not sure where. It's been a while
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can I tweak LXDE/Openbox to do this? jsteel Linux - General 4 12-16-2010 03:37 AM
obconf always segmentation faults! Any other utility for openbox-lxde? Holering Slackware 8 10-20-2010 05:47 PM
Do you think LXDE/OpenBox should replace ........ Wm/Desktop in Slackware? samac Slackware 7 03-14-2010 06:24 AM
KDE/OpenBox/LXDE samac Slackware 4 11-21-2009 09:10 AM
lxde/openbox restarts computer keratos Linux - Desktop 0 11-09-2008 05:11 AM


All times are GMT -5. The time now is 06:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration