LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 11-13-2008, 06:27 PM   #1
rizwanrafique
Member
 
Registered: Jul 2006
Distribution: Debian, Ubuntu, openSUSE, CentOS
Posts: 147

Rep: Reputation: 19
how to setup dual monitors with big desktop on ati card


Hello,
Trying to enable big desktop for two monitors on an ATI Redeon card that has one vga and one dvi output port.

Have been fighting with this for few hours now. After much surfing and searching through forums and irc :-)

Here is my xorg.conf. It's basically a copy from somewhere I found.

Any clues/ideas? No idea what I'm doing wrong.

Code:
Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
EndSection

Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
EndSection

Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "EnableMonitor" "crt2,lvds"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "DesktopSetup" "horizontal"
    Option "Capabilities" "0x00000800"
    Option "Mode2" "1280x1024"
    Option "VRefresh2" "60"
    Option "Centermode" "off"
    Option "PseudoColorVisuals" "off"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
        Viewport 0 0
        Depth 24
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection
Mainly I followed these links and they all seem to make sense.

http://ubuntuforums.org/showthread.php?p=1773544
http://forums.fedoraforum.org/showthread.php?t=162188
http://jen3ral.wordpress.com/2008/04...i-big-desktop/

Oh yes, I'm on Ubuntu 8.10 with fglrx driver. And I've tried this with compiz on and off.

Any pointers will be highly appreciated.

Thanks,
Rizwan
 
Old 11-14-2008, 09:07 AM   #2
rizwanrafique
Member
 
Registered: Jul 2006
Distribution: Debian, Ubuntu, openSUSE, CentOS
Posts: 147

Original Poster
Rep: Reputation: 19
hmm. bump :-)
 
Old 12-08-2008, 11:41 PM   #3
lab-rat
LQ Newbie
 
Registered: Dec 2008
Distribution: Fedora Core 9, suse11.3 ,Ubuntu-super 10.10
Posts: 17

Rep: Reputation: 4
Re : how to setup dual monitors with big desktop on ati card

Trying to enable big desktop for two monitors on an ATI Redeon card that has one vga and one dvi output port.

Have been fighting with this for few hours now. After much surfing and searching through forums and irc :-)

Here is my xorg.conf. It's basically a copy from somewhere I found.

Any clues/ideas? No idea what I'm doing wrong.

_____________ Snip Snip... old Xorg.conf Quote removed here _______________________

..... Oh yes, I'm on Ubuntu 8.10 with fglrx driver. And I've tried this with compiz on and off.

Any pointers will be highly appreciated.

Thanks,
Rizwan





Hi Rizwan:

I'm not sure if you found an answer to your Xorg file issue yet .
But , seeing as i have an ATI 9550 card [dual head] 256 megs vram ...
etc, etc .
I have a working dualhead layout working on FC9, using 2 LG screens.
both are L1720B's [ analogue type ]
As you asked for a working Xorg.conf file to work with here goes.

Note Rizwan ... it is using the fglrx driver Not the ATI driver in the Section "Device" area.

Also note the BusID notation in the same areas. they are not quite the same. ok... and if your system sees the card output differently than mine does, you can change the LeftOf in the "ServerLayout" to RightOf...[ that will swap the monitors virtualy , left one for the right one ].
Also note that I am using "DualHead" "True" rather than "Xinerama" "on" to get the desired screen setting. and also take note that on Screen 1 .. the View port is 1024 0 not 0 0 as it is on Screen 0, This is because the right hand screen starts at X=1024 pixels away from the upper left corner of the left hand screen,which is x=0,y=0 [ the bottom of both screens is 768 pixels down from the top ], so you get 1024 x 768 for screen size for both... and thus with 2 , the virtual size becomes 2048x 768 pixels.

Ok so I am long winded ...lol

Don't forget to back up your original, before you use this one , eh ...

Here is Your file below

____________________________________________________

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
Screen "aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
Option "DualHead" "true"
Option "Clone" "off"
EndSection

Section "Files"
EndSection

Section "Module"
Load "extmod"
Load "dbe"
Load "freetype"
Load "dri"
Load "v4l"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
DisplaySize 340 270
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-1"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
DisplaySize 340 270
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-1"
Driver "fglrx"
BusID "PCI:1:0:1"
Screen 1
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-1"
Device "aticonfig-Device[0]-1"
Monitor "aticonfig-Monitor[0]-1"
DefaultDepth 24
SubSection "Display"
Viewport 1024 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

_____________________________________________________________

Ok ... so copy that file into Kwrite and save it as xorg.conf in /home/rizwan/Documents.

then open superuser file manager , and copy your new xorg.conf file to /etc/X11 folder .

If you cant find a super user file manager you can open Konsol
&& do SU to root
then you can copy the files or move them as needed

you will definitely need to have the new file in the X11 folder
when you are done moving the old one out.

Hope all this helps

Rat
 
Old 12-09-2008, 12:20 AM   #4
lab-rat
LQ Newbie
 
Registered: Dec 2008
Distribution: Fedora Core 9, suse11.3 ,Ubuntu-super 10.10
Posts: 17

Rep: Reputation: 4
This one should have been a no brainer, but I missed it in my caveats in the previous explanation ....

The values here work for my monitors .

DisplaySize 340 270
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0

So make sure you change those, to the values that will work for your monitors . or you may get some boot issues.

if you do get boot issues ,by forgetting to change them... , you can fix it as root in run level 3
To do that ,,, when grub starts up and says booting Fedora kernel in xxx..
seconds tap the space bar to get the grub selector open ... select the kernel you are using . press the A key .. then press the <space bar > and type 3
then the end of the line will change from ,,,, rhgb /quiet to rhgb /quiet 3.

that will boot you to run level 3

login as root

cd /etc/X11
then type in vi xorg.conf

edit your xorg.conf file

save your file

then cd /
then
init 5 or telinit 5 and your GUI log in screen should load
as it should as dual screen [ span mode ]

If you dont know how to use VI , you can find out how in the vi man pages


Have fun

Rat
 
Old 12-12-2008, 02:01 PM   #5
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
system-config-display in rhel5 there is an option for dual head.
 
Old 12-12-2008, 02:13 PM   #6
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
Try this command
Code:
aticonfig --dtop=horizontal
 
Old 12-20-2008, 07:22 AM   #7
lab-rat
LQ Newbie
 
Registered: Dec 2008
Distribution: Fedora Core 9, suse11.3 ,Ubuntu-super 10.10
Posts: 17

Rep: Reputation: 4
Quote:
Originally Posted by Unmindfulawe View Post
Try this command
Code:
aticonfig --dtop=horizontal
Hi Folks / nmindfulawe :

Good point mindful.. thanks

Yep.I used to do that on my Fed 8 install and it worked really well ,,[ same vid card ATI 9550 ,, etc].

What I did was, run aticonfig --initial . then boot to GUI login .
then rebooted to level 3, [ so X wasnt running , then do as you said , aticonfig --dtop=horizontal ], and all was good .

But , with the way Fed9 has the video layout setup . I found that didn't work for me so well. it kept coming up as cloned ,and if you ran the display app for your distro , it would go through the routine of multi-monitor setup ,config ,,,and when I get to the point where all is set ,and go to click apply .... [ survey SAYS ... baaaaahhh ] lol
the app wouldn't apply it ,,not even as root.


So that is why i suggested using the xinerama on , clone off and Dualhead=true scenario.

so folks , if dualhead=true . isnt your cup of tea ,, then as nmindfulawe said, try that method.

if your spin of Fed9 is different than mine [ mine was at the time,straight KDE , no Gnome]
then try aticonfig --dtop=horizontal
and see if you like that better .

'nuff said on this for now


Rat
 
Old 12-24-2008, 10:22 AM   #8
rizwanrafique
Member
 
Registered: Jul 2006
Distribution: Debian, Ubuntu, openSUSE, CentOS
Posts: 147

Original Poster
Rep: Reputation: 19
Thanks lab-rat.

At the end I ditched ATI altogether. Way too much hassle. I had another nvidia card and decided to use that.
 
  


Reply

Tags
ati, big, desktop, dual, fglrx, monitor, multiple


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please check my xorg.conf for ATI big-desktop dual monitors DieselSA Linux - Hardware 14 05-13-2008 07:22 AM
FGLRX - 2.6.20 - Dual Monitors? Big Desktop? sovietpower Slackware 5 02-22-2007 08:32 PM
ATI - Dual Head - Big Desktop (mouse jumps) ... Fix? srafx Linux - Hardware 3 10-09-2006 01:43 PM
SUSE 10.0 two monitors on 1 ATI card (laptop + Desktop displays) setup nayden Suse/Novell 1 10-20-2005 04:39 PM
Dual monitors and extended desktop on ATI tofumonsters Linux - Newbie 1 04-06-2005 02:06 PM


All times are GMT -5. The time now is 02:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration