LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 08-16-2007, 02:23 PM   #1
rh_bomani
Member
 
Registered: Apr 2006
Posts: 42

Rep: Reputation: 15
Fluxbox not starting in VNC session


Hello,

I'm running Linux Network Security Toolkit v 1.5. It's uses Fedora Core 5 kernel.
When I start a VNC session from NST WUI no desktop is displayed. All I get is a black screen w/ big X for my cursor. I'm fortunate to have another NST box to compare settings and I believe it's an issue w/ Fluxbox and/or X.
My fluxbox.log ends with "Error: Couldn't connect to XServer" and my .xsessions-error file contains

"Warning: Failed to open file(/usr/share/fluxbox/nls/en_US/fluxbox.cat)
for translation, using default messages.
Logging to: /root/fluxbox.log
Xlib: connection to ":6.0" refused by server
Xlib: No protocol specified"

I have compared both .fluxbox directories and they contain the same files. No changes have been made on my part.

I'm running NST v1.5.0 on P4 3GHz machine w/ 1Gb of ram. This box is being used only for Snort.

Thank in advance,

rh_bomani

P.S. I have taken a look at a similiar thread http://sourceforge.net/forum/message.php?msg_id=3744677 but our causes are dissimilar.
 
Old 08-17-2007, 09:01 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,771

Rep: Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283
You have to edit ~/.vnc/xstartup and add the following as the last line:
Code:
/path/to/fluxbox &
 
Old 08-17-2007, 09:43 AM   #3
rh_bomani
Member
 
Registered: Apr 2006
Posts: 42

Original Poster
Rep: Reputation: 15
The issue is now resolved. I took a look at both startup logs in VNC Session Manager and noticed that .Xauthority was not being recreated on the broken machine. I simply deleted the old .Xauthority and restarted VNC. Here is a copy of the startup logs.


Running /usr/bin/xauth in preparation for Xvnc...
/usr/bin/xauth -v -f /root/.Xauthority add probe-34:6 . 90566e96f4cbb65a
/usr/bin/xauth: creating new authority file /root/.Xauthority
/usr/bin/xauth: (argv):1: bad display name "probe-34:6" in "add" command
Using authority file /root/.Xauthority

[Error]
Running /usr/bin/xauth in preparation for Xvnc...
/usr/bin/xauth -v -f /root/.Xauthority add probe-35:6 . 24dc416ba60662f6
/usr/bin/xauth: (argv):1: bad display name "probe-35:6" in "add" command
Using authority file /root/.Xauthority

Thanks for your help.
Hope this helps someone else.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Gnome Session over VNC John Parsons Linux - Newbie 7 11-09-2010 08:04 PM
Sharing an X session with VNC rtaft Linux - Desktop 5 01-08-2008 03:37 AM
VNC Session mindjet Suse/Novell 4 02-11-2006 09:49 AM
Live VNC Session b0rgri0t Slackware 1 01-17-2006 11:44 AM
vnc into session 0 fraz Linux - Networking 5 11-21-2005 07:36 AM


All times are GMT -5. The time now is 05:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration