LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 10-27-2006, 12:08 PM   #1
SanchoP
LQ Newbie
 
Registered: Oct 2006
Distribution: Salckware 11, 2.6 kernel
Posts: 6

Rep: Reputation: 0
Unhappy error while installing dvdrip


Hello, I tried to install dvdrip-0.98.1 which is written in perl.
After installing all needed perl modules I type 'perl Makefile.PL', which works fine, then 'make test' and the following error interrupts my dream of dvdrip. I don't know what to do, please help.

Code:
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-Iblib/lib" "-Iblib/arch" test.pl
1..1
Undefined subroutine &POSIX::setlocale called at blib/lib/Video/DVDRip/Config.pm line 657.
Compilation failed in require at (eval 6) line 3.
        ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
BEGIN failed--compilation aborted at blib/lib/Video/DVDRip/GUI/Base.pm line 14.
Compilation failed in require at (eval 1) line 3.
        ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
BEGIN failed--compilation aborted at blib/lib/Video/DVDRip/GUI/Main.pm line 15.
Compilation failed in require at test.pl line 34.
BEGIN failed--compilation aborted at test.pl line 34.
not ok 1
make: *** [test_dynamic] Error 25
 
Old 10-27-2006, 02:26 PM   #2
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
Check to see that you have all the requirements and your path has what is needed. If nothing works, you can download a binary and install from that.

http://www.exit1.org/dvdrip/doc/install.cipp#source_tgz
 
Old 10-27-2006, 02:31 PM   #3
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
I see some things about libs. Do you have the dependencies and libraries that it needs installed?
 
Old 10-28-2006, 05:07 AM   #4
SanchoP
LQ Newbie
 
Registered: Oct 2006
Distribution: Salckware 11, 2.6 kernel
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you for your reply!

I checked all dependencies and libraries. You were right. But i still get a, slightly different, error message.

Code:
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-Iblib/lib" "-Iblib/arch" test.pl
1..1
Undefined subroutine &POSIX::setlocale called at blib/lib/Video/DVDRip/Config.pm line 657.
Compilation failed in require at (eval 6) line 3.
        ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
BEGIN failed--compilation aborted at blib/lib/Video/DVDRip/GUI/Base.pm line 14.
Compilation failed in require at (eval 1) line 3.
        ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
BEGIN failed--compilation aborted at blib/lib/Video/DVDRip/GUI/Main.pm line 15.
Compilation failed in require at test.pl line 34.
BEGIN failed--compilation aborted at test.pl line 34.
not ok 1
make: *** [test_dynamic] Error 255
Maybe something went wrong when I compiled and installed all the stuff needed (lame, ffmpeg, libdvdread, mpeg2dec, transcode, xvid4conf)

I got a lot of error messages during compiling ffmpeg. Do you expect this to be the reason? Because of transcode using ffmpeg and compiling without any error I don't think so.
 
Old 11-01-2006, 09:56 AM   #5
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
I'm not sure what the problem is. I usually have problems when compiling. Most of the time it is dependencies. A few times I could not compile because my computer's time was not being updated with a NTP time server. Have you checked to see that your path is right according to the directions at that website, you did everything at the website, and you are not forgetting any more dependencies? I still see more about libs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help with installing perl 5.8.8 alongside 5.8.7 for dvdrip Benanzo Linux - Software 3 09-11-2006 05:59 AM
dvdrip strangeness GL1800 Fedora 2 07-13-2006 09:33 AM
dvdrip 0.52.7 albertBeach Linux - Software 4 05-26-2006 06:09 PM
Problems with DVDRIP LManer311 Linux - Newbie 14 10-26-2004 12:55 PM
Dvdrip neurotic Linux - Software 8 03-08-2004 02:58 AM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration