LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 05-12-2007, 06:00 AM   #1
kosmik
LQ Newbie
 
Registered: Aug 2006
Location: CZ
Distribution: Slackware (current)
Posts: 4

Rep: Reputation: 0
Unhappy Alt-Tab does not work under Xfce or Gnome


Hi,

recently, i've upgraded Xorg, to modular version 7.2, but since that, i've got problem with Alt key. When I run gnome or xfce4 desktop, Alt key behaves strangely...It does not work for anything. Ctrl-Alt-Fn is ignored, Alt-Tab and Alt-Shift too. (to switch keyboard layouts, Shift-Alt must be pressed,, switching window focus or jumping to another terminal is not working)

Hovever, when I start KDE, everything looks ok. Also when I run some OS under vmware (under gnome/xfce running), guest-os responses to alt-tab(or other alt-based shortcuts) clearly...

Does someone know, how to repair Alt-key, or what is wrong??

Thanks.


Code:
$ egrep -i 'kb|key' /var/log/Xorg.0.log
(**) |-->Input Device "Keyboard0"
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
(II) Initializing built-in extension XKEYBOARD
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Keyboard0: Protocol: standard
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "logiink"
(**) Keyboard0: XkbModel: "logiink"
(**) Option "XkbLayout" "us,cz"
(**) Keyboard0: XkbLayout: "us,cz"
(**) Option "XkbOptions" "grp:alt_shift_toggle,eurosign:e"
(**) Keyboard0: XkbOptions: "grp:alt_shift_toggle,eurosign:e"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
Code:
$ xmodmap -pk | egrep -i 'alt'

     64         0xffe9 (Alt_L)  0xfe0a (ISO_Prev_Group)
    113         0xffea (Alt_R)  0xfe08 (ISO_Next_Group) 0xfe03 (ISO_Level3_Shift)
    125         0x0000 (NoSymbol)       0xffe9 (Alt_L)
output from xev, when alt_l+tab is pressed:
Code:
KeyPress event, serial 31, synthetic NO, window 0x3000001,
    root 0x1a5, subw 0x0, time 2141172833, (395,171), root:(468,257),
    state 0x2010, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x3000001,
    root 0x1a5, subw 0x0, time 2141173473, (395,171), root:(468,257),
    state 0x2018, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 bytes: (09) " "
    XmbLookupString gives 1 bytes: (09) "       "
    XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x3000001,
    root 0x1a5, subw 0x0, time 2141173545, (395,171), root:(468,257),
    state 0x2018, keycode 23 (keysym 0xff09, Tab), same_screen YES,
    XLookupString gives 1 bytes: (09) " "
    XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x3000001,
    root 0x1a5, subw 0x0, time 2141173817, (395,171), root:(468,257),
    state 0x2018, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
part of xorg.conf:
Code:
Section "InputDevice"

    Identifier  "Keyboard0"
    Driver      "kbd"

    Option      "Name"  "Logitech USB Keyboard"

    Option      "VendorName"    "Logitech"
    Option      "vendor"        "0x046d"

    Option     "AutoRepeat"    "500 30"

    Option     "XkbModel"      "logiink"
    Option     "XkbRules"      "xorg"
    Option     "XkbLayout"     "us,cz"
    Option      "XkbOptions"    "grp:alt_shift_toggle,eurosign:e"

EndSection
Begining of .Xsession.errors
Code:
** Message: This build doesn't include support for XF86Misc extension           
** Message: Querying Xkb extension                                              
** Message: Xkb extension found                                                 
** Message: Querying Xkb extension                                              
** Message: Xkb extension found

Last edited by kosmik; 05-13-2007 at 01:44 AM.
 
Old 09-02-2009, 12:09 PM   #2
virtualx
LQ Newbie
 
Registered: Oct 2005
Posts: 22

Rep: Reputation: 15
Same issue here

I'm having the same problem on XFCE on Sidux, did you find a resolution?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alt - Tab in gnome nobby_trussin Linux - Software 4 08-22-2010 10:38 AM
FC 4. Modify ALT+TAB behaviour to CTRL+TAB xtracto Linux - Software 1 09-22-2005 03:06 PM
Alt Gr doesn't work after gnome upgrade mixx Linux - Software 1 08-17-2005 06:39 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 05:56 PM
Alt-Tab and Alt-F4 in Fluxbox? tavilach Linux - Software 2 07-17-2004 05:03 PM


All times are GMT -5. The time now is 03:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration