LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices

Reply
 
LinkBack Search this Thread
Old 11-05-2008, 03:21 AM   #1
MheAd
Member
 
Registered: Jun 2007
Distribution: Ubuntu 11.04
Posts: 186

Rep: Reputation: 36
Can't write Hotmail messages on Linux??!


This morning, M$ once again changed the design of their e-mail. Now it looks more minimalistic, reminds heavily of Gmail, BUT it stopped functioning normally. As of this moment, I'm not able to write messages in Hotmail using my Fedora 8 and FF ver. 2.0.0.17.
When I try to compose a mail message, the message field itself seems like dead, it's unresponsive. This usually could be the fact due text formating being set to RTF. Changing it to unformatted text usually solved the problem. The problem is that now this cannot be done. Sure, the menu for doing it is present above the message windows but by clicking to 'unformatted text' option doesn't change anything, in fact, it remains locked to 'RTF'. As expected, in WinXP and FF 2.0.0.17. everything works flawlessly. What did M$ f**k up now? Can anyone give me a hand if there is a way to solve this?

Thanks in advance!

Last edited by MheAd; 11-05-2008 at 03:25 AM.
 
Old 11-05-2008, 03:34 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,029

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
Please, search before posting.

http://www.linuxquestions.org/questi...hlight=hotmail
 
Old 11-05-2008, 04:05 AM   #3
MheAd
Member
 
Registered: Jun 2007
Distribution: Ubuntu 11.04
Posts: 186

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by i92guboj View Post
sorry 'bout that. i did some google but i was so upset i could burst.
thankfully, my problem got solved in the thread you pointed me to. thanks a lot. but i AM ditching hotmail. enough is enough...
 
Old 11-05-2008, 04:45 AM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,029

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
No problem. I can imagine that this kind of annoyance is enough to drive mad anybody

I am glad that you found a way around.
 
Old 11-05-2008, 08:36 AM   #5
RobF
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Rep: Reputation: 0
MHeAd, it would have been nice if you had posted the simple fix to this problem here, instead of sending the sufferer to that link that helped you and aggravate her even further by having to plow through the long thread and tease out the simple solution. I92guboj helped you by pointing you to that thread, and it's only fair to expect that you pay something back by helping others, i.e. by simply posting the fix here. But no, you got help and had your problem solved and off you went.

The problem appears to be that as of today, Hotmail expects that the "user agent" for browsers with the Mozilla gecko engine (Firefox, Mozilla, Kazehakaze etc.) is "Firefox", and none of the other names that various Linux distros for licensing reasons had to give to Firefox (Bon Echo, Gran Paradiso, Iceweasel, etc.) will do. Hence, you have to change the user agent.

HERE IS THE FIX:

In your browser's address field enter about:config and then in Filter enter agent and in "general.useragent.extra.firefox" or "general.useragent.vendor" change the string there to Firefox, if it's something other than Firefox. You do this by double-clicking on that line and changing the string in the box that pops up. After the change is done, close and restart your browser. You should now get Hotmail to work the way it did before.

Last edited by RobF; 11-05-2008 at 08:39 AM.
 
Old 11-06-2008, 06:24 AM   #6
MheAd
Member
 
Registered: Jun 2007
Distribution: Ubuntu 11.04
Posts: 186

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by RobF View Post
MHeAd, it would have been nice if you had posted the simple fix to this problem here, instead of sending the sufferer to that link that helped you and aggravate her even further by having to plow through the long thread and tease out the simple solution. I92guboj helped you by pointing you to that thread, and it's only fair to expect that you pay something back by helping others, i.e. by simply posting the fix here. But no, you got help and had your problem solved and off you went.
Now *someone* here really woke up on the wrong side of the bed!
I'm grateful for I92guboj's assistance and I followed his link. I see no reason why anybody else, with similar issue, would not be able to do the same. It's not like it has 10+ pages to look through... Also I didn't want to keep posting anymore in this thread that is already, in a way a "double post" since this issue is being discussed on the mentioned link.

Also what the hell does "sending the sufferer to that link" - mean?
 
Old 11-06-2008, 10:46 AM   #7
Sam French
Member
 
Registered: Dec 2007
Posts: 52

Rep: Reputation: 15
RobF I tried that in my address box it keeps sending me to a no address page. Sorry I am not that good on Linux.

Any help would be appreciated.

Thanks

Sam
 
Old 11-06-2008, 11:14 AM   #8
ratpoison987
LQ Newbie
 
Registered: Nov 2008
Posts: 0

Rep: Reputation: 0
user agent switcher for firefox.

change your user agent to something other than a linux based install, and it works perfectly.

It's another attempt by m$ to undermine the linux community. This isn't the first time - after the last 'hotmail facelift', the same was true. You couldn't use the new 'hotmail experience' using firefox under linux, but firefox on windows - worked fine.

User agent switcher solved that too.

Blatant discrimination.

Kind of cowardice if you ask me. If their software was any good, I don't think they'd be nearly as afraid as they are. These actions they're taking only reaffirms the fact that they're fully aware of how inferior their software really is.
 
Old 11-06-2008, 12:54 PM   #9
dbone
LQ Newbie
 
Registered: Nov 2008
Posts: 0

Rep: Reputation: 0
Absolutely true

Quote:
Originally Posted by ratpoison987 View Post
user agent switcher for firefox.

change your user agent to something other than a linux based install, and it works perfectly.

It's another attempt by m$ to undermine the linux community. This isn't the first time - after the last 'hotmail facelift', the same was true. You couldn't use the new 'hotmail experience' using firefox under linux, but firefox on windows - worked fine.

User agent switcher solved that too.

Blatant discrimination.

Kind of cowardice if you ask me. If their software was any good, I don't think they'd be nearly as afraid as they are. These actions they're taking only reaffirms the fact that they're fully aware of how inferior their software really is.
This couldn't be more true. They can't compete fairly based on quality of product so they have resorted to this kind of behavior. It seems like a desperate attempt to get new linux users to switch back to windows with something along the lines of "I'm going back to windows I can't even use hotmail with linux"

If they would do this then think about what else they do.

I strongly suggest people avoid hotmail/live mail at all costs and use another email service such as gmail.

Another workaround is to type about:config in your firefox address bar and scroll down to "general.useragent.vendor" and remove the value. But the best workaround is to stop using hotmail altogether.
 
Old 11-15-2008, 11:18 PM   #10
scottws
LQ Newbie
 
Registered: Nov 2008
Distribution: Kubuntu 8.04
Posts: 0

Rep: Reputation: 0
Quote:
Originally Posted by RobF View Post
MHeAd, it would have been nice if you had posted the simple fix to this problem here, instead of sending the sufferer to that link that helped you and aggravate her even further by having to plow through the long thread and tease out the simple solution. I92guboj helped you by pointing you to that thread, and it's only fair to expect that you pay something back by helping others, i.e. by simply posting the fix here. But no, you got help and had your problem solved and off you went.

The problem appears to be that as of today, Hotmail expects that the "user agent" for browsers with the Mozilla gecko engine (Firefox, Mozilla, Kazehakaze etc.) is "Firefox", and none of the other names that various Linux distros for licensing reasons had to give to Firefox (Bon Echo, Gran Paradiso, Iceweasel, etc.) will do. Hence, you have to change the user agent.

HERE IS THE FIX:

In your browser's address field enter about:config and then in Filter enter agent and in "general.useragent.extra.firefox" or "general.useragent.vendor" change the string there to Firefox, if it's something other than Firefox. You do this by double-clicking on that line and changing the string in the box that pops up. After the change is done, close and restart your browser. You should now get Hotmail to work the way it did before.
You're on the right track, but not exactly right. The user agent for Firefox 3.0.3 under Kubuntu 8.04 is "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3".

If you change it to "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3", which is Firefox 3.0.3 on Windows XP, it works fine.

Note that "Firefox" is in both user agents. Microsoft is intentionally crippling Hotmail on Linux.

Here is my suggested fix:
  1. Download the User Agent Switcher add-on for Firefox.
  2. After restarting Firefox, click on Tools.
  3. Click on User Agent Switcher.
  4. Click Options.
  5. Click Options.
  6. Click User Agents over on the left of the new window that opened.
  7. Press Add to begin setting up a new user agent.
  8. For the Description, put Firefox 3.0.3 (Windows XP).
  9. For the User Agent, put Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3.
  10. For the App Name, put Netscape.
  11. For the App Version, put 5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3.
  12. For the Platform, put Win32.
  13. Press OK, then OK again.
  14. Select your new user agent by clicking Tools, then User Agent Switcher and then Firefox 3.0.3 (Windows XP). You should now be able to use Hotmail just fine.
  15. To go back to the original user agent just go to the user agent switcher and select Default.
 
Old 11-15-2008, 11:27 PM   #11
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64® 14.0
Posts: 981

Rep: Reputation: 88
Question

Quote:
Originally Posted by scottws View Post
Microsoft is intentionally crippling Hotmail on Linux.[/LIST]
Interesting, do you have a source for this?
 
Old 11-16-2008, 09:18 AM   #12
scottws
LQ Newbie
 
Registered: Nov 2008
Distribution: Kubuntu 8.04
Posts: 0

Rep: Reputation: 0
Quote:
Originally Posted by SqdnGuns View Post
Interesting, do you have a source for this?
Ok, I guess I jumped to conclusions when I wrote that; however, I don't know what other explanation there could be.
 
Old 11-17-2008, 06:26 AM   #13
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,029

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
Quote:
Originally Posted by SqdnGuns View Post
Interesting, do you have a source for this?
The brain, I guess.

Though I consider that phrase not to be accurate. The real thing would be to discourage the usage of any non-ms product, not just linux. We see the linux part cause we are linux users, but I am sure that a lot of windows based browsers will fail as well with the default user agent. I am also sure that a lot of other platforms will fail as well.

How else could you interpret a web site not allowing any user agent that's not matching an MS product? Besides that, there's absolutely no mystery about MS being a monopolist enterprise, they have demonstrated that over the years, and they have been sued for that and damned by the European laws about it

I you need javascript support, there are ways to check for that. You don't need to check for IE, it's idiotic from a developer's point of view, and it can only have an explanation: the explanation is that you are checking for IE, and not for javascript support, because you want the people to use IE, and not any other javascript capable browser (99% of them are). Period.

Last edited by i92guboj; 11-17-2008 at 06:28 AM.
 
Old 11-17-2008, 10:14 AM   #14
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 114Reputation: 114
Quote:
Originally Posted by i92guboj View Post
I you need javascript support, there are ways to check for that. You don't need to check for IE, it's idiotic from a developer's point of view, and it can only have an explanation: the explanation is that you are checking for IE, and not for javascript support, because you want the people to use IE, and not any other javascript capable browser (99% of them are). Period.
Wrong, I'm afraid.

You do have to check for IE. Because IE doesn't comply with the standards, and IE works differently than any other browser. So things you might do with javascript or css that work for a compliant browser don't work with IE. So if you don't take particular pains to make your site work for IE, it won't work right - it won't look right.

Since IE is the dominant browser, you check for IE.
 
Old 11-17-2008, 09:16 PM   #15
scottws
LQ Newbie
 
Registered: Nov 2008
Distribution: Kubuntu 8.04
Posts: 0

Rep: Reputation: 0
Ok, I ran some tests. I tried the following user agents and here are the results:
  • Mozilla/5.0 (Blah; U; Blah Blah; en-US; rv:1.9.0.3) Gecko/2008092510 Blah/8.04 (Blah) Firefox/3.0.3: Same result as default Kubuntu 8.04/Firefox 3.0.3 one... it didn't work.
  • Mozilla/5.0 (Blah; U; Blah NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3: Works fine.
  • Mozilla/5.0 (Blah; U; Blah Blah; en-US; rv:1.9.0.3) Gecko/2008092510 Firefox/3.0.3: Works fine.
  • Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Firefox/3.0.3: Works fine.

So, in conclusion, Microsoft does not appear to be purposely screwing over Linux users. It just appears that they aren't parsing the user agent string properly. It seems that Hotmail expects "Firefox/3.0.3" to appear after the Gecko/########## portion. The extra stuff that (K)ubuntu throws in between there - not sure about other distros - seems to break Hotmail's code.
 
  


Reply

Tags
hotmail, microsoft


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
write messages to serial console linuxgentoo Linux - Kernel 2 04-09-2008 01:51 AM
getting syslog to write to other file than /var/log/messages c_mitulescu Linux - Enterprise 6 04-02-2008 10:17 AM
Qmail delivery problem - messages temporarily_deferred sending to yahoo or hotmail karen.pertierra Linux - General 1 02-12-2007 12:53 PM
Is there a program which can notify you of new Hotmail messages? (Simillar to MSN) Eerath Linux - Software 2 10-09-2005 11:05 AM
How to Get Hotmail messages without browser? nextekcarl Linux - Software 3 11-22-2003 01:04 AM


All times are GMT -5. The time now is 03:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration