LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices

Reply
 
Search this Thread
Old 03-16-2004, 07:55 PM   #1
bpatters
LQ Newbie
 
Registered: Feb 2004
Posts: 6

Rep: Reputation: 0
xfree86 cannot load windows after synaptic update


Hello,
I have been running Fedora Redhat Core 1 for a couple of months.
This problem deals with the installation that I have on my Dell Inspiron 1100 Laptop.
Yesterday, I used synaptic to do a system update on my installed packages. I received the usual "duplicate packages" warning because I haven't turned that feature off in my config file. (Not sure which one to edit)
See below...
____________________________________________________
****************************************************
There are multiple versions of "XFree86-xfs" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-xfs$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-Mesa-libGL" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-Mesa-libGL$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "fal

There are multiple versions of "foomatic" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^foomatic$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-base-fonts" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-base-fonts$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "fal

There are multiple versions of "xchat" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^xchat$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-devel" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-devel$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-75dpi-fonts" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-75dpi-fonts$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "f

There are multiple versions of "libxml2-python" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^libxml2-python$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "gdm" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^gdm$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "coreutils" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^coreutils$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "libxml2" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^libxml2$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-xauth" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-xauth$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-libs" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-libs$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "perl" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^perl$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-Mesa-libGLU" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-Mesa-libGLU$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "f

There are multiple versions of "XFree86-100dpi-fonts" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-100dpi-fonts$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning

There are multiple versions of "XFree86-twm" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-twm$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "libxml2-devel" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^libxml2-devel$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";


There are multiple versions of "XFree86-libs-data" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-libs-data$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false

There are multiple versions of "XFree86-truetype-fonts" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^XFree86-truetype-fonts$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warn
______________________________________________________
******************************************************

As I have done before, I used "$rpm -q <package> " to determine the older version, then "$rpm -e <package.older-version>" to remove the older one. I'm not sure what happened, maybe I restarted my box before the new packages were actually installed. When I did restart, I could only log on in a command prompt. I ran "$redhat-config-xfree86" and received the following error...
______________________________________________________
******************************************************
Error generated when I ran redhat-config-xfree86

Traceback (most recent call last):
File "/usr/share/redhat-config-xfree86/xconf.py", line 171, in start_x_server
(server, tmp_config) = fork_off_server(xconfig)
File "/usr/share/redhat-config-xfree86/xconf.py", line 164, in fork_off_server
os.execv(args[0], args)
OSError: [Errno 2] No such file or directory

Couldn't start X server, trying with a fresh configuration
Trying with card: Intel 845
Traceback (most recent call last):
File "/usr/share/redhat-config-xfree86/xconf.py", line 171, in start_x_server
(server, tmp_config) = fork_off_server(xconfig)
File "/usr/share/redhat-config-xfree86/xconf.py", line 164, in fork_off_server
os.execv(args[0], args)
OSError: [Errno 2] No such file or directory

Error, cannot start X server.
Traceback (most recent call last):
File "/usr/share/redhat-config-xfree86/xconf.py", line 171, in start_x_server
(server, tmp_config) = fork_off_server(xconfig)
File "/usr/share/redhat-config-xfree86/xconf.py", line 164, in fork_off_server
os.execv(args[0], args)
OSError: [Errno 2] No such file or directory

Couldn't start X server, trying with a fresh configuration
Trying with card: Intel 845
Error, cannot start X server.
Couldn't start X server, trying with a fresh configuration
Trying with card: Intel 845
Traceback (most recent call last):
File "/usr/share/redhat-config-xfree86/xconf.py", line 171, in start_x_server
(server, tmp_config) = fork_off_server(xconfig)
File "/usr/share/redhat-config-xfree86/xconf.py", line 164, in fork_off_server
os.execv(args[0], args)
OSError: [Errno 2] No such file or directory

Error, cannot start X server.
Couldn't start X server, trying with a fresh configuration
Trying with card: Intel 845
Error, cannot start X server.

______________________________________________________
******************************************************
I used apt-get update and install to try to reinstall the packages that I had removed. That didn't work either.

I have also enclosed the .xsession-errors file...
______________________________________________________
******************************************************
.xsession-errors documentation

/etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0" "root"
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/6444

(evolution-alarm-notify:6572): GConf-CRITICAL **: file gconf-value.c: line 863 (gconf_value_get_int): assertion `value->type == GCONF_VALUE_INT' failed

** (gedit:6574): CRITICAL **: file bonobo-mdi.c: line 2330 (bonobo_mdi_set_restoring_state): assertion `priv->restoring_state && restoring_state' failed
Error: permissions error in pam_timestamp_check

** (gedit:6574): CRITICAL **: file bonobo-mdi.c: line 2330 (bonobo_mdi_set_restoring_state): assertion `priv->restoring_state && restoring_state' failed

(synaptic:6731): Gtk-CRITICAL **: file gtkwidget.c: line 1827 (gtk_widget_hide): assertion `GTK_IS_WIDGET (widget)' failed

** (nautilus:6560): WARNING **: destroyed file still being monitored

** (nautilus:6560): WARNING **: destroyed file still being monitored

** (nautilus:6560): WARNING **: destroyed file still being monitored

** (nautilus:6560): WARNING **: destroyed file still being monitored


Thanks for any assistance!
Bryan


Last edited by bpatters; 03-16-2004 at 08:23 PM.
 
Old 03-17-2004, 04:32 PM   #2
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
This is what I will do if I was in your shoes

Assuming you still have the packages you installed in your apt cache, I will login as root as the command line and enter this command

# apt-get -V --reinstall install /var/cache/apt/archives/*.rpm

to reinstall all the packages again. I am assuming what happened was since you were in X, and you were upgrading X, X was confused in the process.

I just had the same problem and this solved it

Let me know if it works
 
Old 03-17-2004, 06:57 PM   #3
bpatters
LQ Newbie
 
Registered: Feb 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Talking I can see Gnomes(windows)!!!

You rock!!!
I did your rpm entry and I was able to get KDE to come up. I had to reinstall a few other packages to get Gnome working again, but all of my settings were still intact. I never would have gotten that far without your help!!!

Thanks!
Bryan
 
Old 03-18-2004, 07:56 AM   #4
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
Glad to see it worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Many problems after trying to update kde with synaptic Kolzene Libranet 6 11-07-2005 01:13 AM
Synaptic Update Timeout timothykaine Debian 0 05-03-2005 02:48 PM
Update to Acrobat 7.0 held back by Synaptic acanton Debian 3 04-11-2005 02:25 AM
Red Hat 9: Is it safe to update glib2,pango... via synaptic with fedora packages? gevero Linux - Software 0 03-17-2005 04:11 AM
First time Linux... PLEASE HELP! Can't load xfree86! ___crisis___1 Linux - Software 14 05-01-2004 03:23 PM


All times are GMT -5. The time now is 07:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration