Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 04-30-2006, 01:21 AM   #1
Registered: Aug 2005
Distribution: Debian 7
Posts: 508

Rep: Reputation: 31
Tab does not auto-complete in terminal

I am used to hitting tab to list possible matches, in a bash terminal.

$ cp image<tab>
$ cp image1<tab>
$ cp image11<tab>
automatically changes it to:
$ cp image11.png
Fedora Core 5 does not seem to do this. How can I add this feature in?
Old 04-30-2006, 01:39 AM   #2
Penguin of Wonder
Senior Member
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Alot of times you have to hit tab multiple times in order for this feature to kick in. I know I do in Gentoo using Fluxbox.
Old 04-30-2006, 01:41 AM   #3
Registered: Apr 2006
Location: Pittsburgh
Distribution: Debian Sid AMD64
Posts: 296

Rep: Reputation: 30
It's probably the readline config that's different. Put into your ~/.inputrc:
set show-all-if-ambiguous on
set show-all-if-unmodified on
Old 05-07-2009, 02:59 PM   #4
LQ Newbie
Registered: May 2009
Posts: 1

Rep: Reputation: 0
make sure you are using /bin/bash instead of /bin/sh as your shell
Old 06-03-2012, 02:16 PM   #5
LQ Newbie
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
Cool Solution

1. Log as root
2. Press middle (scroll) mouse button in the terminal emulator! (show all ambiguous on)

Last edited by dicyan; 06-04-2012 at 07:18 AM.
Old 06-04-2012, 07:34 PM   #6
Registered: Jun 2008
Location: Dallas, TX
Distribution: Slackware and FC
Posts: 107

Rep: Reputation: 20
wow man dead thread or what? 2006? Its 2012!!! LOL I do it too. I hit one from 30 years ago once.
Old 06-05-2012, 03:08 PM   #7
David the H.
Bash Guru
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954Reputation: 1954
Not to mention that the post that resurrected it doesn't actually provide a solution to the original question. A middle-mouse click generally just pastes the current x-selection. I'm not at all sure what the poster is really thinking.
Old 05-15-2013, 12:03 PM   #8
LQ Newbie
Registered: May 2013
Posts: 1

Rep: Reputation: Disabled
And the correct answer is...

yum install bash-completion
Old 09-12-2013, 02:48 AM   #9
LQ Newbie
Registered: Sep 2013
Posts: 1

Rep: Reputation: Disabled
Originally Posted by _s0t0_ View Post
make sure you are using /bin/bash instead of /bin/sh as your shell

Using /bin/bash fixed this issue for me.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shells & Tab complete. sph90457 Solaris / OpenSolaris 1 05-19-2005 04:59 PM
VIM doesn't complete filenames on pressing Tab The Scientist Linux - Software 2 10-13-2004 11:15 AM
tab complete Frustin AIX 4 07-19-2004 03:31 AM
auto-completion - how does it work & can my script args auto-complete? BrianK Programming 1 06-11-2004 05:51 PM
RedHat 7.3 Tab complete and cut and paste rjmagyar Linux - Software 1 10-08-2002 12:05 PM

All times are GMT -5. The time now is 11:55 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration