LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 12-01-2009, 07:18 PM   #16
iSeal
LQ Newbie
 
Registered: Dec 2009
Posts: 1

Rep: Reputation: 0

Quote:
Originally Posted by BHG_2008 View Post
While this plugin occasionally causes metadata/checksum issues, it is still valuable for speeding up updates.

Instead of "yum -y remove yum-fastestmirror", do the following:
yum makecache --disableplugin=fastestmirror
yum update []

This allows you to continue using the plugin and work around it, instead of just blowing it away.
(CentOS 5.2 is environment, your paths may differ.)
I had the same problem. I am using CentOS 5.2 behind a proxy. The above advice fixed the issue.

Using "yum -y remove yum-fastestmirror" also removed yum with it (dependency!) which wasn't exactly good.
 
Old 02-07-2010, 09:14 AM   #17
gajuambi
LQ Newbie
 
Registered: Aug 2009
Posts: 5
Blog Entries: 1

Rep: Reputation: 0
Angry none of those are working

So far i tried
yum clean all
but no go.
yum clean metadata
but no go.
yum -y remove fastest-mirror
but no go
 
Old 02-07-2010, 04:28 PM   #18
whistl
Member
 
Registered: May 2005
Location: USA
Distribution: Ubuntu, CentOS
Posts: 37

Rep: Reputation: 15
I have found that sometimes the upstream mirror has a corrupt metadata file, possibly caused by running buildrepo while files were still being updated or something like that. The only solution then seems to be to wait 4-24 hours and try again.

Another solution, and one I've since done, is to build your own repository. You just need a web server with ~5 GB free space per version+architecture combination you use, an upstream repo to mirror from (I asked and got permission from GA Tech) and a couple of shell scripts (there are links on centos.org you can read more about this). Then you just modify the /etc/yum.repos.d/CentOS-Base.repo file on each of your servers to point to your repo instead of using the default mirror list for the Base, Updates, Extras and Addons repos, and you're in charge of your own fate.

Updates and kickstarts go a LOT faster when you have your own repository. And if your bosses agree (mine didn't), you can give back to the community by making your repo available over the Internet to other users.
 
Old 03-03-2010, 10:20 PM   #19
blkcamarozr28
Member
 
Registered: Oct 2005
Location: Honolulu, Hawaii
Distribution: Fedora Core 1-7, CentOS 4/5, Ubuntu/Xubuntu
Posts: 63

Rep: Reputation: 15
Made the bonehead mistake and tried to uninstall yum-fastestmirror and it also removed yum-updatesd, yum-fastestmirror, yum, and pirut.

For anyone else who made this mistake here is the fix.

cat /etc/redhat-release (Will tell you what version your running)

Web to http://vault.centos.org/5.3/os/i386/CentOS/ (change the centos ver #)

Look for yum & yum-fastestmirror and copy and paste the link to wget

==Download rpm files to local hdd==
wget http://vault.centos.org/5.3/os/i386/...tos.noarch.rpm
wget http://vault.centos.org/5.3/os/i386/...tos.noarch.rpm

==Install Yum==
rpm -ivh yum-3.2.19-18.el5.centos.noarch.rpm yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm

==Disable Fastest Mirror==
/etc/yum/pluginconf.d/fastestmirror.conf
enabled=0 <--Disabled Fastest Mirror

==Test yum==
yum clean all
yum clean metadata
yum update
 
Old 01-10-2012, 10:21 AM   #20
Gato Azul
Member
 
Registered: Sep 2003
Location: /dev/null
Distribution: CentOS, Ubuntu
Posts: 128

Rep: Reputation: 16
Post http caching

I know this thread is a bit old, but I just ran across it as I was searching for an answer and wanted to add to the collective knowledge of what worked for me.

It appears that this issue is likely to be caused by http caching on the server (repo) side. The reason that "yum clean all" won't fix the problem immediately is because yum will just download the cached out of date metadata file again. Until the repo http server's cache times out and caches the new metadata file, you'll keep getting the old metadata file and yum will keep complaining.

You can instruct yum not to use http caching, however. To do so globally, just add this option under the [main] section in /etc/yum.conf:

Code:
http_caching=none
Now run yum clean all and yum check-update and you should be good to go!

I haven't tested it, but I would assume that you could also specify this option at a repo level instead of globally if you prefer.

All credit goes to this excellent article:
http://plone.lucidsolutions.co.nz/li...match-checksum
 
1 members found this post helpful.
Old 04-03-2012, 08:55 AM   #21
illinux
LQ Newbie
 
Registered: Apr 2012
Location: NJ
Distribution: CentOS
Posts: 1

Rep: Reputation: Disabled
Thanks Gato Azul. You are a savior.

I tried all the previous options, including
-> vi /etc/yum/pluginconf.d/fastestmirror.conf & set enabled=0
-> yum clean all
-> rpm --rebuilddb
even the one with adverse side effects
-> yum -y remove yum-fastestmirror
The above command removed yum. I used the CD I used to install the OS, and the following commands to get it back
-> cd /media/CDROM/CentOS
-> rpm -Uvh yum-3.2.19*.rpm yum-fastestmirror-*.rpm

Finally, what worked was as you mention in your post.
-> vi /etc/yum.conf (add the line http_caching=none under section [main])
-> yum clean all

Last edited by illinux; 04-03-2012 at 08:56 AM. Reason: removed all the unwanted "QUOTE" entries
 
Old 04-13-2012, 01:12 PM   #22
ba.page
Member
 
Registered: Feb 2012
Location: Canada
Distribution: Scientific,Debian
Posts: 35

Rep: Reputation: 7
I stumbled upon this thread while searching for "yum metadata file does not match checksum" online.
I would like to add some useful recon to this thread:

Root cause of problem:
I had a Scientific Linux 5.3 test server that I backed up to a local tar file, upgraded to 5.7 and then restored the backup to take it back down to 5.3 (testing rollback prior to patching production servers).
After rolling back to 5.3, I then reinitiated an upgrade and ran into this problem. yum returned the "metadata file does not match checksum" error.

Solution:
Code:
yum clean metadata
Following that, I was able to proceed with a full upgrade to 5.7 as normal.

Thank you, LinuxQuestions.org and its community, yet again, for hosting good information and showing up with high relevance in search results.
 
Old 10-03-2012, 12:19 PM   #23
b8rt
LQ Newbie
 
Registered: Dec 2006
Posts: 8

Rep: Reputation: 0
In my case running 'yum clean all' or 'rm -r /var/cache/yum' did not fix the error. Yum was checking some old data elsewhere:
Code:
rm -r /var/tmp/yum*
 
Old 10-08-2012, 08:55 AM   #24
ramram29
Member
 
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
[solved]

I'm writing my result here hoping to be able to help others. I got this same error while creating a Red Hat 5.9 YUM Repository on a Red Hat 6.3 server. The problem appears because 6.3 uses the SHA256 checksum by default when creating the primary.xml.gz file; and 5.9 uses the old SHA1.

Solution (follow the logic):

On the YUM Repository server run:

# cd pub/rhel/5.9/os/x86_64
# createrepo -d -s sha -g repodata/comps-rhel5-server-core.xml .

On the YUM source host run:

# yum clean all
# yum repolist
 
2 members found this post helpful.
Old 02-25-2013, 01:33 PM   #25
davinken
LQ Newbie
 
Registered: Aug 2011
Location: Texas, USA
Distribution: CentOS, Fedora
Posts: 6

Rep: Reputation: Disabled
My "yum update"-based upgrade from CentOS 5.8 to 5.9 was failing due to the issue above. Ramses's answer proved to solve this, as it was a local/custom repository failing its checksums what made the whole process to abort every time. Now I split my createrepo-based script in two according to the CentOS branch (5.x or 6.x) and all seems to work just fine now. Thanks !
 
Old 10-15-2013, 06:07 PM   #26
Steeltemplar
LQ Newbie
 
Registered: Jan 2013
Posts: 1

Rep: Reputation: Disabled
I know this is a pretty old thread, but I came to it when I was researching this problem for myself. 'yum clean metadata' and 'yum clean all' did not fix the problem for me. Interestingly, though, simply running 'yum update' got everything back into order. This was with Fedora 19.
 
  


Reply

Tags
cache, checksum, error, fedora, yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum in fc4 error - metadata file does not match dark_prancer Linux - Newbie 6 03-17-2011 07:38 PM
LVM Error: incorrect metadata area header checksum neillans Linux - General 1 02-28-2006 03:06 PM
Yum Errno -1 after installing gimp2 from fedora.us - testing resiak Linux - Software 1 08-15-2005 06:40 PM
SUSE MD5 checksum for DVD ISO refuses to match tisource Suse/Novell 1 02-07-2005 06:26 PM
Checksum did not match timmytytim Linux - Newbie 5 12-26-2004 02:22 PM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration