LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-10-2004, 09:56 PM   #1
imemyself
Member
 
Registered: Feb 2004
Location: Wichita, KS
Distribution: CentOS 4, SuSE 10, Tiger
Posts: 110

Rep: Reputation: 15
Graphics Problem in FC3


I upgraded from FC2 with the DVD. The problems started to happen in the installation, parts of the installer(GUI) would not update. So for example, it looked like it was on a previous page, just the progress bar showed through, etc. And once it finished upgrading, there is definately a big problem. Like when I open an app, the desktop background shows through most of it, except fo the title bar and any buttons(once I hover over them). FC2 worked fine. I have an Intel 810 (integrated) graphics, and it does say i810 in xorg.conf. I've tried changing the refresh rates some and the resolution as well, but it still occurs. It happens in both Gnome and KDE. Any ideas about this? If you want I can post my xorg.conf.
 
Old 11-16-2004, 05:49 PM   #2
psyberdyne
LQ Newbie
 
Registered: Nov 2004
Posts: 3

Rep: Reputation: 0
WOW, you're lucky your system doesn't freeze up like ours did, we couldn't even login to Gnome or KDE.

Try putting an option of "noaccel" in your xorg.conf Device Section, like so:

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 815"
Option "noaccel"
EndSection

There may be better solutions, after a long hard struggle someone found this one for me. Obviously, graphics seem significantly slower than w/FC2, also I've noticed a significant reduction of resolution choices, and the higher resolutions now experience vertical pixel jitter lines, which also didn't happen with FC2.
 
Old 11-19-2004, 09:58 AM   #3
enderjm
LQ Newbie
 
Registered: Aug 2003
Location: Jamaica
Distribution: Gentoo
Posts: 27

Rep: Reputation: 15
I had the same problem. I'm running on a Netvista 2257 with the same onboard video chipset (i810). I had to resort to a text based install. The Graphical install worked sometimes and didn't at other times. It would bug out at random intervals.

After boot same issue. I hope this solution will work. I'll let you all know if it does.
 
Old 11-19-2004, 02:52 PM   #4
psyberdyne
LQ Newbie
 
Registered: Nov 2004
Posts: 3

Rep: Reputation: 0
A better soultion seems to have been found, I'm told this can be found in bugzilla now:

-----------------------------------------------------------
If you want to get your FC3 working with acceleration on and at a higher resolution, make sure you install using text mode (linux text at boot time). After install but before X kicks in, switch to a terminal session.

Replace the i810 driver with this one http://people.redhat.com/krh/i810_drv.o
/usr/X11R6/lib/modules/drivers (replacing the old i810_drv.o there)

Also make sure your /etc/X11/xorg.conf screen section looks like this:

Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
Restart and everything should be well.
-----------------------------------------------------------

Obviously you will want to remove the Option "noaccel" line from the Device section if you've already used that solution.

This seems to have restored the speed somewhat on my system and the higher resolutions don't get that jitter anymore.
 
Old 11-24-2004, 08:41 PM   #5
xaos-ei
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
I'm unfamiliar with the details of the Fedora core 3 and would like to know if anyone has specific instructions on how to do this. Thanks in advance.
 
Old 11-24-2004, 10:12 PM   #6
cflyguy
LQ Newbie
 
Registered: Nov 2004
Location: GA-Atl
Distribution: Debian [sarge]
Posts: 7

Rep: Reputation: 0
I also encountered this problem when upgradeing from FC2 to FC3, changing the bit depth to 16 and including noaccel fixed the problem. I found the easeist way (at least for me) to change this was use ssh to log on and edit the file in vi.
 
Old 11-25-2004, 03:38 PM   #7
psyberdyne
LQ Newbie
 
Registered: Nov 2004
Posts: 3

Rep: Reputation: 0
Here's a basic step by step for anyone new to Linux or FC, or otherwise can't make a terminal connection to the machine over a network:

Part 1:

-If FC3 is already installed, Skip ahead to Part 2
-Insert the installation DVD or the first installation CD, the problem is not specific to one or the other
-(Re)Boot the machine
-At the prompt type linux text (If you don't get the installation prompt you need to go into your system BIOS and set your boot options to boot off of DVD/CD rom first)
-Follow the on screen installation instructions, I did the custom->install everything option so I'm not sure if vi or vim will be installed by the options you may choose, but try to make sure one or the other gets installed, I wouldn't worry about it too much though, I'm pretty sure a version of vi almost always gets installed.

Part 2:

-(Re)Boot the system into FC3.
-The system will come back up with a gray background, or will otherwise fairly obviously not be in text only mode, whenever the background goes grey or it looks like the screen switched back to graphical mode (this may happen several times during the startup process) press the control, alt, and f1 keys together, this will bring you to the first text session screen (usually there are 6 text sessions f1 to f6 and the one graphical X session at f7) as long as the graphical session is not displayed your system shouldn't lock up. (FYI: KDE and Gnome since about RH 8 or 9 usually have a shortcut that conflicts with this functionality, *BAD RED HAT*, but we're not in KDE or Gnome yet so it doesn't matter here)
-When the system is done starting up you should be at a text login, you should log in as root at this point (usually only root can edit the configuration file and replace driver files)
-Replace your old i810_drv.o, if you don't know how to do that you will probably need someone to manually help you do it, otherwise just use the simple noaccel fix and a low resolution, if you know how to do it from KDE or Gnome you can always do the better fix after your system is working correctly
-Now you need to edit the configuration file by typing "vi /etc/X11/xorg.conf"
-In vi you need to type the i key to start editing, if you're not familiar with vi then don't try to cut or paste anything, just use the arrow keys, the backspace key (some versions of vi also allow use of the delete key), and manual typing, then to exit first press the Esc key then type ":wq" and hit enter, which will write out the file and quit the program
-Once out of vi you can type "shutdown -r now" to reboot the machine, and your graphical system should be alot more usable.
 
Old 11-29-2004, 05:44 PM   #8
xaos-ei
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
Thanks for the reply. That solved my problem.
 
Old 12-10-2004, 09:11 PM   #9
smnoel
LQ Newbie
 
Registered: Dec 2004
Location: Michigan
Distribution: Fedora Core 3
Posts: 11

Rep: Reputation: 0
The link for the driver does not work anymore!
:-(
I had the same problem would like to get back 3d accel! :-(

Any suggestions?

(I have accel disabled right now)
 
Old 12-11-2004, 01:07 AM   #10
smnoel
LQ Newbie
 
Registered: Dec 2004
Location: Michigan
Distribution: Fedora Core 3
Posts: 11

Rep: Reputation: 0
Well well...
I removed Option "noaccel".
And everything is working fine and accel is enable!
The bug is only when you first install the distro.

Thank you psyberdyne!
 
Old 12-30-2004, 05:45 PM   #11
daveymg
LQ Newbie
 
Registered: Aug 2003
Location: New Zealand
Distribution: Fedora Core
Posts: 4

Rep: Reputation: 0
I had a similar display freeze problem that was fixed with the noaccel option, however I couldn't get into any of the text mode login screens as the display froze when I tried to switch. I discovered that the FC3 install CD has a rescue mode ("linux rescue" at the prompt) which will mount the filesystem under /mnt/sysimage and start up a shell. From there I could edit xorg.conf

dg
 
Old 01-05-2005, 11:23 PM   #12
Wakim
LQ Newbie
 
Registered: Jan 2005
Location: NY State
Distribution: Mandrake Community 10.1
Posts: 19

Rep: Reputation: 0
I just finished my first Linux install, and I know I should have searched for my graphics card here before I did, but I seem to have the same problems with my Intel 810 integrated graphics.

I'm really new to this, and there looks like a couple of things I could try here, but frankly I am wondering if I should just try a differant distro that doesn't have this problem? Any suggestions?

Maybe someone could indicate what the easiest solution here for a total newbie to get up and running in graphical mode and I could probalby figure out something from there.

I installed, and I get to the wellcome screen, enter time and date, and it gets to the set your graphics options, and whatever I click on here I end up with some strange lines running up and down my screen.

Does Mandrake have better support for this graphics processor?
 
Old 05-04-2005, 08:27 PM   #13
Tarmac
LQ Newbie
 
Registered: May 2005
Location: Ireland
Posts: 1

Rep: Reputation: 0
hi all

I am the absolute definition of a newbie when it comes to Linux and am trying my hardest to learn.

I too am trying to install FC3 on a Dell Inspiron 2500 with an Intel i810 chipset and am getting the same problems.

Because the page linking to the new graphics driver is no longer valid, i can't follow that route.

However, I was trying to follow the steps outlined by psyberdyne but when I press the cntrl-alt-f1, it ALWAYS just freezes at the line saying "Enabling swap area" yadda yadda... and does nothing more.

No matter how many time i try this, i never get a textual login interface. If i let the boot-up commence normally, it brings me into the screen asking to set the timezone and on occasion to the graphics display setup - i.e. it is trying to complete the setup of FC3 I guess.

Is there an "obvious" step ommitted from psybers post that people whom are comfortable with linux would know to do or is there something totally pearshaped with this distro? i even reinstalled it again a second time using the textual installer instead of the graphical one because the screen wasn't updating when using the graphical install.

any help would be greatly appreciated!

thanks

Edit:

Further investigation on this reveals that the problem is related to the BIOS update. I updated the BIOS on my Inspiron to PhoenixBios 6 Rev 4. If I revert to the pre-update version, the display problem does not happen with Red Hat 8.0, but does still happen with FC3. With the updated BIOS, even Red Hat 8 doesn't work graphically, which would lead me to believe that the problems must be BIOS related somehow with FC3 possibly?

Last edited by Tarmac; 05-07-2005 at 05:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics Problem kurcz Linux - Hardware 4 08-23-2005 12:34 AM
running my graphics card ATI Radeon Mob 9800 in FC3 FinalFlash Linux - Hardware 0 05-15-2005 08:34 AM
Graphics problem Smokieisgod Linux - Hardware 2 01-16-2004 08:39 AM
Graphics Problem jasonk Linux - Newbie 1 10-27-2002 11:56 PM
Graphics problem frkstein Linux - General 6 02-22-2002 07:50 PM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration