LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-03-2010, 08:35 PM   #1
aayu09
Member
 
Registered: Feb 2010
Posts: 30

Rep: Reputation: 15
Smile gcc-4.4.3 make error - failed to build gcc-4.4.3--please help


I am working to build a gcc-4.4.3 for c/c++ and java. I have worked a few hours and still getting stuck. I need some help on this issue.
The steps I followed are:

1. downlad the gcc-4.4.3 package and uncompressed.
2. mkdir objdir, then cd objdir
3. ../gcc-4.4.3/config --enable -languages=c, c++, java
All the steps works fine so far.

4. make BOOT_CFLAGS='-O' bootstrap

I got the following error:
checking for i686-pc-linux-gnu-ranlib... ranlib checking for i686-pc-linux-gnu-strip... strip checking whether ln -s works... yes checking for i686-pc-linux-gnu-gcc... /root/objdir/./gcc/xgcc -B/root/objdir/./gcc/ -B/usr/local/i686-pc-linux-gnu/bin/ -B/usr/local/i686-pc-linux-gnu/lib/ -isystem /usr/local/i686-pc-linux-gnu/include -isystem /usr/local/i686-pc-linux-gnu/sys-include
checking for suffix of object files... configure: error: in `/root/objdir/i686-pc-linux-gnu/libgcc':
configure: error: cannot compute suffix of object files: cannot compile See `config.log' for more details.
make[2]: *** [configure-stage1-target-libgcc] Error 1
make[2]: Leaving directory `/root/objdir'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/root/objdir'
make: *** [bootstrap] Error 2

By the way, my machine info
$uname -a

Linux 2.6.15-1.2054_FC5smp #1 SMP Tue Mar 14 16:05:46 EST 2006 i686 i686 i386 GNU/Linux

$gcc --v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../gcc-4.2.4/configure
Thread model: posix
gcc version 4.2.4


Please help on my build errors. I really appreciate al the help.

Thanks,

-Anping
 
Old 03-04-2010, 12:54 PM   #2
troop
Member
 
Registered: Feb 2010
Distribution: gentoo, arch, fedora, freebsd
Posts: 379

Rep: Reputation: 96
seems like http://gcc.gnu.org/bugzilla/show_bug.cgi?id=42727
 
Old 03-04-2010, 10:22 PM   #3
aayu09
Member
 
Registered: Feb 2010
Posts: 30

Original Poster
Rep: Reputation: 15
Wink

Hi,

Thanks for the url info. My question will be: is bug resolved? how to build gcc-4.4.3? I have another computer which runs fedora 12, and gcc-4.4.3 comes with the OS.

I will need to use FC5 for my company project, and current gcc is 4.2.4, we need to upgrade to gcc 4.4.3, can you please let me know how to do that? Thanks.
 
Old 03-04-2010, 11:27 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,279

Rep: Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775
Quote:
I will need to use FC5 for my company project, and current gcc is 4.2.4, we need to upgrade to gcc 4.4.3, can you please let me know how to do that? Thanks.
FIRST
DO NOT use a UNSUPPORTED and DEAD version of fedora
fedora 5 is DEAD,DEAD,DEAD

if you need something a bit older than "the cutting edge " of fedora ,then use CentOS 5.4 ( the free version of RHEL 5.4)


also it is NEXT to impossible to install gcc 4.4 on fedora 5 without rebuilding 95% of the OS to bring it upto date with fedora 12

---
and yes this IS one of my "pet peeve's "
using a UNSUPPORTED version of FEDORA -- and MOST especially for a
" company project "

Last edited by John VV; 03-04-2010 at 11:30 PM.
 
Old 03-05-2010, 10:20 AM   #5
aayu09
Member
 
Registered: Feb 2010
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks, John.

We will find alternatives for the approach, maybe stick with gcc-4.2.4 and upgrade the gcc version later when upgrade OS.

-anping
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS 6.4 build gcc error Ron_Beltran Linux From Scratch 4 09-23-2009 12:18 AM
remove the gcc-build, binutils-build, etc after make @d4M Linux From Scratch 6 01-26-2009 05:29 AM
help: failed build of GCC 4.3 on SLES 10/gcc 4.1 ia64 ron7000 Programming 6 05-28-2008 12:24 AM
GCC build error lukeiamyourfather Linux From Scratch 5 01-05-2008 12:01 PM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare Suse/Novell 3 11-29-2004 03:13 PM


All times are GMT -5. The time now is 02:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration