LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-17-2004, 10:25 AM   #1
gomartin
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Rep: Reputation: 0
Exclamation Fedora doesnt recognize correct cpu speed


I'm running Fedora Core2 on an Acer Aspire 1315 LM
which has an AMD Athlon(tm) XP 2500 cpu

but when i look for my cpuspeed
with 'cat /proc/cpuinfo' this is what it says:

processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2500+
stepping : 0
cpu MHz : 796.124
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips : 1558.82

my cpu MHz speed is not a third as it shoud be!!

any idea to change this?

i heard of a tool name cpufreq but i don't now if it's appropriate
or
shall i recompile the kernel myself? is there a config-file for the newest kernel?
though i installed the new kernel with up2date i've got no clue if i already have
the src and the config-file..

or is there an easyer way (what i hope is the case)?

thx, would be really great if someone comes up with any help

cheers
gomartin
 
Old 08-17-2004, 12:46 PM   #2
Teukka
LQ Newbie
 
Registered: Aug 2003
Location: Finland
Distribution: Debian, Fedora, FreeBSD, OpenBSD
Posts: 22

Rep: Reputation: 15
Re: Fedora doesnt recognize correct cpu speed

Hi

Acer Aspire 1315 LM is notebook / laptop right? so there is the answer!
Notebooks & Laptops adjust processor speed all the time to save batteries and avoid heating etc, You can try run some heavy progs and same time look the what is thats moments processor MHz etc.

Best regards
Pekka "Teukka"
Finland

Last edited by Teukka; 08-17-2004 at 12:47 PM.
 
Old 08-17-2004, 01:05 PM   #3
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
I have FC3-T1 on a Compaq laptop, and had the same concern first time I saw it.

If you want, you can run "kill -USR1 $(pidof cpuspeed)" as root. I know, it looks like you are killing cpuspeed, but you aren't. It sends USR1 signal to cpuspeed... Which is a signal to tell cpuspeed to run the processor at full speed. cpuspeed controls the processor so that it slow down when it's not as active. When load increases, cpuspeed is s'posed to bump the processor up. This helps keep the heat down, and uses less power.
 
Old 08-17-2004, 03:19 PM   #4
gomartin
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Original Poster
Rep: Reputation: 0
@teukka

you're right! thx, i did'nt know that. i run some programs and the cpu-speed did increase!
but when i'm running some video files with mplayer it is reporting to me, that
my system is to slow to play the desired file... is there a way manipulation it like
ranger_nemo suggested?

@ranger_nemo

i can't apply the same command. when i'm trying to run it i get following
errors:

[root@12kingdoms root]# kill -USR1 $(pidof cpuspeed)
bash: pidof: command not found
kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l [sigspec]
[root@12kingdoms root]# kill -USR1 cpuspeed
bash: kill: cpuspeed: no such pid

any idea what to change? i tried to yum install cpuspeed and apt-get install cpuspeed,
but nothing worked yet...

thx 2 u both for reply's, they gave me hope

cheers
gomartin
 
Old 08-17-2004, 04:17 PM   #5
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
You can get the pid of cpuspeed with "ps -e | grep cpuspeed". Then run "kill -USR1 #", replacing the # with the pid listed from the first command.

You prob'ly used "su" to run the original command I suggested. If you did, you would need to change it to "kill -USR1 $(/sbin/pidof cpuspeed)". With "su", you only get the permissions of root, not the path. If you would use "su -" instead, then it would be like you are logging-in as root, and gain the path, too. Then, the original "kill -USR1 $(pidof cpuspeed)" would work.

There's also a -USR2 signal. "man cpuspeed" will give you a lot more info.
 
Old 08-17-2004, 05:03 PM   #6
gomartin
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Original Poster
Rep: Reputation: 0
aaaaaaaaahhh pid = process id.

what a shame! sure thing.

now it works all fine. i already made 2 scripts to speedup und to lower my speed.
thx a lot. u brought light into my darkness or shall i say speed to my cpu?

cheers
gomartin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Processor clock speed vs. CPU speed moxieman99 Linux - General 4 06-24-2005 11:43 AM
Can install Linux Fedora on my laptop because it doesnt recognize my keyboard mortiphen Linux - Laptop and Netbook 2 02-09-2005 12:58 AM
please help guys, wrong cpu speed shown with a regular non-mobile cpu !! : ( maku Linux - Hardware 1 01-02-2005 03:03 PM
Does BIOS really need to recognize correct HDD size? ikletti Linux - Hardware 1 09-24-2003 06:13 PM
How to setting the correct value in BIOS about CPU speed? explorer1979 General 1 09-09-2001 06:35 AM


All times are GMT -5. The time now is 08:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration