LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 07-12-2007, 11:03 PM   #1
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Rep: Reputation: 30
Clocksource tsc unstable


My server keeps hanging and when I see the last event that occurred before the system lags in /var/log/messages, it is the following:

Code:
Jul 12 21:00:05 server kernel: Clocksource tsc unstable (delta = 4685968956 ns)
Jul 12 21:00:05 server kernel: Time: acpi_pm clocksource has been installed.
I asked someone about this and he suspected that my CMOS battery was dying. I replaced it. The problem remains.

This only started after I upgraded to Fedora 7. I didn't have this problem prior to that.

Has anyone else experienced the issue and/or knows of a fix or what this problem truly is?

TIA.
 
Old 07-12-2007, 11:19 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,296

Rep: Reputation: 205Reputation: 205Reputation: 205
TSC=Time Stamp Counter. Processors have dynamically changed clock speed (ofc to save power). The TSC is supposed to tick at the CPU rate (unless it's a constant_tsc, see /proc/cpuinfo flags, so on frequency change, this ought to happen. The kernel will automatically switch to something else. There's acpi_pm <-(this is what yours has switched to) and, IIRC, pit. This message seems to appear with the newer kernel upgrades.

Last edited by {BBI}Nexus{BBI}; 07-12-2007 at 11:21 PM.
 
Old 07-12-2007, 11:28 PM   #3
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Thanks for the information. How do I remove it? Can I add constant_tsc to the flags on /proc/cpuinfo?
 
Old 07-13-2007, 07:54 AM   #4
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Bump - just don't want to do the wrong thing and have kernel panic.
 
Old 07-13-2007, 04:47 PM   #5
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Okay, I can't edit /proc/cpuinfo anyway. What can I do to avoid this problem? My server is dying nearly every 24-36 hours.
 
Old 07-13-2007, 10:35 PM   #6
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,296

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by punt
Okay, I can't edit /proc/cpuinfo anyway. What can I do to avoid this problem? My server is dying nearly every 24-36 hours.
Roll back to your previous kernel or see if there is a patch you can apply to your current kernel.
 
Old 07-14-2007, 08:16 PM   #7
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
I think all the previous kernels work for FC6. This problem only existed when I upgraded to FC7. I'm not familiar with how to go about this.
 
Old 07-15-2007, 11:04 AM   #8
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
bump for anyone specifically familiar with this for FC7. I'm about to reboot my machine again because of this problem.
 
Old 07-15-2007, 02:50 PM   #9
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,296

Rep: Reputation: 205Reputation: 205Reputation: 205
You could try disabling the acpi in the bios, other than that there seems to be various fixes around for the tsc problem. I don't know if any of them will help you. To see a few put this in google: Fix TSC timer selection
 
Old 07-15-2007, 04:28 PM   #10
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
I'm going to take the route to disable ACPI in the BIOS. We'll see what happens. Thanks.
 
Old 07-20-2007, 06:10 PM   #11
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Just wanted to be fair to update this thread and say that it appears disabling the ACPI in the BIOS in fact did the trick. Thanks
 
Old 12-29-2008, 03:16 AM   #12
saavik
Member
 
Registered: Nov 2001
Location: NRW, Germany
Distribution: SLES11 / FC20/ OES / CentOS
Posts: 600

Rep: Reputation: 32
thanks

that also helped me.

Thanks everybody.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unstable Clocksource with SMP kernels after 2.6.20 thesk8ingtoad Slackware 4 08-15-2007 02:19 AM
Losing too many ticks! TSC cannot be used as a timesource. V Naveen Linux - Software 4 06-26-2007 10:27 PM
'Unstable' made my computer unstable...;) debuser123 Debian 10 01-26-2007 04:11 AM
is ubuntu unstable less unstable than debian unstable? lefty.crupps Ubuntu 9 10-14-2005 01:38 PM
Problem with Exceed and multiple users logged via TSC Michele Spinolo Linux - General 0 02-01-2005 04:48 PM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration