Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 10-07-2004, 02:08 PM   #1
LQ Newbie
Registered: Dec 2001
Posts: 19

Rep: Reputation: 0

kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 16x16/stock/media not valid.

debain sarge , This is beginning to get very large so i think i will ask how to fix it.

now this error is just one of the many i get with all the sizes and sub directorys of /usr/share/icons/hicolor/ upon looking it seems all thoose catagories are empty and contain no icons. but all the subsequent folders are there.

i now ran into a problem when i tried to launch "smb4k" application and it errored out with the exact same list thats in my .xsessions-errors file. anyway to fix this or KIconLoader?
Old 10-08-2004, 11:25 AM   #2
LQ Newbie
Registered: Dec 2001
Posts: 19

Original Poster
Rep: Reputation: 0
no one huh
Old 10-09-2004, 11:47 AM   #3
LQ Newbie
Registered: Dec 2001
Posts: 19

Original Poster
Rep: Reputation: 0
ok found a little info/workaround

as root:
cd /usr/share/icons/hicolor/
cp index.theme index.desktop

this will eliminate the log in .xsession-errors

but fix the problem/bug? dont know cause the program "smb4k"
hangs upon launch with no output in the terminal until a kill command is issued.

another fix/workaround to have it not flood xsession-errors is to

"kdebugdialog --fullmode". Look for debug area 264, and change the combobox for the warning to "None"

but it just seems to hide the problem still

The errors went unnoticed until i installed smb4k (cause linneghborhood dont like samba3 too much)

Theese fixes just seem like they hide the problem and if anyone has any further info it will be appreciated.

thanks for all the replys
Old 10-09-2004, 10:12 PM   #4
Senior Member
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 46
Maybe there is a reason sarge is testing? Maybe you should file a bug report.
Old 10-09-2004, 11:09 PM   #5
LQ Newbie
Registered: Dec 2001
Posts: 19

Original Poster
Rep: Reputation: 0
its been done not by me but its documented.. That were i found most of my info on this issue thanks
Old 10-11-2004, 07:52 AM   #6
Registered: Sep 2003
Location: Estonia Tartu
Distribution: Debian, edition depends on what i run it, wheezy on main box.
Posts: 91

Rep: Reputation: 15
did help me ..maybe helps you

aquire hicolor-icon-themes from
and install it.
for some reason it is missing sometimes. there should be debian version of it also available.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
~/.xsession-errors Phiebie Debian 2 12-21-2004 09:00 AM
.xsession-errors file exploding ??? tjuii Linux - General 3 12-14-2004 01:32 PM
insight into .xsession-errors kodon Slackware 4 08-29-2004 04:29 AM
xsession errors DB Troll Linux - General 0 07-15-2003 11:09 PM
.xsession-errors egh128 Linux - General 3 05-31-2002 11:37 PM

All times are GMT -5. The time now is 07:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration