LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-16-2006, 01:37 PM   #1
Shankarrajus
LQ Newbie
 
Registered: Dec 2004
Location: PA, USA
Distribution: FC2
Posts: 14

Rep: Reputation: 0
xserver-xfree86: Xserver could not start on my ATI-radeon video card


Hi,
THis is the first time I am installing "debian sarge 3.1r2" on my HP
laptop and when I try to configure xserver I am getting the error
message saying that Could not start xserver, reconfigure and try again.
But I have "Fedora core-3" on my laptop whose xserver is working[Fatal server error:
xf86MapPciMem: Could not mmap PCI memory]. Any
suggestions on resolving this issue? Please, let me know if you need any other
info about my system.

============================================
X server symlink status:
lrwxrwxrwx 1 root root 20 Jul 8 14:55 /etc/X11/X -> /usr/bin/X11/XFree86
-rwxr-xr-x 1 root root 1746444 Sep 1 2005 /usr/bin/X11/XFree86

Contents of /var/lib/xfree86/XF86Config-4.roster:
xserver-xfree86

VGA-compatible devices on PCI bus:
0000:01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device
5835

/etc/X11/XF86Config-4 does not match checksum
in /var/lib/xfree86/XF86Config-4.md5sum.

XFree86 X server configuration file status:
-rw-r--r-- 1 root root 2537 Jul 9 01:23 /etc/X11/XF86Config-4

Contents of /etc/X11/XF86Config-4:
# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.

Section "Files"
FontPath"unix/:7100"# local font server
# if the local font server has problems, we can fall back on these
FontPath"/usr/lib/X11/fonts/misc"
FontPath"/usr/lib/X11/fonts/cyrillic"
FontPath"/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath"/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath"/usr/lib/X11/fonts/Type1"
FontPath"/usr/lib/X11/fonts/CID"
FontPath"/usr/lib/X11/fonts/Speedo"
FontPath"/usr/lib/X11/fonts/100dpi"
FontPath"/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load"GLcore"
Load"bitmap"
Load"dbe"
Load"ddc"
Load"dri"
Load"extmod"
Load"freetype"
Load"glx"
Load"int10"
Load"record"
Load"speedo"
Load"type1"
Load"vbe"
EndSection

Section "InputDevice"
Identifier"Generic Keyboard"
Driver"keyboard"
Option"CoreKeyboard"
Option"XkbRules""xfree86"
Option"XkbModel""pc104"
Option"XkbLayout""us"
EndSection

Section "InputDevice"
Identifier"Configured Mouse"
Driver"mouse"
Option"CorePointer"
Option"Device""/dev/input/mice"
Option"Protocol""ImPS/2"
Option"Emulate3Buttons""true"
Option"ZAxisMapping""4 5"
EndSection

Section "Device"
Identifier"ATI Mobility Radeon 9000 IGP"
Driver"radeon"
VideoRam256
EndSection

Section "Monitor"
Identifier"Generic Monitor"
HorizSync31.5-37.9
VertRefresh50.0-70.0
Option"DPMS"
EndSection

Section "Screen"
Identifier"Default Screen"
Device"ATI Mobility Radeon 9000 IGP"
Monitor"Generic Monitor"
DefaultDepth16
SubSection "Display"
Depth16
Modes"800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier"Default Layout"
Screen"Default Screen"
InputDevice"Generic Keyboard"
InputDevice"Configured Mouse"
EndSection

Section "DRI"
Mode0666
EndSection

Module Loader present
OS Kernel: Linux version 2.6.8-2-686 (horms@tabatha.lab.ultramonkey.org) (gcc
version 3.3.5 (Debian 1:3.3.5-13)) #1 Tue Aug 16 13:22:48 UTC 2005
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Jul 9 10:22:39 2006
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "ATI Mobility Radeon 9000 IGP"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
Entry deleted from font path.
(**) FontPath set to
"unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No
symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No
symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No
symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o": No
symbols found
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols
found
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "radeon"
(II) Loading /usr/X11R6/lib/modules/drivers/radeon_drv.o
(II) Module radeon: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 4.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "ati"
(II) Loading /usr/X11R6/lib/modules/drivers/ati_drv.o
(II) Module ati: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 6.5.5
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) ATI: ATI driver (version 6.5.5) for chipsets: ati, ativga
(II) R128: Driver for ATI Rage 128 chipsets:
ATI Rage 128 Mobility M3 LE (PCI), ATI Rage 128 Mobility M3 LF (AGP),
ATI Rage 128 Mobility M4 MF (AGP), ATI Rage 128 Mobility M4 ML (AGP),
ATI Rage 128 Pro GL PA (AGP?), ATI Rage 128 Pro GL PB (AGP?),
ATI Rage 128 Pro GL PC (AGP?), ATI Rage 128 Pro GL PD (PCI),
ATI Rage 128 Pro GL PE (AGP?), ATI Rage 128 Pro GL PF (AGP),
ATI Rage 128 Pro VR PG (AGP?), ATI Rage 128 Pro VR PH (AGP?),
ATI Rage 128 Pro VR PI (AGP?), ATI Rage 128 Pro VR PJ (AGP?),
ATI Rage 128 Pro VR PK (AGP?), ATI Rage 128 Pro VR PL (AGP?),
ATI Rage 128 Pro VR PM (AGP?), ATI Rage 128 Pro VR PN (AGP?),
ATI Rage 128 Pro VR PO (AGP?), ATI Rage 128 Pro VR PP (PCI),
ATI Rage 128 Pro VR PQ (AGP?), ATI Rage 128 Pro VR PR (PCI),
ATI Rage 128 Pro VR PS (AGP?), ATI Rage 128 Pro VR PT (AGP?),
ATI Rage 128 Pro VR PU (AGP?), ATI Rage 128 Pro VR PV (AGP?),
ATI Rage 128 Pro VR PW (AGP?), ATI Rage 128 Pro VR PX (AGP?),
ATI Rage 128 GL RE (PCI), ATI Rage 128 GL RF (AGP),
ATI Rage 128 RG (AGP), ATI Rage 128 VR RK (PCI),
ATI Rage 128 VR RL (AGP), ATI Rage 128 4X SE (AGP?),
ATI Rage 128 4X SF (AGP?), ATI Rage 128 4X SG (AGP?),
ATI Rage 128 4X SH (AGP?), ATI Rage 128 4X SK (AGP?),
ATI Rage 128 4X SL (AGP?), ATI Rage 128 4X SM (AGP),
ATI Rage 128 4X SN (AGP?), ATI Rage 128 Pro ULTRA TF (AGP),
ATI Rage 128 Pro ULTRA TL (AGP), ATI Rage 128 Pro ULTRA TR (AGP),
ATI Rage 128 Pro ULTRA TS (AGP?), ATI Rage 128 Pro ULTRA TT (AGP?),
ATI Rage 128 Pro ULTRA TU (AGP?)
(II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP),
ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP),
ATI Radeon VE/7000 QY (AGP/PCI), ATI Radeon VE/7000 QZ (AGP/PCI),
ATI Radeon Mobility M7 LW (AGP),
ATI Mobility FireGL 7800 M7 LX (AGP),
ATI Radeon Mobility M6 LY (AGP), ATI Radeon Mobility M6 LZ (AGP),
ATI Radeon IGP320 (A3) 4136, ATI Radeon IGP320M (U1) 4336,
ATI Radeon IGP330/340/350 (A4) 4137,
ATI Radeon IGP330M/340M/350M (U2) 4337,
ATI Radeon 7000 IGP (A4+) 4237, ATI Radeon Mobility 7000 IGP 4437,
ATI FireGL 8700/8800 QH (AGP), ATI Radeon 8500 QL (AGP),
ATI Radeon 9100 QM (AGP), ATI Radeon 8500 AIW BB (AGP),
ATI Radeon 8500 AIW BC (AGP), ATI Radeon 7500 QW (AGP/PCI),
ATI Radeon 7500 QX (AGP/PCI), ATI Radeon 9000/PRO If (AGP/PCI),
ATI Radeon 9000 Ig (AGP/PCI), ATI FireGL Mobility 9000 (M9) Ld (AGP),
ATI Radeon Mobility 9000 (M9) Lf (AGP),
ATI Radeon Mobility 9000 (M9) Lg (AGP),
ATI Radeon 9100 IGP (A5) 5834,
ATI Radeon Mobility 9100 IGP (U3) 5835,
ATI Radeon 9200PRO 5960 (AGP), ATI Radeon 9200 5961 (AGP),
ATI Radeon 9200 5962 (AGP), ATI Radeon 9200SE 5964 (AGP),
ATI Radeon Mobility 9200 (M9+) 5C61 (AGP),
ATI Radeon Mobility 9200 (M9+) 5C63 (AGP), ATI Radeon 9500 AD (AGP),
ATI Radeon 9500 AE (AGP), ATI Radeon 9600TX AF (AGP),
ATI FireGL Z1 AG (AGP), ATI Radeon 9700 Pro ND (AGP),
ATI Radeon 9700/9500Pro NE (AGP), ATI Radeon 9700 NF (AGP),
ATI FireGL X1 NG (AGP), ATI Radeon 9600 AP (AGP),
ATI Radeon 9600SE AQ (AGP), ATI Radeon 9600XT AR (AGP),
ATI Radeon 9600 AS (AGP), ATI FireGL T2 AT (AGP),
ATI FireGL RV360 AV (AGP), ATI Radeon Mobility 9600 (M10) NP (AGP),
ATI Radeon Mobility 9600 (M10) NQ (AGP),
ATI Radeon Mobility 9600 (M11) NR (AGP),
ATI Radeon Mobility 9600 (M10) NS (AGP),
ATI FireGL Mobility T2 (M10) NT (AGP),
ATI FireGL Mobility T2 (M11) NV (AGP), ATI Radeon 9800SE AH (AGP),
ATI Radeon 9800 AI (AGP), ATI Radeon 9800 AJ (AGP),
ATI FireGL X2 AK (AGP), ATI Radeon 9800PRO NH (AGP),
ATI Radeon 9800 NI (AGP), ATI FireGL X2 NK (AGP),
ATI Radeon 9800XT NJ (AGP)
(II) Primary Device is: PCI 01:05:0
(--) Assigning device section with no busID to primary device
(--) Chipset ATI Radeon Mobility 9100 IGP (U3) 5835 found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -100xffe00000 - 0xffffffff (0x200000) MX[B](B)

(II) Loading sub module "radeon"
(II) LoadModule: "radeon"
(II) Reloading /usr/X11R6/lib/modules/drivers/radeon_drv.o
(II) resource ranges after probing:
[0] -100xffe00000 - 0xffffffff (0x200000) MX[B](B)
(II) Setting vga for screen 0.
(II) RADEON(0): MMIO registers at 0xd0100000
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) RADEON(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is
0x0000
(II) RADEON(0): PCI bus 1 card 5 func 0
(**) RADEON(0): Depth 16, (--) framebuffer bpp 16
(II) RADEON(0): Pixel depth = 16 bits stored in 2 bytes (16 bpp pixmaps)
(==) RADEON(0): Default visual is TrueColor
(==) RADEON(0): RGB weight 565
(II) RADEON(0): Using 6 bits per RGB (8 bit DAC)
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) RADEON(0): initializing int10
(II) RADEON(0): Primary V_BIOS segment is: 0xc000
(--) RADEON(0): Chipset: "ATI Radeon Mobility 9100 IGP (U3) 5835" (ChipID =
0x5835)
(--) RADEON(0): Linear framebuffer at 0xe0000000
(II) RADEON(0): Video RAM override, using 256 kB instead of 131072 kB
(**) RADEON(0): VideoRAM: 0 kByte (64 bit DDR SDRAM)
(II) RADEON(0): AGP card detected
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Reloading /usr/X11R6/lib/modules/libddc.a
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.2.0
ABI class: XFree86 Video Driver, version 0.6
(II) RADEON(0): I2C bus "DDC" initialized.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 2, Detected Type: 0
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 4, Detected Type: 0
(II) RADEON(0): Non-DDC laptop panel detected
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 3, Detected Type: 0
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 4, Detected Type: 0
(II) RADEON(0): Displays Detected: Monitor1--Type 2, Monitor2--Type 0

(II) RADEON(0):
(II) RADEON(0): Primary Display == Type 2
(II) RADEON(0): Panel ID string: LGP
(II) RADEON(0): Panel Size from BIOS: 1024x768
(II) RADEON(0): BIOS provided dividers will be used.
(==) RADEON(0): Using gamma correction (1.0, 1.0, 1.0)
(II) RADEON(0): Validating modes on Primary head ---------
(II) RADEON(0): Total number of valid DDC mode(s) found: 0
(II) RADEON(0): Valid mode using on-chip RMX: 800x600
(II) RADEON(0): Valid mode using on-chip RMX: 640x480
(II) RADEON(0): Total number of valid FP mode(s) found: 2
(--) RADEON(0): Virtual size is 800x600 (pitch 800)
(**) RADEON(0): *Mode "800x600": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz,
60.0 Hz
(II) RADEON(0): Modeline "800x600" 65.00 800 1048 1184 1344 600 771 777
806
(**) RADEON(0): *Mode "640x480": 65.0 MHz (scaled from 0.0 MHz), 48.4 kHz,
60.0 Hz
(II) RADEON(0): Modeline "640x480" 65.00 640 1048 1184 1344 480 771 777
806
(**) RADEON(0): Default mode "640x350": 65.0 MHz (scaled from 0.0 MHz), 48.4
kHz, 60.0 Hz
(II) RADEON(0): Modeline "640x350" 65.00 640 1048 1184 1344 350 771 777
806
(**) RADEON(0): Default mode "640x400": 65.0 MHz (scaled from 0.0 MHz), 48.4
kHz, 60.0 Hz
(II) RADEON(0): Modeline "640x400" 65.00 640 1048 1184 1344 400 771 777
806
(**) RADEON(0): Default mode "720x400": 65.0 MHz (scaled from 0.0 MHz), 48.4
kHz, 60.0 Hz
(II) RADEON(0): Modeline "720x400" 65.00 720 1048 1184 1344 400 771 777
806
(**) RADEON(0): Default mode "1024x768": 65.0 MHz (scaled from 0.0 MHz), 48.4
kHz, 60.0 Hz
(II) RADEON(0): Modeline "1024x768" 65.00 1024 1048 1184 1344 768 771 777
806
(**) RADEON(0): Default mode "832x624": 65.0 MHz (scaled from 0.0 MHz), 48.4
kHz, 60.0 Hz
(II) RADEON(0): Modeline "832x624" 65.00 832 1048 1184 1344 624 771 777
806
(++) RADEON(0): DPI set to (100, 100)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) RADEON(0): AGP Fast Write disabled by default
(II) RADEON(0): Depth moves disabled by default
(II) Loading sub module "shadowfb"
(II) LoadModule: "shadowfb"
(II) Loading /usr/X11R6/lib/modules/libshadowfb.a
(II) Module shadowfb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) RADEON(0): Page flipping disabled
(!!) RADEON(0): For information on using the multimedia capabilities
of this adapter, please see http://gatos.sf.net.
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 000xd0100000 - 0xd010ffff (0x10000) MX[B]

Fatal server error:
xf86MapPciMem: Could not mmap PCI memory
[base=0xe0000000,hostbase=0xe0000000,size=0] (Invalid argument)


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.

=============================================

Thanks,
Ssr
 
Old 07-17-2006, 06:06 AM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,667

Rep: Reputation: 112Reputation: 112
Code:
VGA-compatible devices on PCI bus:
0000:01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device
5835
This is where it starts to go wrong. The kernel doesn't recognise your videocard. It might help if you update the file pci.ids with a recent version, download from http://pciids.sourceforge.net/ The pci.ids file is located at /usr/share/misc on my Sarge system.
 
Old 07-17-2006, 07:00 AM   #3
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

Take a look at the VideoRam setting:

Section "Device"
Identifier"ATI Mobility Radeon 9000 IGP"
Driver"radeon"
VideoRam256
EndSection

This is not correct, as stated in the log:

(II) RADEON(0): Video RAM override, using 256 kB instead of 131072 kB
(**) RADEON(0): VideoRAM: 0 kByte (64 bit DDR SDRAM)

You are using 256Kb instead of 128Mb.

Remove the VideRam setting altogether form the config file, or set to appropriate value (VideoRam 131072).

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver-xfree86 problem. apenguinlinux Debian 4 08-20-2005 03:48 AM
xserver-xorg config warning: migrating xserver-xfree86 templates doctorwebbox Debian 9 07-27-2005 07:24 PM
Xserver won't start in Ubuntu using Radeon 9700 pro BrandonLuke Linux - Software 0 01-29-2005 01:13 PM
IBOOK ATI RADEON 7500 Mobility Laptop Xserver not working tried recompiling x server davegermiquet Mandriva 0 02-13-2004 06:45 PM
Any smaller XServer than XFree86 out there? GIJoe Linux - General 0 11-18-2003 05:12 AM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration