LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-14-2006, 08:07 PM   #1
onorua
LQ Newbie
 
Registered: May 2006
Location: Ukraine, Kiev
Distribution: Debian, Gentoo
Posts: 7

Rep: Reputation: 0
Updating from etch to unstable get error


Hello.

I've tried to upgrade my system from etch to unstable release. Here is how I tried to do it:
apt-get update
apt-get upgrade
apt-get dist-upgrade

And after all, I receive such error:
=====================================

Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
xfonts-utils: Depends: xfonts-encodings but it is not installed
E: Unmet dependencies. Try using -f.
======================================

When I'm rying to invoke apt-get -f install, I get:
======================================

(Reading database ... 63941 files and directories currently installed.)
Unpacking xfonts-encodings (from .../xfonts-encodings_1%3a1.0.0-3_all.deb) ...
dpkg: error processing /var/cache/apt/archives/xfonts-encodings_1%3a1.0.0-3_all.deb (--unpack):
trying to overwrite `/usr/X11R6/lib/X11/fonts/encodings/encodings.dir', which is also in package xfonts-base
Errors were encountered while processing:
/var/cache/apt/archives/xfonts-encodings_1%3a1.0.0-3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
=======================================

What I done wrong? or how can I rollback to previous state? I can't install anything due dependence, and I'm really worry about it.
Thanks in advice.
 
Old 05-14-2006, 08:21 PM   #2
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
dpkg --force-overwrite -i /var/cache/apt/archives/xfonts-encodings_1%3a1.0.0-3_all.deb
 
Old 05-15-2006, 12:26 AM   #3
onorua
LQ Newbie
 
Registered: May 2006
Location: Ukraine, Kiev
Distribution: Debian, Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by JackieBrown
dpkg --force-overwrite -i /var/cache/apt/archives/xfonts-encodings_1%3a1.0.0-3_all.deb
It helped. Thank you so much!
 
  


Reply

Tags
debian, upgrade


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error upgrading from Sarge to Etch kpachopoulos Debian 1 05-13-2006 08:07 AM
Error message during boot Debian Etch anti.corp Debian 3 12-14-2005 09:15 PM
is ubuntu unstable less unstable than debian unstable? lefty.crupps Ubuntu 9 10-14-2005 02:38 PM
Etch Unstable NetInstall CD fails on start of install BuckRogers01 Debian 9 07-16-2005 02:58 PM
Use Sarge unstable cds for Etch? adamb10 Debian 2 06-08-2005 12:44 PM


All times are GMT -5. The time now is 09:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration