Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 11-11-2004, 04:47 AM   #1
LQ Newbie
Registered: Nov 2004
Distribution: debian 3.1
Posts: 1

Rep: Reputation: 0
Question startx and kdm do not run kde or fluxbux except from failsafe

Hello all,

I'm having a problem with my debian unstable and I'm hoping some could help me solving it. Since I'm a , please be gentle.


First the problem it self:

When booting, kdm starts as it is supposed to. When giving the right credentials and selecting any displaymanager but "failsafe", kdm disappears and about a second later the xserver restarts and shows kdm again.

When failsafe is selected, the xterm starts. With the command startkde, kde starts as it is supposed to.

If I try to start the X server from the console with startx it just shows the gray background and throws me back to the console. The last message being something like "waiting for the x server to shutdown".

I have checked the kdm.log and XFree86.0.log, both report some messages which seem to be common:
Warning: font renderer for ".snf" already registered at priority 0
QImage::... Image is a null image

I have attempted to start kdm from a console with "kdm -debug 0" and no apparent errors or warnings came up.


The problem started after I used apt-get to update kde from 3.2.3 to 3.3.1 and xserver from 4.3.0.dfsg.1-1 to 4.3.0.dfsg.1-8.

The only error message that shows up, although I'm not sure if it has any thing to do with the problem is the following:

"kdm_greet[2182]: Can't open default user face"

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"

Section "Module"
#	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
#	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"PS/2"
	Option		"Emulate3Buttons"	"true"
Section "InputDevice"
	Identifier	"Generic Mouse"
	Driver		"mouse"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"

Section "Device"
	Identifier	"NVIDIA Corporation NV15 [GeForce2 GTS/Pro]"
	Driver		"nvidia"
#	Driver		"nv"
	Option		"NoLogo"		"1"

Section "Monitor"
	Identifier	"Dell E770p"
	HorizSync	30-70
	VertRefresh	50-160
	Option		"DPMS"

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV15 [GeForce2 GTS/Pro]"
	Monitor		"Dell E770p"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1024x768" "800x600" "640x480"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Generic Mouse"

Section "DRI"
	Mode	0666
Old 11-12-2004, 03:55 PM   #2
Registered: Apr 2004
Location: Motherboard
Distribution: Debian GNU/Linux
Posts: 156

Rep: Reputation: 30
Hello there,
I don't know if that might help but I had the very same problem. when faced by kdm
I enter the correct info and then xserver restarts and kdm shows up again.
The problem was that the partition was completely full (0% free disk space). when I
deleted some stuff it logged in smoothly with no problems.
Hope this helps.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE don't start (only failsafe) hifi25nl Linux - Software 1 10-24-2005 05:32 PM
KDE 3.4 & kdm & startx Angelus Linux - Software 16 05-25-2005 04:28 AM
How to set KDE to start when i run startx? ssobeht Debian 1 02-13-2005 08:01 AM
KDM -vs- startx ?.?.. hollywoodb Linux - Newbie 1 09-02-2003 04:58 PM
SuSE 7.3: All KDM choices lead to failsafe Geosharp Linux - Distributions 0 07-02-2003 09:40 AM

All times are GMT -5. The time now is 11:50 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration