LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-15-2004, 06:13 PM   #1
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
make bzImage error


I have kernel 2.4.26 and I applied the grsecurity patch. When I am recompiling (make bzImage) I get this error:
gcc -E -C -P -I/usr/src/linux-2.4.26/include -D__KERNEL__ -imacros /usr/src/linux-2.4.26/include/linux/config.h -imacros /usr/src/linux-2.4.26/include/asm-i386/segment.h -imacros /usr/src/linux-2.4.26/include/asm-i386/page.h -Ui386 arch/i386/vmlinux.lds.S >arch/i386/vmlinux.lds
ld -m elf_i386 -T /usr/src/linux-2.4.26/arch/i386/vmlinux.lds -e stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o init/version.o init/do_mounts.o \
--start-group \
arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o \
drivers/parport/driver.o drivers/char/char.o drivers/block/block.o drivers/misc/misc.o drivers/net/net.o drivers/char/agp/agp.o drivers/char/drm/drm.o drivers/ide/idedriver.o drivers/cdrom/driver.o drivers/pci/driver.o drivers/pcmcia/pcmcia.o drivers/net/pcmcia/pcmcia_net.o drivers/pnp/pnp.o drivers/video/video.o drivers/media/media.o drivers/input/inputdrv.o crypto/crypto.o \
net/network.o \
grsecurity/grsec.o \
/usr/src/linux-2.4.26/arch/i386/lib/lib.a /usr/src/linux-2.4.26/lib/lib.a /usr/src/linux-2.4.26/arch/i386/lib/lib.a \
--end-group \
-o vmlinux
fs/fs.o: In function `dput':
fs/fs.o(.text+0x13495): undefined reference to `atomic_dec_and_lock'
make: *** [vmlinux] Error 1

Can someone tell me what's wrong?
 
Old 05-16-2004, 03:51 PM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
i'm not sure. have you tried 2.4.23? i've heard about..
 
Old 06-02-2004, 12:39 PM   #3
rvieler
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
XPediTioN:
I am also trying to update Linux 2.4.26 with the corresponding grsecurity patch. I elected to download the newest Knoppix 3.4 (with Linux 2.4.26) and apply the patch from there. But when I look into the ...usr/src/linux-2.4.26 directory, all I see are "Documentation" and "include" directories? I cant find a Makefile or an image? Any help getting to the place where you are stuck would be greatly appreciated.
Ric :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error with make bzImage dmarchetti Red Hat 3 03-13-2006 01:24 PM
make bzImage error TedNugent Slackware 1 03-13-2005 11:41 PM
Error during make bzImage Sid2004 Linux - Newbie 1 10-25-2004 01:38 PM
Error with make bzImage abefroman Slackware 1 04-26-2004 09:02 AM
make bzImage error Robert0380 Linux - General 2 05-19-2003 04:12 PM


All times are GMT -5. The time now is 01:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration