LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-05-2007, 04:12 AM   #1
carsten78
LQ Newbie
 
Registered: Apr 2006
Distribution: Debian etch
Posts: 3

Rep: Reputation: 0
Loading GLX on X.org 7.1.1 fails with Nvidia


Hello,

yesterday I did an "apt-get upgrade" on my Debian-Etch. After that the X-Server always fails after loading the GLX-Module. I reinstalled the nvidia modules by hand, but that did not change the situation. I also downloaded some different drivers from the Nvidia homepage, they all had the same problem.


Here is what startx says:
Code:
xauth:  creating new authority file /root/.serverauth.3415

X: warning; process set to priority -1 instead of requested priority 0

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN 
Current Operating System: Linux voyager 2.6.18-3-k7 #1 SMP Mon Dec 4 17:23:11 UTC 2006 i686
Build Date: 30 December 2006
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  4 21:12:11 2007
(==) Using config file: "/etc/X11/xorg.conf"
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
I can't find an errormessage in the Xorg.0.log:
Code:
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN 
Current Operating System: Linux voyager 2.6.18-3-k7 #1 SMP Mon Dec 4 17:23:11 UTC 2006 i686
Build Date: 30 December 2006
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  4 21:12:11 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Standardbildschirm"
(**) |   |-->Device "nVidia Corporation NV20 [GeForce3 Ti 200]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
	Entry deleted from font path.
(**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/X11R6/lib/X11/fonts/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/X11R6/lib/X11/fonts/100dpi,
	/usr/share/fonts/X11/75dpi,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.3
	X.Org Video Driver: 1.0
	X.Org XInput driver : 0.6
	X.Org Server Extension : 0.3
	X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(--) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3099 card 0000,0000 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b099 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:0a:0: chip 109e,0350 card 0000,0000 rev 12 class 04,00,00 hdr 00
(II) PCI: 00:0b:0: chip 1274,5880 card 1274,2000 rev 02 class 04,01,00 hdr 00
(II) PCI: 00:0d:0: chip 10ec,8029 card 10ec,8029 rev 00 class 02,00,00 hdr 00
(II) PCI: 00:11:0: chip 1106,3074 card 1106,3074 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1106,0571 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:2: chip 1106,3038 card 0925,1234 rev 18 class 0c,03,00 hdr 00
(II) PCI: 00:11:3: chip 1106,3038 card 0925,1234 rev 18 class 0c,03,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0201 card 1462,5105 rev a3 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000c (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
	[0] -1	0	0xe0000000 - 0xe1ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
	[0] -1	0	0xd8000000 - 0xdfffffff (0x8000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI: (0:10:0) Brooktree Corporation Bt848 Video Capture rev 18, Mem @ 0xe2000000/12
(--) PCI:*(1:0:0) nVidia Corporation NV20 [GeForce3 Ti 200] rev 163, Mem @ 0xe0000000/24, 0xd8000000/26, 0xdc000000/19
(II) Addressable bus resource ranges are
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xd0000000 from 0xd7ffffff to 0xcfffffff
(II) Active PCI resource ranges:
	[0] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[B]O
	[1] -1	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
	[2] -1	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
	[3] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
	[4] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[B](B)
	[5] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[6] -1	0	0x0000dc00 - 0x0000dc1f (0x20) IX[B]
	[7] -1	0	0x0000d800 - 0x0000d80f (0x10) IX[B]
	[8] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[9] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
(II) Active PCI resource ranges after removing overlaps:
	[0] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[B]O
	[1] -1	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
	[2] -1	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
	[3] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
	[4] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[B](B)
	[5] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[6] -1	0	0x0000dc00 - 0x0000dc1f (0x20) IX[B]
	[7] -1	0	0x0000d800 - 0x0000d80f (0x10) IX[B]
	[8] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[9] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[B]O
	[5] -1	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
	[6] -1	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
	[7] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[B](B)
	[9] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[10] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[11] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[12] -1	0	0x0000dc00 - 0x0000dc1f (0x20) IX[B]
	[13] -1	0	0x0000d800 - 0x0000d80f (0x10) IX[B]
	[14] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[15] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
(II) LoadModule: "bitmap"
(II) Reloading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/lib/xorg/modules/libddc.so
(II) Module ddc: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
	compiled for 0.0.0, module version = 1.1.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
	compiled for 7.1.1, module version = 2.1.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.8776
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "type1"
(II) Loading /usr/lib/xorg/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.2
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Type1
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.0
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.8776
	Module class: X.Org Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.1
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6
(II) NVIDIA X Driver  1.0-8776  Mon Oct 16 21:58:46 PDT 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/lib/xorg/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 0.1.0
	ABI class: X.Org Video Driver, version 1.0
(II) resource ranges after xf86ClaimFixedResources() call:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[B]O
	[5] -1	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
	[6] -1	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
	[7] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[B](B)
	[9] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[10] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[11] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[12] -1	0	0x0000dc00 - 0x0000dc1f (0x20) IX[B]
	[13] -1	0	0x0000d800 - 0x0000d80f (0x10) IX[B]
	[14] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[15] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
(II) resource ranges after probing:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[B]O
	[5] -1	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
	[6] -1	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
	[7] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[B](B)
	[9] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B]
	[10] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B]
	[11] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B]
	[12] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[13] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[14] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[15] -1	0	0x0000dc00 - 0x0000dc1f (0x20) IX[B]
	[16] -1	0	0x0000d800 - 0x0000d80f (0x10) IX[B]
	[17] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[18] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
	[19] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B]
	[20] 0	0	0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): NVIDIA GPU GeForce3 Ti 200 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 03.20.00.20.03
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are not supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce3 Ti 200 at PCI:1:0:0:
(--) NVIDIA(0):     OEC (CRT-0)
(--) NVIDIA(0): OEC (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1152x864"
(II) NVIDIA(0):     "1024x768"
(II) NVIDIA(0):     "800x600"
(II) NVIDIA(0):     "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1152 x 864
(++) NVIDIA(0): DPI set to (100, 100); computed from -dpi X commandline option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
	[0] 0	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B]
	[1] 0	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B]
	[2] 0	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B]
	[3] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[4] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[5] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[6] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[7] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[B]O
	[8] -1	0	0xdc000000 - 0xdc07ffff (0x80000) MX[B](B)
	[9] -1	0	0xd8000000 - 0xdbffffff (0x4000000) MX[B](B)
	[10] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
	[11] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[B](B)
	[12] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
	[13] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
	[14] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
	[15] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[16] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[17] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[18] -1	0	0x0000dc00 - 0x0000dc1f (0x20) IX[B]
	[19] -1	0	0x0000d800 - 0x0000d80f (0x10) IX[B]
	[20] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[21] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
	[22] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
	[23] 0	0	0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(II) NVIDIA(0): Setting mode "1152x864"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
my xorg.conf:
Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "evdev"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "record"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "de"
    Option         "XkbVariant" "nodeadkeys"
    Option         "XkbOptions" "nodeadkeys"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "ImPS/2"
EndSection

Section "Monitor"
    Identifier     "Standardbildschirm"
    HorizSync       30.0 - 68.0
    VertRefresh     50.0 - 70.0
    Option         "DPMS"
EndSection

Section "Device"

	# Driver		"nv"
    Identifier     "nVidia Corporation NV20 [GeForce3 Ti 200]"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV20 [GeForce3 Ti 200]"
    Monitor        "Standardbildschirm"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
When I remove Load "glx" from the xorg.conf file, the System starts normal, but without GLX support.

Did anyone have the same problem or knows how to solve it?

Thanks for your help,
Carsten
 
Old 01-05-2007, 06:35 PM   #2
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
did you modprode nvidia?

Also, how did you install the nvidia drivers?
 
Old 01-06-2007, 01:04 PM   #3
carsten78
LQ Newbie
 
Registered: Apr 2006
Distribution: Debian etch
Posts: 3

Original Poster
Rep: Reputation: 0
I have the entry
Code:
alias char-major-195 nvidia
in my /etc/modules.conf and "lsmod | grep nvidia" says

Code:
nvidia               4550484  8 
i2c_core               20096  6 nvidia,tuner,bttv,i2c_viapro,i2c_algo_bit,tveeprom
agpgart                30216  2 nvidia,via_agp
The nvidia-module itself works fine, it's GLX that doesn't work. When I delete the entry
Code:
Load "glx"
from the xorg.conf, my X starts normaly, but it has no GLX-support. Keeping the entry gives me the error.

I installed the nvidia modules with "apt-get install", but I also tried compiling the driver with the packages from the Nvidia homepage (I uninstalled the debian packages before doing this). I tried some different versions, they all got the same error.

It seems tho be a problem of the xorg-xserver and the nvidia GLX modules, but I don't know more. Before doing the "apt-get upgrade", it all worked fine, but I don't know which versions of X and the Nvidia-driver I used.
 
Old 01-07-2007, 07:39 PM   #4
sleekmason
Member
 
Registered: Mar 2006
Location: Arkansas
Distribution: Sidux. Others on occasion.
Posts: 312

Rep: Reputation: 31
use this site to install the drivers: http://tinyplanet.ca/~lsorense/debia...-dri-howto.txt

let me know if this doesnt take care of it and I have a couple of other things to try.
 
Old 01-09-2007, 02:47 AM   #5
carsten78
LQ Newbie
 
Registered: Apr 2006
Distribution: Debian etch
Posts: 3

Original Poster
Rep: Reputation: 0
I did it as described on that site, but still the same problem.
 
Old 01-10-2007, 05:41 AM   #6
runnerfrog
Member
 
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
Hi.
Quote:
NVIDIA GPU GeForce3 [...] NVIDIA X Driver 1.0-8776
May be an old nvidia card?.
Instead of those outputs, you should post just the nvidia driver version, kernel version, the output error, and the already posted output of "lsmod | grep nvidia".
Is very possible that your problem might be solved by reading this other thread, in particular the issue about adding a section to your /etc/X11/xorg.conf:
http://www.linuxquestions.org/questi...d.php?t=515382
Try and tell. Cheers.
 
  


Reply

Tags
glx, nvidia, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers jollyjoice Linux - Hardware 7 06-07-2006 09:02 AM
glx loading problems mr.data Linux - Newbie 2 01-05-2006 06:59 AM
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 02:42 PM
GLX in X-ORG (voodo 3) crm Linux - Software 0 10-24-2004 05:41 AM
SOLVED: nVidia fails to load GLX library Ed-MtnBiker Fedora 0 03-26-2004 04:57 PM


All times are GMT -5. The time now is 12:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration