LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-04-2005, 03:07 PM   #1
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 49

Rep: Reputation: 17
ISOLinux from Debian etch cannot find kernel image (but kernel is in its place)! Why?


I have two DVDs with Debian etch for amd64 (I have 64-bit enabled Sempron). When I try to boot from first DVD, I get following result:

Code:
ISOLINUX 2.04 2003-04-16  Copyright (C) 1994-2003 H. Peter Anvin
Could not find kernel image: linux
boot:
Only thing what I can do is pretty useless - I can enter "isolinux" or "isolinux.bin" and get above message again. Anything else, of course, gives error "Could not find kernel image". DVDs has been downloaded from debian.org. What's wrong and how can I solve this (I need installable distribution)?
 
Old 11-05-2005, 08:16 AM   #2
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 771

Rep: Reputation: 32
Just a suggestion as I cannot test this.

If you can look at the DVD in a Linux System the file Linux should be in the Root directory and linked to another in /Boot. Try entering that name as the image.(in full, for example /boot/vmlinuz.........)

One other possibility is to make a boot floppy and boot from that.
 
Old 11-05-2005, 12:18 PM   #3
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 49

Original Poster
Rep: Reputation: 17
I can boot /install/vmlinuz, but this is useless because soon after that I get kernel panic about impossibility to mount root filesystem (cannot show messages because kernel is 64-bit, i.e. I cannot start it within VMWare). Even if I create boot floppy, I will end up like that anyway... Why etch distribution for amd64 is broken? Is this its common problem?

Normally Debian installation must start without attempt to boot normal kernel. Before installation process, I can read some help pages and make my choose between normal and expert modes (I need expert mode). Question is - how can I start installation in expert mode manually.

Last edited by *Dark Dragon*; 11-05-2005 at 01:03 PM.
 
Old 11-07-2005, 03:57 PM   #4
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 49

Original Poster
Rep: Reputation: 17
Hm, I thought that this is simple question... But as far as I understand I will not get answer, again. I did asked for other questions, but ended up without solutions; of course, I did found all solutions for my problems by myself, without any help. And I can find solution to this problem too... But if someone suggest me this solution, I will save time, and will appreciate this. Oh, no mean...

At least, can you say me, this problem is typical for etch distribution, or only for amd64 etch? I asking this because this is a major bug. I didn't investigate this problem yet, but maybe, this is because incorrectly burned image, i.e. with some unwanted changes. But creator of my DVD set is just gamer, and he did downloaded both DVD images from debian.org. Or maybe this is typical bug?

Last edited by *Dark Dragon*; 11-07-2005 at 04:06 PM.
 
Old 11-07-2005, 10:54 PM   #5
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 49

Original Poster
Rep: Reputation: 17
There is an answers: http://www.linuxquestions.org/questions/history/350967 and http://lists.debian.org/debian-amd64.../msg00110.html . So, I think this is typical problem if you have downloaded broken disk images. But thise threads didn't tell you what's wrong. But this is simple: there is no isolinux.cfg (it must be in the isolinux/ directory)! Solution is also must be simple: put this file to disk. I will try this tomorow, hopefully this will solve my problem. But before burning new DVD, I will try to type at boot prompt full kernel path (/install/vmlinuz) and add to it nessecary options. Here is part of isolinux.cfg from sarge:

Code:
LABEL expert
  kernel /install/vmlinuz
  append  DEBCONF_PRIORITY=low vga=normal initrd=/install/initrd.gz ramdisk_size=10240 root=/dev/rd/0 devfs=mount,dall rw --
So, I think only that I need to do is at least type kernel path and this options. If this solve problem, then I will burn new DVD with isolinux.cfg (I need to have easy installable disk).

Last edited by *Dark Dragon*; 11-07-2005 at 11:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
oh uh,i can't find the boot image 'isolinux.bin' shams Linux - Software 7 07-17-2007 03:34 PM
mkisofs: Error - boot image './isolinux/isolinux.bin' has not an allowable size. ogross74 Red Hat 2 05-15-2007 10:19 AM
I can't find the place where I can download ISO image of LFS from tenzan Linux From Scratch 2 05-23-2005 01:42 PM
Could not find kernel image: linux Senz Mandriva 2 09-14-2003 06:58 AM
Could not find kernel image: linux riverrat Linux - Software 1 12-01-2001 12:10 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration