LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2011, 03:59 PM   #1
dsenic2000@yahoo.com
LQ Newbie
 
Registered: Feb 2011
Location: Belgrade, Serbia
Distribution: Debian, Ubuntu
Posts: 5

Rep: Reputation: 0
Angry Installing driver for LaserJet Canon LBP2900 at Squeeze


Dear All!

Did some one solved the problem how to install Laser Printer Canon LBP2900 at Squeeze? The driver (version 2.20; in the documentation stays that they were tested some of previous versions at Debian 5.04 or like) I found at the Canon's site doesn't wish to be installed at Squeeze, but somehow I succeeded at Ubuntu 10.04 and Ubuntu 10.10.... Any proposal? Any reliable procedure, script or anything useful?

Regards!

D.Senic
 
Old 04-23-2011, 09:40 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,631

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
I tried installing canon mp240 it requests libcupsys which is not available in squeeze but is available in sid, but is also available in lenny.
That's why it's no problem in Ubuntu as it's using kernel that's considered testing for debian.
 
Old 04-23-2011, 11:04 PM   #3
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,221

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Quote:
Originally Posted by EDDY1 View Post
I tried installing canon mp240 it requests libcupsys which is not available in squeeze but is available in sid, but is also available in lenny.
That's why it's no problem in Ubuntu as it's using kernel that's considered testing for debian.
Actually it works in Ubuntu 11.04 because libcupsys is installed there. The reason is that, while 2.6.38 is used in Debian testing, it is also the current kernel in Sid.

Ubuntu syncs their normal releases to Debian unstable. Therefore they have the libcupsys in their repo for 11.04 now. Should hit us in Debian testing pretty soon

Ubuntu only syncs their pre-release repos to Debian testing for their LTS releases when they want more stability than in their other releases.
 
Old 04-23-2011, 11:30 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,631

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
That's a better way of saying, but that's what I was trying to tell op.
I myself have no desire now to install MP240 unless I put it on my wheezy machine, not trying to push squeeze to the limit.
 
Old 04-24-2011, 01:04 AM   #5
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,221

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Quote:
Originally Posted by EDDY1 View Post
That's a better way of saying, but that's what I was trying to tell op.
I myself have no desire now to install MP240 unless I put it on my wheezy machine, not trying to push squeeze to the limit.
I guess I just have a thing about peoples perception of Ubuntu. Ubuntu does a good many things but folks think of it as just an "improvement" of Debian.

The vast majority of those "improvements" are straight from the Debian repos. They are, it is true, a long way from being in the Debian stable repos. On the other hand, Debian stable is stable. Much more stable than the Ubuntu LTS releases, let alone the "regular" releases.

Don't get me wrong about Ubuntu. I admire it greatly, used it a long time as my "main" OS. Debian I just keep on here to see what all the fuss about configuring it was. Couldn't see the problem really and so when they "improved" Ubuntu to the point that it really did not run well on my box I just dropped it for Debian.

Ubuntu has a very slightly easier to understand repo system, slightly better font rendering and plymouth that excludes a number of folks with fairly new hardware from using it.

I can boot their LTS (10.04), which is basically their version of Squeeze (based on Squeeze when it was Debian testing). It takes a long time and the bugger will not shut down. You can't file a bug tht gets attention because they want the boot logs. The boot logs are the responsibility of plymouth.d. One thing is does not do on my box is right any logs.

Debian testing, my main OS now, is more stable than Ubuntu (any version), does not need Alt+SysRq+b to shut it down and with the Liquorix kernel is running the same kernel as Ubuntu 11.04.

When folks want Debian to do things that the newest Ubuntu is doing they should be running Sid and they would be slightly ahead.

I now just keep Ubuntu pre-release on my box for entertainment. Wouldn't dream of doing serious work on it or any other version of Ubuntu because you just can't quite trust it.

Somewhat sorry for the rant. Thought I should explain that I was just trying to make things clear and got carried away.
 
1 members found this post helpful.
Old 04-24-2011, 02:47 AM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,631

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Quote:
Debian testing, my main OS now, is more stable than Ubuntu (any version), does not need Alt+SysRq+b to shut it down and with the Liquorix kernel is running the same kernel as Ubuntu 11.04.
I only tried wheezy on my laptop & network was going in and out, also was out of town, and no other machine, so switched hdd that has squeeze until I get home.
Play with it later.
 
Old 04-24-2011, 02:55 AM   #7
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,683

Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
@ dsenic, from all the above posts I have managed to glean that you would need to install the 2.6.38 kernel. The easiest, although possibly not the best, way to install it would be to use the liquorix kernel. I would do this once only because Liquorix updates often and at more than 50 MB a time it can become quite a problem with bandwidth usage.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Driver for HP Laserjet 1020 daniell Linux - Newbie 23 04-23-2013 08:37 AM
Canon lbp2900 and linux problems databox Linux - Hardware 4 02-14-2011 09:30 AM
[B]My Canon LBP2900 doesn't work at FC9[/B] baig Linux - Hardware 23 03-02-2009 07:44 AM
Canon LBP2900 printer: recognized but not working Kropotkin Linux - Hardware 3 09-10-2008 11:41 PM
Installing driver for Canon Lide 60 with Suse dth1 Linux - Hardware 10 06-05-2006 01:19 PM


All times are GMT -5. The time now is 01:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration