LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 01-30-2011, 06:33 PM   #1
LQ Newbie
Registered: Nov 2003
Location: Derbyshire, UK
Distribution: Debian Testing
Posts: 14

Rep: Reputation: 0
gnome-sessions option not available at logon

Hello, all:
I have been running Lenny with the non-free nVidia drivers for a while now, but decided to run testing RC2.
When I was done my monitor had a solid blue-gray background and the mouse pointer, but none of the GUI parts displayed (blank).
After a couple of checks I went back to the gdm logon screen and opened 'sessions' to _not_ find Gnome as one of the choices.
So I logged into Gnome(failsafe) and got my full GUI.
Console (F1) and xterm also work fine.
Trying to get my Gnome Desktop back.
GDM is working and I have the session choice for TWM, but with Gnome(failsafe) working I haven't tried it yet to see if it works.
Did the usual checks for config files, etc.
Old 02-04-2011, 03:45 AM   #2
Senior Member
Registered: Apr 2005
Posts: 1,687
Blog Entries: 3

Rep: Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708
Did you upgrade or do a clean install? Your post is not at all clear on that point.
Old 02-04-2011, 03:54 AM   #3
LQ Addict
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,826

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
What is your run-level?
Some how you've changed to x-desktop.
right -clicking on screen gives options.
I have debian squeeze and it's set at run-level 2 which has regular desktop.

Last edited by EDDY1; 02-04-2011 at 03:56 AM.


desktop manager, gnomesession, xwindows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome-terminal starts automatically on gnome logon PenguinWearsFedora Red Hat 4 06-02-2010 05:12 AM
Gnome logout kills X (was "How to enable Gnome logon facebook browser...") bezdomny Debian 2 02-14-2009 04:50 PM
Multiple gnome sessions? Swinstead Linux - Newbie 3 11-29-2005 09:54 AM
More Gnome-sessions simultaneously Menestrel Debian 5 06-19-2005 04:17 PM
missing gnome option in gnome-keybinding-properties fedora core 1? lrt2003 Fedora 0 04-18-2004 08:35 PM

All times are GMT -5. The time now is 08:13 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration