LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2006, 01:55 AM   #1
fastTalker
LQ Newbie
 
Registered: Feb 2006
Location: USA
Distribution: Debian Etch, Debian Lenny, Ubuntu Feisty
Posts: 28

Rep: Reputation: 15
failed to load glx and nvidia modules


screensaver has been killing the xserver. xserver log showed that glx module was failing to load. so i decided to reinstall the nvidia drivers.

I installed the official nvidia drivers. and now i am getting this error when i try to start gdm.

Code:
(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.
by the way, i am running etch. this may have started after i did an apt-get upgrade. not sure though.

the entire xorg log file is listed below.

Code:
X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.12-1-686 i686
Current Operating System: Linux debian 2.6.15-1-686-smp #2 SMP Mon Mar 6 15:34:50 UTC 2006 i686
Build Date: 16 March 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 17 18:24:17 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "___:ffff"
(**) |   |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
        Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/usr/lib/X11/fonts/Type1".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/usr/lib/X11/fonts/Type1").
(WW) The directory "/usr/share/fonts/X11/CID" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
        Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/share/fonts/X11/misc,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/lib/X11/fonts/Speedo,/usr/share/fonts/X11/100dpi,/usr/lib/X11/fonts/100dpi,/usr/share/fonts/X11/75dpi,/usr/lib/X11/fonts/75dpi,/usr/share/fonts/X11/misc/,/usr/share/fonts/X11/TTF/,/usr/share/fonts/X11/OTF,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/CID/,/usr/share/fonts/X11/100dpi/,/usr/share/fonts/X11/75dpi/"
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.2
        X.Org Video Driver: 0.8
        X.Org XInput driver : 0.5
        X.Org Server Extension : 0.2
        X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,2770 card 8086,4e53 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,2771 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:1b:0: chip 8086,27d8 card 8086,0707 rev 01 class 04,03,00 hdr 00
(II) PCI: 00:1c:0: chip 8086,27d0 card 0000,0000 rev 01 class 06,04,00 hdr 81
(II) PCI: 00:1c:2: chip 8086,27d4 card 0000,0000 rev 01 class 06,04,00 hdr 81
(II) PCI: 00:1c:3: chip 8086,27d6 card 0000,0000 rev 01 class 06,04,00 hdr 81
(II) PCI: 00:1c:4: chip 8086,27e0 card 0000,0000 rev 01 class 06,04,00 hdr 81
(II) PCI: 00:1c:5: chip 8086,27e2 card 0000,0000 rev 01 class 06,04,00 hdr 81
(II) PCI: 00:1d:0: chip 8086,27c8 card 8086,4e53 rev 01 class 0c,03,00 hdr 80
(II) PCI: 00:1d:1: chip 8086,27c9 card 8086,4e53 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:1d:2: chip 8086,27ca card 8086,4e53 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:1d:3: chip 8086,27cb card 8086,4e53 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:1d:7: chip 8086,27cc card 8086,4e53 rev 01 class 0c,03,20 hdr 00
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev e1 class 06,04,01 hdr 01
(II) PCI: 00:1f:0: chip 8086,27b8 card 8086,4e53 rev 01 class 06,01,00 hdr 80
(II) PCI: 00:1f:2: chip 8086,27c0 card 8086,4e53 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:1f:3: chip 8086,27da card 8086,4e53 rev 01 class 0c,05,00 hdr 00
(II) PCI: 01:00:0: chip 10de,00c0 card 1682,2178 rev a2 class 03,00,00 hdr 00
(II) PCI: 07:02:0: chip 4444,0016 card 0070,8003 rev 01 class 04,00,00 hdr 00
(II) PCI: 07:03:0: chip 1186,1300 card 1186,1301 rev 10 class 02,00,00 hdr 00
(II) PCI: 07:05:0: chip 104c,8024 card 8086,4e53 rev 00 class 0c,00,10 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,7), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
        [0] -1  0       0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
        [0] -1  0       0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
        [0] -1  0       0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
        [0] -1  0       0x54000000 - 0x55ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
        [0] -1  0       0x40000000 - 0x4fffffff (0x10000000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:28:0), (0,2,2), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 2 non-prefetchable memory range:
        [0] -1  0       0x56200000 - 0x562fffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:28:2), (0,3,3), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 3 non-prefetchable memory range:
        [0] -1  0       0x56300000 - 0x563fffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 4: bridge is at (0:28:3), (0,4,4), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 4 non-prefetchable memory range:
        [0] -1  0       0x56400000 - 0x564fffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 5: bridge is at (0:28:4), (0,5,5), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 5 non-prefetchable memory range:
        [0] -1  0       0x56500000 - 0x565fffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 6: bridge is at (0:28:5), (0,6,6), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 6 non-prefetchable memory range:
        [0] -1  0       0x56600000 - 0x566fffff (0x100000) MX[B]
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 7: bridge is at (0:30:0), (0,7,7), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 7 I/O range:
        [0] -1  0       0x00001000 - 0x000010ff (0x100) IX[B]
        [1] -1  0       0x00001400 - 0x000014ff (0x100) IX[B]
        [2] -1  0       0x00001800 - 0x000018ff (0x100) IX[B]
        [3] -1  0       0x00001c00 - 0x00001cff (0x100) IX[B]
(II) Bus 7 non-prefetchable memory range:
        [0] -1  0       0x56000000 - 0x560fffff (0x100000) MX[B]
(II) Bus 7 prefetchable memory range:
        [0] -1  0       0x50000000 - 0x53ffffff (0x4000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV41.0 rev 162, Mem @ 0x55000000/24, 0x40000000/28, 0x54000000/24, BIOS @ 0xfffe0000/0
(--) PCI: (7:2:0) unknown vendor (0x4444) unknown chipset (0x0016) rev 1, Mem @ 0x50000000/26
(II) Addressable bus resource ranges are
        [0] -1  0       0x00000000 - 0xffffffff (0x0) MX[B]
        [1] -1  0       0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
        [0] -1  0       0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0       0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0       0x0000ffff - 0x0000ffff (0x1) IX[B]
        [6] -1  0       0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
        [0] -1  0       0x56000000 - 0x56003fff (0x4000) MX[B]
        [1] -1  0       0x56004000 - 0x560047ff (0x800) MX[B]
        [2] -1  0       0x56004800 - 0x560048ff (0x100) MX[B]
        [3] -1  0       0x56104400 - 0x561047ff (0x400) MX[B]
        [4] -1  0       0x56100000 - 0x56103fff (0x4000) MX[B]
        [5] -1  0       0x50000000 - 0x53ffffff (0x4000000) MX[B](B)
        [6] -1  0       0xfffe0000 - 0xfffe0000 (0x1) MX[B](B)
        [7] -1  0       0x54000000 - 0x54ffffff (0x1000000) MX[B](B)
        [8] -1  0       0x40000000 - 0x4fffffff (0x10000000) MX[B](B)
        [9] -1  0       0x55000000 - 0x55ffffff (0x1000000) MX[B](B)
        [10] -1 0       0x00001000 - 0x000010ff (0x100) IX[B]
        [11] -1 0       0x00002000 - 0x0000201f (0x20) IX[B]
        [12] -1 0       0x000020a0 - 0x000020af (0x10) IX[B]
        [13] -1 0       0x00002020 - 0x0000203f (0x20) IX[B]
        [14] -1 0       0x00002040 - 0x0000205f (0x20) IX[B]
        [15] -1 0       0x00002060 - 0x0000207f (0x20) IX[B]
        [16] -1 0       0x00002080 - 0x0000209f (0x20) IX[B]
(II) Active PCI resource ranges after removing overlaps:
        [0] -1  0       0x56000000 - 0x56003fff (0x4000) MX[B]
        [1] -1  0       0x56004000 - 0x560047ff (0x800) MX[B]
        [2] -1  0       0x56004800 - 0x560048ff (0x100) MX[B]
        [3] -1  0       0x56104400 - 0x561047ff (0x400) MX[B]
        [4] -1  0       0x56100000 - 0x56103fff (0x4000) MX[B]
        [5] -1  0       0x50000000 - 0x53ffffff (0x4000000) MX[B](B)
        [6] -1  0       0xfffe0000 - 0xfffe0000 (0x1) MX[B](B)
        [7] -1  0       0x54000000 - 0x54ffffff (0x1000000) MX[B](B)
        [8] -1  0       0x40000000 - 0x4fffffff (0x10000000) MX[B](B)
        [9] -1  0       0x55000000 - 0x55ffffff (0x1000000) MX[B](B)
        [10] -1 0       0x00001000 - 0x000010ff (0x100) IX[B]
        [11] -1 0       0x00002000 - 0x0000201f (0x20) IX[B]
        [12] -1 0       0x000020a0 - 0x000020af (0x10) IX[B]
        [13] -1 0       0x00002020 - 0x0000203f (0x20) IX[B]
        [14] -1 0       0x00002040 - 0x0000205f (0x20) IX[B]
        [15] -1 0       0x00002060 - 0x0000207f (0x20) IX[B]
        [16] -1 0       0x00002080 - 0x0000209f (0x20) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
        [0] -1  0       0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0       0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0       0x0000ffff - 0x0000ffff (0x1) IX[B]
        [6] -1  0       0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
        [0] -1  0       0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0       0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0       0x56000000 - 0x56003fff (0x4000) MX[B]
        [6] -1  0       0x56004000 - 0x560047ff (0x800) MX[B]
        [7] -1  0       0x56004800 - 0x560048ff (0x100) MX[B]
        [8] -1  0       0x56104400 - 0x561047ff (0x400) MX[B]
        [9] -1  0       0x56100000 - 0x56103fff (0x4000) MX[B]
        [10] -1 0       0x50000000 - 0x53ffffff (0x4000000) MX[B](B)
        [11] -1 0       0xfffe0000 - 0xfffe0000 (0x1) MX[B](B)
        [12] -1 0       0x54000000 - 0x54ffffff (0x1000000) MX[B](B)
        [13] -1 0       0x40000000 - 0x4fffffff (0x10000000) MX[B](B)
        [14] -1 0       0x55000000 - 0x55ffffff (0x1000000) MX[B](B)
        [15] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
        [16] -1 0       0x00000000 - 0x000000ff (0x100) IX[B]
        [17] -1 0       0x00001000 - 0x000010ff (0x100) IX[B]
        [18] -1 0       0x00002000 - 0x0000201f (0x20) IX[B]
        [19] -1 0       0x000020a0 - 0x000020af (0x10) IX[B]
        [20] -1 0       0x00002020 - 0x0000203f (0x20) IX[B]
        [21] -1 0       0x00002040 - 0x0000205f (0x20) IX[B]
        [22] -1 0       0x00002060 - 0x0000207f (0x20) IX[B]
        [23] -1 0       0x00002080 - 0x0000209f (0x20) IX[B]
(II) LoadModule: "bitmap"
(II) Reloading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/lib/xorg/modules/libddc.so
(II) Module ddc: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
        compiled for 7.0.0, module version = 2.1.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(WW) Warning, couldn't open module GLcore
(II) UnloadModule: "GLcore"
(II) UnloadModule: "glx"
(II) Unloading /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "type1"
(II) Loading /usr/lib/xorg/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.2
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.1.0
        ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(II) LoadModule: "keyboard"
(II) Loading /usr/lib/xorg/modules/input/keyboard_drv.so
(II) Module keyboard: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.4
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(EE) No drivers available.
 
Old 07-18-2006, 10:16 AM   #2
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Rep: Reputation: 30
when you go to run the nvidia installer run it with:

./nvidia.run --x-module-path=/usr/lib/xorg/modules/
 
Old 07-18-2006, 10:52 AM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by Michael_aust
when you go to run the nvidia installer run it with:

./nvidia.run --x-module-path=/usr/lib/xorg/modules/
Even better idea would be running the uninstall option hoping it gets rid of everything then making sure that contrib and non-free are in the line for his etch sources then run these commands.

Code:
apt-get install module-assistant
m-a prepare
m-a a-i -i -t -f nvidia-kernel
apt-get install nvidia-glx nvidia-glx-dev
Which should use the modules assistant to prepare/download the kernel-headers for the running kernel build the nvidia modules for said kernel and install them, I would reboot just to make sure to initialize everything for the first time.
 
Old 07-18-2006, 01:04 PM   #4
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Rep: Reputation: 30
using apt to install the drivers wont work at the moment as the nvidia packages dont match the kernel in etch.
 
Old 07-18-2006, 01:46 PM   #5
fastTalker
LQ Newbie
 
Registered: Feb 2006
Location: USA
Distribution: Debian Etch, Debian Lenny, Ubuntu Feisty
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Michael_aust
when you go to run the nvidia installer run it with:

./nvidia.run --x-module-path=/usr/lib/xorg/modules/
Ah yeah. that rings a bell. I had forgotten about that since the last time i installed the nvidia driver.

screensaver appears to working again as well.

thanks!
 
Old 07-18-2006, 01:46 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by Michael_aust
using apt to install the drivers wont work at the moment as the nvidia packages dont match the kernel in etch.
The module-assistant downloads the source and compiles the correct module for your running kernel as long as the headers are available it will work.
 
Old 07-19-2006, 08:10 AM   #7
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Rep: Reputation: 30
how would that work seeing as the nvidia-glx package no longer exists in the repos and you are saying to apt-get it
 
Old 07-19-2006, 12:56 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by Michael_aust
how would that work seeing as the nvidia-glx package no longer exists in the repos and you are saying to apt-get it
Looks like you would need a temporary line for sid in the sources.list if running etch to get it.

Code:
>$ apt-cache policy nvidia-glx
nvidia-glx:
  Installed: 1.0.8762-2
  Candidate: 1.0.8762-2
  Version table:
 *** 1.0.8762-2 0
        600 http://ftp2.de.debian.org sid/non-free Packages
        100 /var/lib/dpkg/status
 
Old 07-19-2006, 06:20 PM   #9
fastTalker
LQ Newbie
 
Registered: Feb 2006
Location: USA
Distribution: Debian Etch, Debian Lenny, Ubuntu Feisty
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by HappyTux
Looks like you would need a temporary line for sid in the sources.list if running etch to get it.

Code:
>$ apt-cache policy nvidia-glx
nvidia-glx:
  Installed: 1.0.8762-2
  Candidate: 1.0.8762-2
  Version table:
 *** 1.0.8762-2 0
        600 http://ftp2.de.debian.org sid/non-free Packages
        100 /var/lib/dpkg/status
too much work on my part.
--x-module-path=/usr/lib/xorg/modules/ definately takes care of my problem.
 
Old 07-19-2006, 10:19 PM   #10
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
Well the advantage of doing it with module assisant is that you don't have to re-install your nvidia installer withe each minor kernel version.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no display: Xorg, Nvidia driver broken after Etch update; Failed to load module "glx" forgox Debian 19 07-12-2010 01:26 PM
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 06:51 PM
ati glx load with NVIDIA TuxFreak Fedora 10 01-30-2005 12:51 PM
No NVIDIA-GLX modules ??? Creak Linux - Hardware 5 08-02-2004 01:59 PM
(EE) NVIDIA (0) : Failed to load GLX (what's wrong ???) Linux_Inside Slackware 6 10-23-2003 03:19 AM


All times are GMT -5. The time now is 05:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration