LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-18-2007, 07:08 PM   #1
@ngelot
Member
 
Registered: Oct 2004
Posts: 84

Rep: Reputation: 15
Failed dist-upgrade


On my debian stable I'm running kernel 2.2.20

I did a apt-get upgrade without any problems, and then I did a apt-get dist-upgrade. I got this message:
Code:
Name Service Switch update in the C Library: pre-installation question.

Running services and programs that are using NSS need to be restarted,
otherwise they might not be able to do lookup or authentication any more.
The installation process is able to restart some services (such as ssh or
telnetd), but other programs cannot be restarted automatically.  One such
program that needs manual stopping and restart after the glibc upgrade by
yourself is xdm - because automatic restart might disconnect your active
X11 sessions.

Known packages that need to be stopped before the glibc upgrade are:
        xdm kdm gdm postgresql xscreensaver

This script did not detect any installed services which need to be
stopped.

If you want to interrupt the upgrade now and continue later, please
answer No to the question below.

Do you want to upgrade glibc now? [Y/n]
After answering Yes I got this:
Code:
WARNING: This version of glibc requires that you be running
kernel version 2.4.1 or later. Earlier kernels contained
bugs that may render the system unusable if a modern version
of glibc is installed.
dpkg: Feil ved behandling av /var/cache/apt/archives/libc6_2.3.6.ds1-13_i386.deb (--unpack):
 underprosessen pre-installation script returnerte feilstatus 1
Det oppsto feil ved behandling av:
 /var/cache/apt/archives/libc6_2.3.6.ds1-13_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
(Sorry it's in norwegian...)
Code:
# apt-get install linux-image-2.6-686
Leser pakkelister ... Ferdig
Skaper oversikt over avhengighetsforhold ... Ferdig
Du vil kanskje utføre "apt-get -f install" for å rette på disse:
Følgende pakker har uinnfridde avhengighetsforhold:
  libc6-dev: Avhenger av: libc6 (= 2.3.6.ds1-13) men 2.3.2.ds1-22sarge5 skal installeres
  linux-image-2.6-686: Avhenger av: linux-image-2.6.18-4-686 men skal ikke installeres
  locales: Avhenger av: glibc-2.3.6.ds1-1
E: Uinnfridde avhengighetsforhold. Prøv "apt-get -f install" uten pakker (eller angi en løsning).
apt-get -f install turn into a loop where I'm getting the same messages....
apt-get upgrade and apt-get dist-upgrade gives me the same errormessages:
Code:
# apt-get upgrade
Leser pakkelister ... Ferdig
Skaper oversikt over avhengighetsforhold ... Ferdig
Du vil kanskje kjøre "apt-get -f install" for å rette på dette.
Følgende pakker har uinnfridde avhengighetsforhold:
  libc6-dev: Avhenger av: libc6 (= 2.3.6.ds1-13) men 2.3.2.ds1-22sarge5 er installert
  locales: Avhenger av: glibc-2.3.6.ds1-1
E: Uinnfridde avhengighetsforhold - Prøv "-f".
How can I fix this so that I can install a newer kernel, and then try dist upgrade again....?

Please help - I'm stuck...
 
Old 07-18-2007, 07:20 PM   #2
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
I got stuck in one of these problems, and people kept preaching at me that I should be using aptitude.

The process is detailed in one of the later posts on my thread (apt-get hell)

I can't read norweigan but some of the other things in that thread might help you...
 
Old 07-18-2007, 07:24 PM   #3
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,667

Rep: Reputation: 112Reputation: 112
You didn't upgrade your system in a while, haven't you? You're still on Woody or maybe even Potato Anyway, the easiest way to upgrade now is to start from scratch. Yes, I know Debian has a "install once, upgrade forever" policy, but: a) that only works if you keep pace with release cycles and b) it's no use trying to fix something that'll take forever to fix. Get yourself the Etch net-install cd (current Stable) and install again. Be sure to backup any data before you begin

Last edited by Dutch Master; 07-18-2007 at 07:25 PM.
 
Old 07-19-2007, 11:36 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,570

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
Quote:
Originally Posted by @ngelot
On my debian stable I'm running kernel 2.2.20
???

Debian Stable (Etch) is at 2.6.18. Debian OldStable (Sarge) is on 2.6.8/2.4.27 (iirc). You're running a very old version.

As mentioned, you should do a clean install of Etch.
 
Old 07-19-2007, 12:57 PM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 62
dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.3.6.ds1-13_i386.deb to get by the packaging error then dpkg --configure -a to get the unconfigured packages when the error happened now proceed with your dist-upgrade/new kernel install.
 
Old 07-19-2007, 08:36 PM   #6
Daws
Member
 
Registered: May 2006
Location: UK
Distribution: Debian, Linux From Scratch
Posts: 416
Blog Entries: 1

Rep: Reputation: 30
Quote:
dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.3.6.ds1-13_i386.deb to get by the packaging error then dpkg --configure -a to get the unconfigured packages when the error happened now proceed with your dist-upgrade/new kernel install.
Hmm maybe... but as was stated earlier 2.2.20 was last seen in Woody, the rest of the system itself could be a lot older. This error is likely the first of many down the line. I agree with the others, a reinstall would be my first suggestion. Upgrading a 2.2 kernel directly to a 2.6 is ok if you are insane and have nothing to lose and in the unlikely event that it works, you still have all the other packages to upgrade.

@ngelot, if you are going to take the HappyTux route, and I cannot stress this enough: you'd better have some recent backups.
 
Old 07-28-2007, 06:55 PM   #7
@ngelot
Member
 
Registered: Oct 2004
Posts: 84

Original Poster
Rep: Reputation: 15
Thanks for all help!

My problem is now solved !!

What I did was to download and install the oldstable-versions of libc6, libc6-dev and locales.

I had to purge tzdata to get oldstable libc installed.

After that libc6-dev was having issues with locales, but this was also solved installing the oldstable versions of both.

Now apt have no errors, and I'll be sure to install a newer kernel before doing any dist-upgrades!!

What probably happend was that I when I set up the server in oct 2004 I compiled my own kernel. Doing this I haven't had any kernel-upgrades using apt since, and I was stuck with 2.2.20...

Anyway - it's solved now and I'm a happy penguin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 01:33 PM
debian upgrade dist-upgrade gabsik Linux - Software 1 07-19-2006 04:38 AM
Will 'aptitude upgrade or dist-upgrade' downgrade manually installed deb package? Akhran Debian 3 03-14-2006 02:40 PM
dist-upgrade failed! HELP! seppe Debian 5 11-05-2003 03:50 PM
Error trying to dist-upgrade or upgrade KDE prophet621 Linux - Newbie 0 09-10-2003 04:17 PM


All times are GMT -5. The time now is 07:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration