LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-12-2004, 05:23 PM   #16
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
GNOME lovers


For a light and fast Gnome:

#apt-get install gnome-core icewm (it could be fluxbox, blackbox, wmaker)

once you have Gnome installed, change the default window manager in Gnome, from Metacity to IceWM.

With your favorite editor edit the file:

/home/your_user_name/.gnomerc

or

~/.gnomerc

change the second line, to look like this:

# set the default GNOME window manager
export WINDOW_MANAGER=icewm

save/exit


Right-click on the terminal icon and choose 'Properties'
change the 'Name' and 'Command' lines to read:

xterm

it will launch a terminal faster.

logout/login

voilá!

Unfortunately, still no match for XFCE4 when it comes to speed.

CORRECTION!!!

after editing the line in /.gnomerc IT SHOULD READ:

# set the default GNOME window manager
export WINDOW_MANAGER=/usr/bin/icewm


Last edited by macondo; 10-13-2004 at 06:04 PM.
 
Old 09-20-2004, 02:29 PM   #17
jbrader
LQ Newbie
 
Registered: Sep 2004
Location: Washington State
Distribution: Debian
Posts: 3

Rep: Reputation: 0
Thanks this is really great. I was all set to ask a bunch of questions regarding my new debian install but I'm gonna go through all this first.
 
Old 09-26-2004, 05:59 AM   #18
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
I am making this a stick thread as I think it will be useful to all.

Macondo - have you seen our Linux Tutorial section? I think that some, if not all, of this would make a great addition to that section.
 
Old 09-26-2004, 08:41 AM   #19
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
XavierP:

i already did, it's under Applications/GUI/Multimedia, thanks.
 
Old 09-26-2004, 09:10 PM   #20
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
hey macondo,

i was checking out your suggestion about lightening gnome, but i don't have a ~/.gnomerc file (i'm running gnome 2.6 on sarge). i tried creating a .gnomerc that includes only the line

export WINDOW_MANAGER=icewm

and restarted gnome, but icewm is definately not the new gnome WM (ice is installed, and i can run it independently). any thoughts?

zero
 
Old 09-27-2004, 08:15 AM   #21
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
"i was checking out your suggestion about lightening gnome, but i don't have a ~/.gnomerc file (i'm running gnome 2.6 on sarge). i tried creating a .gnomerc that includes only the line"

export WINDOW_MANAGER=icewm
*******************************************

~/.gnomerc = /home/your_username/.gnomerc

you SHOULD have a /.gnomerc

try this in your /home/user_name/.gnomerc:

export WINDOW_NANGER=/usr/bin/icewm

reboot

"and restarted gnome, but icewm is definately not the new gnome WM (ice is installed, and i can run it independently). any thoughts?"

let me know if now it works, i'm downloading 'gnome-core' again, so i can answer any questions.

EDIT: I downloaded 'gnome-core', disabled the splash screen in

Applicatins/Desktop Preferences/Advanced/Sessions

it just eats ram, configured the background to 'No Wallpaper' in

Applications/Desktop Preferences/Desktop Background

eliminating the blue wallpaper, for a plain one (saving ram), changed the window manager to icewm, changed the terminal to 'xterm' in the Terminal icon Properties, rebooted, works great.

this is what i show in my ~/.gnomerc after editing it:

# set the default GNOME window manager
export WINDOW_MANAGER=/usr/bin/icewm

I will correct the original post, thanks, and i'm sorry.

Last edited by macondo; 09-27-2004 at 09:15 AM.
 
Old 09-27-2004, 06:47 PM   #22
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
thanks for the suggestion macondo, but that didn't do the trick either. could the fact that i'm starting gnome from gdm be an issue? does gdm use it's own gnome resource file perhaps? thanks.
 
Old 09-27-2004, 07:27 PM   #23
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
zero79 wrote:
i don't have a ~/.gnomerc file
Perhaps you could put the export line into ~/.xsession. Something like:
Code:
export WINDOW_MANAGER=/usr/bin/icewm
exec gnome-session
I think that the "default" session in GDM reads the ~/.xsession file, but I might be wrong (I haven't used Gnome or GDM for some time).
 
Old 09-27-2004, 07:55 PM   #24
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
"thanks for the suggestion macondo, but that didn't do the trick either. could the fact that i'm starting gnome from gdm be an issue? does gdm use it's own gnome resource file perhaps? thanks."

I don't think gdm has anything to do with it, although, i'm using xdm, but it shouldn't.

Do you mean ~/.gnomerc does not exist in your box?

What shows when you try to see it with your favorite editor?

Example:
#vim /home/macondo/.gnomerc

?????

are you using a graphical editor (gedit, kate, etc), if so, is it possible it's not showing the hidden files?

Or are you looking with a file manager and have NOT enabled the view of the hidden files?

#apt-get install mc

Just in case, as root, invoke 'mc', go down the left list with the 'down' arrow till the end, where the file names are of a lighter or different color, and look for '.gnomerc', select it, press F4 to edit, make your change, F2 to save, F10 TWICE to get out, logout/login. Report back.

Last edited by macondo; 09-27-2004 at 08:24 PM.
 
Old 09-27-2004, 09:03 PM   #25
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
i'm using the shell (xterm) to manipulate my file system and vi to edit text files.

the ".gnomerc" file did not exist before i started making changes. when i did

Code:
ls ~/.gnomerc
i got nothing on the standard output. i created the ".gnomerc" file so that it only contains your suggestion, so now when i do

Code:
cat ~/.gnomerc
i get

Code:
export WINDOW_MANAGER=/usr/bin/icewm
on the standard output. i actually don't have an "~/.xsession" file either. i don't know how gdm knows how to load gnome/kde/icewm/etc. i've looked in "/etc/gdm" and can't find the file which tells gdm what desktop environment to load.

thanks again for your thoughts.

peace.
 
Old 09-27-2004, 09:28 PM   #26
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
Hmm, i can see creating the ~/.xsession, i had to, but the ~/.gnomerc was already there after the gnome installation.
Weird.
 
Old 09-27-2004, 09:35 PM   #27
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I seem to recall that GDM checks its session files from /etc/gdm/Sessions/. Or perhaps it was /etc/dm/Sessions/. If you haven't got either of these, you can just create the ~/.xsession file, make it a shell script, and make it executable.
 
Old 09-28-2004, 06:05 PM   #28
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
mo' better fonts

in addition to the previous post about better fonts, do this:

1) Install x-ttcidfont-conf and defoma (you probably already have defoma)

2) Add a line like this to /etc/X11/XF86Config-4, in the "Files" section FontPath at the top.

"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

It should look like this:

FontPath "unix/:7100" # local font server
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
FontPath "/usr/lib/X11/fonts/Type1"

reboot

Last edited by macondo; 09-28-2004 at 06:06 PM.
 
Old 10-02-2004, 07:51 PM   #29
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 49
Guarddog: opening port for incoming connection

Contributed by omry_y:

How can I open a port (ssh, http) for incomming connections using guarddog?

Answer:
Got this reply from a good soul on guarddog mailing list:
Click the Protocol tab then select the "local" zone.
On the right, expand "Interactive sessions". Find SSH and check (not X) the boxes to allow the local zone to provide SSH services to whatever other zones you choose.
 
Old 10-02-2004, 08:28 PM   #30
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
Hey macondo! You've got good timing m' man. I just recently came back to Debian after trying out Slack for a while, and caught this thread just the other day with my freshly-burned Sarge netinst CD in-hand. :)

I've followed your tips, and have a few comments:

1. Regarding editors: Rather than vim, I recommend nedit. It's just so simple, clean, and easy to use. I've even written a small help sheet for folks using nedit: http://www.simisen.com/jmg/nedit_help.html

2. Thank you thank you thank you for the tip about firestarter. Nice.

3. Thanks also for the xchat instructions. That looks like a great program. IIRC, I've never used IRC. :) But when I do give it a try, I'll use xchat.

4. Regarding getting sound/audio working: I didn't need to do anything. I installed sndconfig and ran it, but it told me my SB Live! card wasn't supported. I quit sndconfig, opened an mp3 in gxine, and boom -- it worked. I didn't even need to add myself to the audio group as I already was in that group.

Am I using ALSA? How can I tell? "dpkg -l | grep -i alsa" gives me nothing.

If I'm using alsa, does aumix affect it? *EDIT*: yup, changing the volume in aumix does actually change the volume.

5. Eek! A default install doesn't give you modconf. 'apt-get install modconf'

6. You suggest installing "discover" and mention that it's very useful. When do you directly use discover? Or is it something the system automatically uses at boot-time? Is it used by hotplug in some way? kudzu?

7. Regarding the tips you give about fonts -- I'm not sure I get the point. I'm using icewm too, and most of time I'm just looking at xterms (which use fixed-width "10x20" ). I installed the Bitstream Vera fonts along with mozilla-firefox and mozilla-thunderbird, and they seem to work just fine right out-of-the-box with the Vera fonts. What does the tweaking you recommend get you?

Some packages I've got installed that are pretty useful:
usbview
xcolorsel (for use in selecting text-highlighting colors in nedit)
wget

Thanks again for the contribution. :)

Last edited by johnMG; 06-26-2005 at 04:49 PM.
 
  


Reply

Tags
debian, setup


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Debian Post-Install Configuration macondo LinuxAnswers Discussion 5 12-11-2008 10:21 PM
(new to Debian) post install questions gugamare Debian 4 11-01-2005 09:01 AM
debian ugly post-install ssaady Debian 4 10-27-2005 06:02 AM
FC3 installation fails at post install configuration stage grstaker Fedora - Installation 8 06-20-2005 10:43 AM
RedHat 7.3 post install configuration LOCKS UP sput Linux - Distributions 7 07-19-2002 12:10 PM


All times are GMT -5. The time now is 11:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration