LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2006, 02:37 PM   #1
FWSquatch
Member
 
Registered: Jan 2006
Location: Fort Worth, TX
Distribution: Ubuntu, DSL
Posts: 47

Rep: Reputation: 15
apt-get and dependencies


I'm pretty new at this and so far I'm loving the apt-get command. I was under the impression that it would find dependencies and then install the packages needed. I've been trying to install gnucash, and it's giving me all kinds of unmet dependencies:

Code:
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  gnucash: Depends: gnucash-common (>= 1.8.12-6) but it is not going to be installed
           Depends: bonobo (>= 1.0.22) but it is not going to be installed
           Depends: gdk-imlib11 but it is not going to be installed
           Depends: libart2 (>= 1.2.13-5) but it is not going to be installed
           Depends: libbonobo2 (>= 1.0.22) but it is not going to be installed
           Depends: libdb3 (>= 3.2.9-23) but 3.2.9-22 is to be installed
           Depends: libgal23 (>= 0.24) but it is not going to be installed
           Depends: libgconf11 (>= 1.0.7) but it is not going to be installed
           Depends: libgdk-pixbuf-gnome2 (>= 0.22.0) but it is not going to be installed
           Depends: libgdk-pixbuf2 (>= 0.22.0) but it is not going to be installed
           Depends: libghttp1 but it is not going to be installed
           Depends: libglade-gnome0 but it is not going to be installed
           Depends: libglade0 but it is not going to be installed
           Depends: libglib1.2 (>= 1.2.0) but it is not going to be installed
           Depends: libgnome32 (>= 1.2.13-5) but it is not going to be installed
           Depends: libgnomeprint15 (>= 0.29-1) but it is not going to be installed
           Depends: libgnomesupport0 (>= 1.2.13-5) but it is not going to be installed
           Depends: libgnomeui32 (>= 1.4.2-3) but it is not going to be installed
           Depends: libgtk1.2 (>= 1.2.10-4) but it is not going to be installed
           Depends: libgtkhtml1.1-3 (>= 1.1.10) but it is not going to be installed
           Depends: libguppi16 but it is not going to be installed
           Depends: libgwrapguile1 (>= 1.3.4-5) but it is not going to be installed
           Depends: libltdl3 (>= 1.5.2-2) but it is not going to be installed
           Depends: liboaf0 (>= 0.6.10) but it is not going to be installed
           Depends: libofx2c2a but it is not going to be installed
           Depends: liborbit0 (>= 0.5.17) but it is not going to be installed
           Depends: libstdc++6 (>= 4.0.2-4) but it is not going to be installed
           Depends: libxml1 (>= 1:1.8.14-3) but it is not going to be installed
           Depends: libzvt2 (>= 1.4.1.3-3) but it is not going to be installed
           Depends: oaf (>= 0.6.10) but it is not going to be installed
           Depends: slib (>= 3a2-5) but it is not going to be installed
           Depends: guile-1.6-slib but it is not going to be installed
           Depends: libfinance-quote-perl but it is not going to be installed
           Depends: libdate-manip-perl but it is not going to be installed
           Depends: psfontmgr but it is not going to be installed
           Depends: x-ttcidfont-conf but it is not going to be installed
           Depends: libgconf11 (>= 1.0.9-7) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
What is causing this? Are there some packages that I'm looking for that are not in the repository or is there something else that I'm missing?
 
Old 02-01-2006, 02:58 PM   #2
ingvildr
Member
 
Registered: Mar 2005
Location: England, South East
Distribution: Fedora
Posts: 358

Rep: Reputation: 30
first have you tried running apt-get -f install like it suggests and second what branch are you using sid, etch, sarge.
 
Old 02-01-2006, 03:47 PM   #3
FWSquatch
Member
 
Registered: Jan 2006
Location: Fort Worth, TX
Distribution: Ubuntu, DSL
Posts: 47

Original Poster
Rep: Reputation: 15
Sorry about not being specific. Yes, I tried the -f and still got the same messages. I'm running Sarge and my kernel is 2.4. Here is my sources.list

Code:
#deb file:///cdrom/ sarge main

deb cdrom:[Debian GNU/Linux 3.1 r0a _Sarge_ - Official i386 Binary-1 (20050607)]
/ unstable contrib main

deb http://security.debian.org/ stable/updates main contrib
deb http://http.us.debian.org/debian unstable main
Maybe I need a different repository?
 
Old 02-01-2006, 03:50 PM   #4
ingvildr
Member
 
Registered: Mar 2005
Location: England, South East
Distribution: Fedora
Posts: 358

Rep: Reputation: 30
you need main contrib and non-free on all those lines
 
Old 02-02-2006, 08:22 AM   #5
FWSquatch
Member
 
Registered: Jan 2006
Location: Fort Worth, TX
Distribution: Ubuntu, DSL
Posts: 47

Original Poster
Rep: Reputation: 15
OK, I put both of those things into my sources.list and I also tried running it with the -f in there. Same result. I have the .deb package of gnucash as well. I tried an install of it first and saw those massive dependency errors which is why I switched to the apt-get installation. Could that have caused a problem?
 
Old 02-02-2006, 08:30 AM   #6
deroB
Member
 
Registered: Dec 2005
Location: Sydney, Australia
Distribution: Arch Linux
Posts: 208

Rep: Reputation: 30
after adding non-free and contrib did you "apt-get update"?

also, if you downloaded the gnucash .deb from a testing/unstable repository this would(most likely) cause problems with dependancies.

Last edited by deroB; 02-02-2006 at 08:40 AM.
 
Old 02-02-2006, 09:50 AM   #7
esje
Member
 
Registered: Mar 2004
Location: Holland
Distribution: Debian Etch, Gentoo 2005.1/SUSE 10
Posts: 52

Rep: Reputation: 15
I'm only seeing one line with sarge, the rest is unstable. Unstable and especially contrib are known to have issues like these.

If you truly want to find out the exact package that is causing this, try to apt-get each of the conflicting packages one by one. Usually most of them are in conflict with one package and perhaps you can do something about that
 
Old 02-02-2006, 11:58 AM   #8
FWSquatch
Member
 
Registered: Jan 2006
Location: Fort Worth, TX
Distribution: Ubuntu, DSL
Posts: 47

Original Poster
Rep: Reputation: 15
I went ahead and did apt-get remove gnucash and it said that it freed up like 15 MB so I assume it cleaned out the bad install from the .deb. This time when I ran apt-get -f install gnucash, I got this
Code:
The following packages have unmet dependencies:
  gnucash: Depends: slib (>= 3a2-5) but it is not going to be installed
           Depends: guile-1.6-slib but it is not going to be installed
It's down to 2 unmet dependencies so it looks like we're getting somewhere. I'll have to wait until I get home to apt-get slib because it said it was a massive package and my boss doesn't like me blasting our bandwidth all the time . I'll let you know how it goes tomorrow. Thanks for all the help so far!
 
Old 02-02-2006, 07:42 PM   #9
FWSquatch
Member
 
Registered: Jan 2006
Location: Fort Worth, TX
Distribution: Ubuntu, DSL
Posts: 47

Original Poster
Rep: Reputation: 15
Woohoo! It works! Thanks for the help guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does apt-get has any dependencies Jzarecta Linux - Software 1 01-01-2006 04:15 PM
apt-get: don't resolve dependencies? merchtemeagle Debian 7 06-17-2005 02:11 PM
APT unresolved dependencies pingu Linux - Software 5 05-11-2005 09:47 AM
apt doesn't fix all dependencies :(? darkleaf Debian 4 07-25-2004 04:08 AM
apt-get remove and dependencies wrongman Debian 3 05-21-2004 03:57 PM


All times are GMT -5. The time now is 02:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration