LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Blogs > jjthomas
User Name
Password

Notices

Rate this Entry

Part 2, php and setting up Apache2

Posted 12-16-2008 at 08:35 AM by jjthomas
Updated 12-16-2008 at 10:34 PM by jjthomas

Create test.php:
Code:
<?php
phpinfo();
?>
Test with localhost/test.php.

Does not work. At this point I simply edit my /etc/httpd/httpd.conf file, after backing it up, of course.

My first item is to clean out all the comments. Since most of the work I do now is by an ssh shell (too many computers, not enough monitors) I can have one session open for editing and another session open for reading the comments, looking at man pages, etc. I also have a browser open pointing to my slackware box at http://192.168.0.2/manual.

The cause of the above error code can be found in the httpd.conf file, notibly:
Code:
# Uncomment the following line to enable PHP:
#
#Include /etc/httpd/mod_php.conf
Removing the # from the above Include line, *AND* /etc/rc.d/rc.httpd restart gets me my phpinfo.


========================================
At this point I decided to bump back to
slackware 12.1. Their are somethings I
want to do with Gnome SlackBuild. Once
GSB is out I will most likely revisit
Slackware 12.2
Views 1193 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 05:23 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration