LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 09-08-2013, 12:40 PM   #1
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Rep: Reputation: 1
PLEASE HELP:->For ROOT Mirroring in Solaris,See Full Information.


Hi Guys,

I need to do disk mirroring on Solaris 8 Server1 just like Server2 without damaging this Server. I have never done this before. So need your guidance/help.

In Simple words

I NEED TO CONVERT THIS

Code:
/proc                   -                       /proc   proc    -       no      -
fd                      -                       /dev/fd fd      -       no      -
swap                    -                       /tmp    tmpfs   -       yes     -
#
/dev/dsk/c1t0d0s3       -                       -       swap    -       no      -
/dev/dsk/c1t1d0s3       -                       -       swap    -       no      -
#
#
/dev/dsk/c1t0d0s0               /dev/rdsk/c1t0d0s0              /       ufs     1       no      logging
/dev/dsk/c1t0d0s1               /dev/rdsk/c1t0d0s1              /var    ufs     1       no      logging
/dev/dsk/c1t0d0s4               /dev/rdsk/c1t0d0s4              /u01    ufs     2       yes     logging
TO THIS:-

Code:
/proc			-			/proc	proc	-	no	-
fd			-			/dev/fd	fd	-	no	-
swap			-			/tmp	tmpfs	-	yes	-
#
/dev/dsk/c1t0d0s3	-			-	swap	-	no	-
/dev/dsk/c1t1d0s3	-			-	swap	-	no	-
#
/dev/md/dsk/d0		/dev/md/rdsk/d0		/	ufs	1	no	logging
/dev/md/dsk/d1		/dev/md/rdsk/d1		/var	ufs	1	no	logging
/dev/md/dsk/d2		/dev/md/rdsk/d2		/u01	ufs	2	yes	logging



IN OTHER WORDS, I NEED TO CONVERT THIS:-

Code:
bash-2.03$ metastat -p
metastat: system1: there are no existing databases


TO THIS:-

Code:
bash-2.03$ metastat -p
d0 -m d10 d20 1
d10 1 1 c1t0d0s0
d20 1 1 c1t1d0s0
d1 -m d11 d21 1
d11 1 1 c1t0d0s1
d21 1 1 c1t1d0s1
d2 -m d12 1
d12 1 1 c1t0d0s4
d22 1 1 c1t1d0s4
bash-2.03$
Server 1 FORMAT OUTPUT
Code:
bash-2.03$ sudo format
Password:
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <SUN36G cyl 24620 alt 2 hd 27 sec 107>  ROOTDSK
          /pci@1c,600000/scsi@2/sd@0,0
Specify disk (enter its number):

Server 2 FORMAT OUTPUT
Code:
bash-2.03$ sudo format
Password:
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <SUN36G cyl 24620 alt 2 hd 27 sec 107>  ROOTDSK
          /pci@1c,600000/scsi@2/sd@0,0
       1. c1t1d0 <SUN36G cyl 24620 alt 2 hd 27 sec 107>  ROOTMIRR
          /pci@1c,600000/scsi@2/sd@1,0
Specify disk (enter its number):
THIS IS SAME ON BOTH Server1 and Server2
Code:
partition> p
Volume:  ROOTDSK
Current partition table (original):
Total disk cylinders available: 24620 + 2 (reserved cylinders)

Part      Tag    Flag     Cylinders         Size            Blocks
  0       root    wm       0 -  5807        8.00GB    (5808/0/0)  16779312
  1        var    wm    5808 - 11615        8.00GB    (5808/0/0)  16779312
  2     backup    wm       0 - 24619       33.92GB    (24620/0/0) 71127180
  3       swap    wu   11616 - 14519        4.00GB    (2904/0/0)   8389656
  4 unassigned    wm   14520 - 24607       13.90GB    (10088/0/0) 29144232
  5 unassigned    wm       0                0         (0/0/0)            0
  6 unassigned    wm       0                0         (0/0/0)            0
  7 unassigned    wm   24608 - 24619       16.93MB    (12/0/0)       34668

partition>

I think we are yet to put new identical disk on Server1 as FORMAT command showing only one disk on Server1.

Would you please tell me the steps and their sequence to follow, AND WHAT I SHOULD NOT BE DOING TO DESTROY CURRENT DISKS ON Server1.

I need to do disks mirrorng of "/" , "/var" and "/u01"

How many reboots do I need to do this mirroring ?

I have been reading lots of google steps but not sure where to start in my case.

Please please guide , this is the most importance help from you talented guys.

Thanks in advance.

Last edited by manalisharmabe; 09-08-2013 at 12:57 PM.
 
Old 09-08-2013, 01:26 PM   #2
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
Hi Guys,
Below are the steps, can you please edit those as per my / /var and /u01 mirroring, IT WILL MOST USEFUL HELP FOR ME EVER.

Steps:-

SOLUTION

For this procedures, we will be mirroring all the slices of the local boot disk (c0t0d0) to another local disk (c1t0d0). You will have to make the appropriate changes for your system.

Reminders before you start:
- a slice is required for state database (also called replica or metadb)
- the local disks need to be identical and need to have the same partition layout
- for each partition on your boot disk (/, /usr, /var, /opt, /export/home, or any other partition you may have), you must create minimum of 3 new meta devices: one for the existing slice, one for the slice on the mirrored disk, and one for the SVM mirror



A) How to mirror the boot disk

A1) Prepare the partitions of the boot disk (c0t0d0) and the rootmirror disk (c1t0d0)


A1a) Be sure you have a slice 7 for state database on the boot disk.
To use slice 7 for replicas is a recommendation any other slice can be used. Furthermore slice 7 should have 32MB, but a size of 20MB should be the minimum.


A1b) Copy the partition table from boot disk (c0t0d0) to rootmirror disk (c1t0d0)

# prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c1t0d0s2
Be carefully with this command, write the vtoc to the right direction/disk!


A2) Initialize Solaris Volume Manager

# metadb -afc 3 c0t0d0s7 c1t0d0s7
Option -a for attach new replica device
Option -f is necessary if create the first replica on this system
Option -c 3 means to have 3 metadb copies on each disk's slice 7.


Verify success:

# metadb
For conceptual information about state database please refer to
Chapter 6 - State Database (Overview) in Solaris Volume Manager Administration Guide
http://docs.oracle.com/cd/E18752_01/...eplicas-1.html

A2a) Optional: Only if you have an even number of disks or controllers for local replicas consider adding the following to file /etc/system

set md:mirrored_root_flag=1
Why this flag? See
Document 1420334.1 Solaris Volume Manager (SVM): Understanding the Kernel Tunable Parameter "md:mirrored_root_flag"


A3) Initialize SVM root mirror (d0) for the root submirror partition (d1)

# metainit -f d1 1 1 c0t0d0s0
The option -f is required for active root


A3a) For rootmirror partition (d2)

# metainit d2 1 1 c1t0d0s0

A3b) Setup one-way mirror for the active root partition

# metainit d0 -m d1
Caution - Be sure to create a one-way mirror with the metainit command then attach the additional submirrors with the metattach command. When the metattach command is not used, no resynchronization operations occur. As a result, data could become corrupted when Solaris Volume Manager assumes that both sides of the mirror are identical and can be used interchangeably.

A4) Initialize SVM for all additional partitions of the boot disk (/var, /opt, …)
for swap mirror (d10):

# metainit -f d11 1 1 c0t0d0s1 (-f is required for active swap)
# metainit d12 1 1 c1t0d0s1
# metainit d10 -m d11
for /var mirror (d4):

# metainit -f d5 1 1 c0t0d0s4 (-f is required for active /var)
# metainit d6 1 1 c1t0d0s4
# metainit d4 -m d5
You can use this approach/example from /var for any other partition on the boot disk


A5) Modify /etc/vfstab for the boot disk
first make a copy for safety reasons

# cp /etc/vfstab /etc/vfstab.pre_svm
Change configuration for root in /etc/vfstab and /etc/system

# metaroot d0
This will change the entry for root in /etc/vfstab and put the entry 'rootdev:/pseudo/md@0:0,0,blk' to /etc/system

For additional partitions edit /etc/vfstab as follows:
for swap change from:

/dev/dsk/c0t0d0s1 - - swap - no -
to:
/dev/md/dsk/d10 - - swap - no -
for /var or any other partition on the boot disk change from:

/dev/dsk/c0t0d0s4 /dev/rdsk/c0t0d0s4 /var ufs 2 yes -
to:
/dev/md/dsk/d4 /dev/md/rdsk/d4 /var ufs 2 yes -
Be carefully by editing /etc/vfstab, because boot can fail due to errors in /etc/vtstab!


A6) Activate one-way SVM boot mirror disk

# lockfs -fa
# reboot
After the system has rebooted, you can verify that root and other slices are under SVM's control by running:

# df -k
# swap -l

A7) Attach second submirror to used SVM mirrors

# metattach d0 d2 ( root partition )
# metattach d10 d12 ( swap partition )
# metattach d4 d6 ( /var partition )
Verify the sync status of the SVM mirrors with

# metastat | grep sync
Once you have attached all the submirrors to the metamirrors, and all the syncing has completed, your boot disk is mirrored.


A8) Set the dump device to the correct device, using the command:

# dumpadm -d swap
Verify that the dump device is set correctly to swap with
# dumpadm


A9) Set up Open Boot Prom (OBP) environment by following
Document 1504573.1 How to setup OBP/NVRAM parameter for SPARC if system is mirrored with Solaris Volume Manager?
and try to boot from aliases

ok boot rootmirror
ok boot rootdisk

Last edited by manalisharmabe; 09-08-2013 at 01:28 PM.
 
Old 09-08-2013, 03:41 PM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,647

Rep: Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969
Quote:
Originally Posted by manalisharmabe View Post
Hi Guys,
Below are the steps, can you please edit those as per my / /var and /u01 mirroring, IT WILL MOST USEFUL HELP FOR ME EVER.
Please see the LQ Rules about posting homework questions. We are NOT going to do your homework/assignments for you. Post reported.
 
Old 09-08-2013, 04:32 PM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
@TBOne This is not homework but verbatim copy of Solaris documentation ( http://docs.oracle.com/cd/E19253-01/...jxl/index.html ).

@manalisharmabe Please cite your sources when you paste documents. I'd love to be wrong but I'm afraid what you are asking for is beyond the usual help people provide on Forums. In any case, if you have no reply and cannot hire someone with enough experience to complete what you look for without breaking your system, I would suggest to build a server with the same characteristics as the one you are describing, and experiment/train yourself with SVM. You might then be able to came back with simpler and reasonably answerable questions.
 
1 members found this post helpful.
Old 09-08-2013, 05:02 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,647

Rep: Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969
Quote:
Originally Posted by jlliagre View Post
@TBOne This is not homework but verbatim copy of Solaris documentation ( http://docs.oracle.com/cd/E19253-01/...jxl/index.html ).

@manalisharmabe Please cite your sources when you paste documents. I'd love to be wrong but I'm afraid what you are asking for is beyond the usual help people provide on Forums. In any case, if you have no reply and cannot hire someone with enough experience to complete what you look for without breaking your system, I would suggest to build a server with the same characteristics as the one you are describing, and experiment/train yourself with SVM. You might then be able to came back with simpler and reasonably answerable questions.
You are indeed correct, my apologies. From the wording of the 'question' (especially in post #2), it certainly SOUNDED like homework.
 
Old 09-09-2013, 03:51 AM   #6
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
Ok fine!

I understand.

so Please tell me how many hard disk should I create if I need to practice mirroring of / , /var and /u01 on vmware?

2 are enough?

Please guide me while practicing it.

Thanks a lot.
 
Old 09-09-2013, 04:46 AM   #7
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
One single disk (c1t0d0) is containing all of your file systems (/, /var and /u01). A second disk will be sufficient for mirroring them.

A similar server would be better than running Solaris on VMWare. As the latter is providing an x86 environment, there is no openboot prom so step 7 should be done a different way. There are undoubtedly other steps that differ and/or are more complex, due to the fact on x86, a disk as an extra partitioning leyer (fdisk). See http://docs.oracle.com/cd/E19253-01/...kde/index.html
 
Old 09-09-2013, 01:09 PM   #8
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
Why this step starts with

A1b) Copy the partition table from boot disk (c0t0d0) to rootmirror disk (c1t0d0)

# prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c1t0d0s2

Be carefully with this command, write the vtoc to the right direction/disk!
I mean why not

# prtvtoc /dev/rdsk/c0t0d0s1 | fmthard -s - /dev/rdsk/c1t0d0s1




This is what I have on my practise VM, i am going to mirror / , /var, /opt .

Code:
bash-3.00# format
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <DEFAULT cyl 2548 alt 2 hd 255 sec 63>
          /pci@0,0/pci15ad,1976@10/sd@0,0
       1. c1t1d0 <DEFAULT cyl 6525 alt 2 hd 255 sec 63>
          /pci@0,0/pci15ad,1976@10/sd@1,0
Specify disk (enter its number): 0
selecting c1t0d0
[disk formatted]
Warning: Current Disk has mounted partitions.
/dev/dsk/c1t0d0s0 is currently mounted on /. Please see umount(1M).
/dev/dsk/c1t0d0s1 is currently mounted on /var. Please see umount(1M).
/dev/dsk/c1t0d0s3 is currently used by swap. Please see swap(1M).
/dev/dsk/c1t0d0s5 is currently mounted on /opt. Please see umount(1M).
/dev/dsk/c1t0d0s7 is currently mounted on /export/home. Please see umount(1M).
And what exactly this means:-

A1a) Be sure you have a slice 7 for state database on the boot disk.
To use slice 7 for replicas is a recommendation any other slice can be used. Furthermore slice 7 should have 32MB, but a size of 20MB should be the minimum. Is this really important ?

Thanks.
 
Old 09-09-2013, 01:52 PM   #9
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
Second query:
Code:
partition> p
Current partition table (original):
Total disk cylinders available: 2548 + 2 (reserved cylinders)

Part      Tag    Flag     Cylinders        Size            Blocks
  0       root    wm      67 -  797        5.60GB    (731/0/0)  11743515
  1        var    wm     798 -  818      164.73MB    (21/0/0)     337365
  2     backup    wm       0 - 2547       19.52GB    (2548/0/0) 40933620
  3       swap    wu       1 -   66      517.72MB    (66/0/0)    1060290
  4 unassigned    wm       0               0         (0/0/0)           0
  5 unassigned    wm     819 -  909      713.83MB    (91/0/0)    1461915
  6 unassigned    wm       0               0         (0/0/0)           0
  7       home    wm     910 - 2547       12.55GB    (1638/0/0) 26314470
  8       boot    wu       0 -    0        7.84MB    (1/0/0)       16065
  9 unassigned    wm       0               0         (0/0/0)           0

partition>
I am not able to run this

Code:
bash-3.00# metadb -a -f -c 2 c1t0d0s6 c1t1d0s6
metadb: main: c1t0d0s6: device size 0 is too small for metadevice database replica
Now what should I do in ths case?

Please guide now, I have started my practice.
 
Old 09-09-2013, 02:07 PM   #10
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,647

Rep: Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969
Quote:
Originally Posted by manalisharmabe View Post
Why this step starts with
A1b) Copy the partition table from boot disk (c0t0d0) to rootmirror disk (c1t0d0)

# prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c1t0d0s2

Be carefully with this command, write the vtoc to the right direction/disk!
I mean why not

# prtvtoc /dev/rdsk/c0t0d0s1 | fmthard -s - /dev/rdsk/c1t0d0s1
Because if you looked at ANY of the easily-found Solaris documentation, you'd see that slice two in Solaris always represents the ENTIRE DISK. Since you're issuing a command to format it, you don't just want to format one slice, obviously.
Quote:
And what exactly this means:-

A1a) Be sure you have a slice 7 for state database on the boot disk.
To use slice 7 for replicas is a recommendation any other slice can be used. Furthermore slice 7 should have 32MB, but a size of 20MB should be the minimum. Is this really important ?
The Solaris manual is telling you this..if you don't believe it's important, then try not doing it, or ignoring that advice. And if you don't believe the manual, why are you asking someone else, who you won't believe either?
Quote:
Originally Posted by manalisharmabe
I am not able to run this
Code:
bash-3.00# metadb -a -f -c 2 c1t0d0s6 c1t1d0s6
metadb: main: c1t0d0s6: device size 0 is too small for metadevice database replica
Now what should I do in ths case?
It's telling you that the device you selected is too small...wouldn't it be obvious to make it BIGGER, or select a different device???
Quote:
Please guide now, I have started my practice.
This is a VOLUNTEER forum...do not tell people to hurry up and answer you, because YOU are in a hurry. That's fairly rude, especially since this is a 'practice' system, on a virtual machine, so YOU can learn. If you really were in a hurry to learn, you'd try researching things/doing things on your own first, which would give you the answers.
 
Old 09-09-2013, 02:16 PM   #11
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Originally Posted by manalisharmabe View Post
Why this step starts with

A1b) Copy the partition table from boot disk (c0t0d0) to rootmirror disk (c1t0d0)

# prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c1t0d0s2

Be carefully with this command, write the vtoc to the right direction/disk!
I mean why not

# prtvtoc /dev/rdsk/c0t0d0s1 | fmthard -s - /dev/rdsk/c1t0d0s1
Because s2 is the whole disk and is what to use to copy the vtoc. s1 is a single slice and doesn't start with a vtoc.

Beware that these commands use a source disk (c0t0d0) and a destination disk (c1t0d0) that are different than the one you have in your test platform (c1t0d0 as source and c1t1d0 as destination). Make sure you adapt the commands to your configuration !!


Quote:
This is what I have on my practise VM, i am going to mirror / , /var, /opt .

Code:
bash-3.00# format
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <DEFAULT cyl 2548 alt 2 hd 255 sec 63>
          /pci@0,0/pci15ad,1976@10/sd@0,0
       1. c1t1d0 <DEFAULT cyl 6525 alt 2 hd 255 sec 63>
          /pci@0,0/pci15ad,1976@10/sd@1,0
Specify disk (enter its number): 0
selecting c1t0d0
[disk formatted]
Warning: Current Disk has mounted partitions.
/dev/dsk/c1t0d0s0 is currently mounted on /. Please see umount(1M).
/dev/dsk/c1t0d0s1 is currently mounted on /var. Please see umount(1M).
/dev/dsk/c1t0d0s3 is currently used by swap. Please see swap(1M).
/dev/dsk/c1t0d0s5 is currently mounted on /opt. Please see umount(1M).
/dev/dsk/c1t0d0s7 is currently mounted on /export/home. Please see umount(1M).
And what exactly this means:-

A1a) Be sure you have a slice 7 for state database on the boot disk.
To use slice 7 for replicas is a recommendation any other slice can be used. Furthermore slice 7 should have 32MB, but a size of 20MB should be the minimum. Is this really important ?
Sure it is. You need an extra slice for the state database. This is a first hurdle you have to overcome.

I would try to slightly reduce the swap area and use the recovered space in slice 5 which is currently unused, i.e something like:

Code:
...
  3       swap    wu   11616 - 14489        4.00GB    (2874/0/0)   8302986
  4 unassigned    wm   14520 - 24607       13.90GB    (10088/0/0) 29144232
  5 unassigned    wm   14490 - 14519        0         (30/0/0)       86670
...
 
Old 09-10-2013, 09:54 AM   #12
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by TB0ne View Post
Because if you looked at ANY of the easily-found Solaris documentation, you'd see that slice two in Solaris always represents the ENTIRE DISK. Since you're issuing a command to format it, you don't just want to format one slice, obviously.

The Solaris manual is telling you this..if you don't believe it's important, then try not doing it, or ignoring that advice. And if you don't believe the manual, why are you asking someone else, who you won't believe either?

It's telling you that the device you selected is too small...wouldn't it be obvious to make it BIGGER, or select a different device???

This is a VOLUNTEER forum...do not tell people to hurry up and answer you, because YOU are in a hurry. That's fairly rude, especially since this is a 'practice' system, on a virtual machine, so YOU can learn. If you really were in a hurry to learn, you'd try researching things/doing things on your own first, which would give you the answers.

Thanks TBOne!
No I am not telling to hurry up any one. You misjudge that one.
Any way I remember what you say regarding my questions now. i have no one in my whole known circle area to discuss about Solaris, its only this Forum helping me.
 
Old 09-10-2013, 10:03 AM   #13
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,647

Rep: Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969Reputation: 7969
Quote:
Originally Posted by manalisharmabe View Post
Thanks TBOne!
No I am not telling to hurry up any one. You misjudge that one.
Sorry, when you say "Please guide now, I have started my practice. ", you're telling people to give you answers NOW, aren't you?
Quote:
Any way I remember what you say regarding my questions now. i have no one in my whole known circle area to discuss about Solaris, its only this Forum helping me.
...except, very obviously, the books and manuals you have, which tell you things. This is a practice VM server, for you to LEARN on. You learn by DOING. Agonizing over each step you take on a practice server and questioning the manuals will not teach you ANYTHING, and will only make your learning process take longer.

FOLLOW the instructions...RESEARCH the things first before asking questions. Putting "why is slice 2 on a solaris disk special" into Google would have gotten you that answer easily. We are happy to help you with problems, but you're not HAVING a problem...you're learning. Again, study the guides, follow the instructions, and research on your own. If you're absolutely stuck, post back with what you're not clear about.

Last edited by TB0ne; 09-10-2013 at 10:30 AM.
 
Old 09-10-2013, 10:21 AM   #14
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by TB0ne View Post
Putting "why is slice 2 on a solaris disk special" into Google would have gotten you that answer easily.
I agree!
 
Old 09-10-2013, 10:44 AM   #15
manalisharmabe
Member
 
Registered: Dec 2010
Posts: 242

Original Poster
Rep: Reputation: 1
I have some queries:-

Code:
/proc                   -                       /proc   proc    -       no      -
fd                      -                       /dev/fd fd      -       no      -
swap                    -                       /tmp    tmpfs   -       yes     -
#
/dev/dsk/c1t0d0s3       -                       -       swap    -       no      -
/dev/dsk/c1t1d0s3       -                       -       swap    -       no      -
#
#
/dev/dsk/c1t0d0s0               /dev/rdsk/c1t0d0s0              /       ufs     1       no      logging
/dev/dsk/c1t0d0s1               /dev/rdsk/c1t0d0s1              /var    ufs     1       no      logging
/dev/dsk/c1t0d0s4               /dev/rdsk/c1t0d0s4              /u01    ufs     2       yes     logging
bash-2.03$
Question 1:-

Why swap is shown here 2 times , I mean c1t0d0s3 and c1t1d0s3 ? Is it mirrored ? Well, I have only one disk so I don't think , It's mirrored.




Code:
ash-2.03$ sudo format
Password:
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <SUN36G cyl 24620 alt 2 hd 27 sec 107>  ROOTDSK
          /pci@1c,600000/scsi@2/sd@0,0
       1. c1t1d0 <SUN36G cyl 24620 alt 2 hd 27 sec 107>  ROOTMIRR
          /pci@1c,600000/scsi@2/sd@1,0
Specify disk (enter its number):

In above information what exactly indicates that there are two disks in system?

is it

1. c1t1d0 <SUN36G cyl 24620 alt 2 hd 27 sec 107> ROOTMIRR
/pci@1c,600000/scsi@2/sd@1,0

t1 here or something else, please excuse me for asking this, but I am really confused about the same.

Thanks.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Root disk mirroring rmerrird Linux - Newbie 1 10-23-2011 03:23 PM
Root mirroring in SUSE 10.1 sri243 Linux - Server 5 12-29-2010 10:23 AM
Root mirroring on Redhat ZAMO Linux - Server 4 01-22-2010 09:14 AM
LXer: DiskSuite/VolumeManager or Zpool Mirroring On Solaris: Pros and Cons LXer Syndicated Linux News 0 04-28-2009 03:30 PM
Solaris disk mirroring neil Solaris / OpenSolaris 4 09-25-2006 07:46 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 11:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration